Migration paths

An overview of the migration paths between different IBM® MQ versions. For some IBM MQ for z/OS® migration paths, you can revert to the version you were using prior to migration. For IBM MQ for Multiplatforms, you cannot easily revert to a previous version.

Note: Before each new version of the product is released, it is tested for migration from earlier versions that are in support at that time. Direct migration from a version that is out of support might also work, but is neither tested nor supported. Therefore, to migrate to the latest version from a version that is out of support, you should first migrate to an interim version that was released before the earlier version went out of support.
[UNIX, Linux, Windows, IBM i]

Migration paths: IBM MQ for Multiplatforms

You can migrate from IBM MQ 8.0 or later direct to IBM MQ 9.1. To migrate from IBM WebSphere® MQ 7.0.1, you must first migrate to IBM MQ 8.0. To migrate from IBM WebSphere MQ 7.1 or IBM WebSphere MQ 7.5, you must first migrate to IBM MQ 8.0 or IBM MQ 9.0.

For IBM MQ for UNIX, Linux®, and Windows, Side-by-side and Multi-stage migration were introduced in IBM WebSphere MQ 7.1, and can be used to migrate from IBM WebSphere MQ 7.0.1 Fix Pack 6 or later. Before you use either of these migration methods to migrate from IBM WebSphere MQ 7.0.1, check that your IBM WebSphere MQ 7.0.1 installation is at Fix Pack 6 or later.

Table 1. Migration paths: IBM MQ for Multiplatforms
Migration from To IBM MQ 9.1 To IBM MQ 9.0 To IBM MQ 8.0 To IBM WebSphere MQ 7.5 To IBM WebSphere MQ 7.1
IBM MQ 9.0 Yes - - - -
IBM MQ 8.0 Yes Yes - - -
IBM WebSphere MQ 7.5 No Yes Yes - -
IBM WebSphere MQ 7.1 No Yes Yes Yes -
IBM WebSphere MQ 7.0.1 No No Yes Yes Yes

For IBM MQ for Multiplatforms, you cannot easily revert to a previous version. However, if a queue manager has not been started, you can uninstall the current version and reinstall a different version of IBM MQ. It does not matter what versions of IBM MQ are installed between when a queue manager was last started and when it is next started.

[z/OS]

Migration paths: IBM MQ for z/OS

You can migrate from IBM MQ 8.0 or later direct to IBM MQ 9.1.

If you are migrating to IBM MQ 9.1 from IBM WebSphere MQ 7.1, you must first migrate to IBM MQ 8.0 or IBM MQ 9.0 and restart each queue manager with OPMODE=(NEWFUNC,800) or OPMODE=(NEWFUNC,900). For more information, see Migrating from earlier unsupported releases of IBM MQ for z/OS.

Table 2. Migration paths: IBM MQ for z/OS
Migration from To IBM MQ 9.1 To IBM MQ 9.0 To IBM MQ 8.0
IBM MQ 9.0 Yes - -
IBM MQ 8.0 Yes Yes -
IBM WebSphere MQ 7.1 No Yes Yes

To revert to a previous version, see Reverting a queue manager to a previous version on z/OS.

Detailed migration information

For migrating to an IBM MQ version other than the current version, see the documentation for the target version:

For out of service IBM MQ versions, where the documentation is no longer available in the online IBM Documentation, you can instead download the documentation for offline use. See Documentation for older versions of IBM MQ.