Release notes - IBM i2 Enterprise Insight Analysis 2.3.1

IBM® i2® Enterprise Insight Analysis 2.3.1 is available.

Contents

Description

Enterprise Insight Analysis is an open, interoperable, extendable, and scalable solution that enables organizations to turn overwhelming and disparate data into actionable insight and intelligence, in near real time.

Enterprise Insight Analysis helps analysts and investigators develop a comprehensive understanding of the threat landscape to identify vulnerabilities and disrupt threats. The combination of machine-led analytics and human-led analysis capabilities helps to find hidden connections and critical patterns that are buried in internal, external, and open source data.

Separately licensed add-on components are available to extend the capabilities of IBM i2 Enterprise Insight Analysis in key areas:
Collaborate
The Collaborate Add On provides access to a core subset of capabilities that are delivered through a lightweight browser-based application. These capabilities can help users from outside the traditional intelligence unit, including researchers, investigators, and front-line personnel, to work alongside the analysts to collect supportive information.
Recommendation Engine
The Recommendation Engine Add On enables analysts and investigators to determine when multiple identities are the same. The add-on offers an automated identity resolution and recommendation engine that proactively alerts analysts when new information is available, and when data points are altered, strengthened, or resolved.
Investigate
The Investigate Add On enables investigators to quickly visualize and explore data in a web browser.

Announcements

See the IBM i2 Intelligence Analysis product portfolio for a statement of general direction.

Enterprise Insight Analysis 2.3 does not support deployments of i2 Analyze that contain the Information Store deployed to use the Onyx services. All other combinations of deployment patterns are unaffected. If you have a deployment that includes the Information Store with Onyx services, you cannot upgrade to Enterprise Insight Analysis 2.3.

Note: If you are using IBM Db2® version 10.5, you must install fix pack 10 or later.

Enterprise Insight Analysis only supports the operating systems and supported software listed in the detailed system requirements. Ensure that existing deployments are upgraded to currently supported versions of all the software required. For more information about the software supported for the current release, see System Requirements.

Release highlights

The following new and updated features are available:

IBM i2 Enterprise Insight Analysis
The Enterprise Insight Analysis Onyx services have been removed, this means that the separate Enterprise Insight Analysis installer is no longer required, and the Analyst's Notebook Premium Onyx Extensions have been removed. When purchasing Enterprise Insight Analysis, you will be provided with Enterprise Insight Analysis specific licensing, and installation media for bundled products.
IBM i2 Analyst's Notebook
  • Undo Stack: Chart navigation actions are no longer stored as undo steps.

  • Bar chart and histograms: A 'Fit Selection to Window' option is available. When enabled, the chart window zooms to fit the items in the current bar selection.

  • Product Access Management: The license manager has been upgraded to support Windows Server 2019.
    Important: The product access management feature is compatible with earlier supported versions of IBM i2 applications, but is not always compatible with later versions. To ensure that your permits are handled correctly, upgrade your License Manager before you upgrade your applications.
The following APARs are fixed in this release of Analyst's Notebook.
  • Analyst’s Notebook® allows Windows to resize the user interface when using text sizes greater than 100%. [APAR PO06685]
  • The blank identity field in the import specification remains blank when set rather than creating an entity with a blank identity. [APAR PO08542]
  • i2 Esri Maps no longer crashes when a gallery item is double-clicked. [APAR PO08480]
IBM i2 Analyst's Notebook Premium - Opal connector
  • Record matching on import: Use system rules in import specifications to match records in the incoming data to records in the Information Store, and on the chart.

  • Get matches: Find out if chart entity records match with records in the Information Store.

  • Record matching from external search: Use systems rules to match records from external searches to analyst governed records in the Information Store, and on the chart.

  • Source references: Describe the source information related to i2 Analyze records using links, images, and text.

  • Record identifiers: Make distinct records easy to share and locate with a unique identifier.

  • i2 Maps: i2 Analyze records with geospatial properties can be visualized on the i2 Maps surface.

  • Geospatial Visual Query: Define the boundary of a search area in Visual Query, either by drawing a shape or using GeoJSON data.

  • Get paths: Search the Information Store for paths between lead records and copy the results to the chart.

The following APARs are fixed in this release of Analyst's Notebook Premium.

  • The property 'length' of null error message in the Record Inspector is resolved. [APAR PO08310]
IBM i2 Analyze
  • Web client:
    • A summary view of each record is available including any links of specific types.
    • Source reference information: Source reference information can now be added to records.
    • Image support: Records can now support image URLs, allowing images associated with Information Store records to be displayed on chart surfaces.
  • Deployment:
    • Information Store matching service: Enhanced tooling provided to help create system wide record matching rules and manage potential matches.
    • Performance: Tooling for performance measurement and sizing guidance
    • Mapping configuration: Mapping configuration options, such as the locations of mapping tiles, and coordinate reference systems can be added.
    • Schema ID validation: Item Type IDs stored in the schema are now validated to ensure only alphanumeric characters ([a-z], [A-Z], [0-9]) are used.

The following APARs are fixed in this release of i2 Analyze.

  • The fix for APAR PO08502 limits the lengths of strings returned from external sources, to improve memory and performance when selecting entities.
IBM i2 iBase
  • GIS Interfaces: iBase can now support Esri ArcGIS version 10.6.
  • Analyst's Notebook plug-in: You can select the following update options.
    • Update chart items that contain iBase records with changes that come from the iBase database.
    • Automate an update to chart items that contain iBase records to occur after you log in to the iBase database.
  • Browse performance: The response time is significantly faster response time when you click Browse to display records.
  • An update provides increased security.
The following APARS are fixed in this release.
  • The fixes for APARs PO07589 and PO07590 resolve a number of issues. When you use iBase Designer to modify fields on an existing entity or link type, with audit history switched on, you no longer see error messages when you modify fields in the following ways.
    • Select a field type, then change the field type and click OK.
    • Put a period in the field name, select the Mandatory check box, and click OK.
  • The fix for APAR PO07745 corrects the IBM Knowledge Center information about audit levels so that it accurately reflects the actions that get audited in the product. For more information, see the IBM Knowledge Center Controlling What is Audited.

Virtualization support

The Intelligence Analysis products in Enterprise Insight Analysis are supported on hardware virtualization environments that run any of the operating systems that are listed in the detailed system requirements. When you run in a virtual environment, any issues that can be replicated by IBM in a supported operating system are addressed by using the standard IBM support policy.

Known problems

The most up-to-date source for known problems in Enterprise Insight Analysis is the HTML version of these release notes at http://www.ibm.com/support/knowledgecenter/SSXVXZ_2.3.1/com.ibm.i2.releasenotes.doc/eia.html.

At the time of publication, the following problems were known:

Analyst's Notebook Premium - Opal connector
Table 1. Analyst's Notebook Premium - Opal connector
Problem Description
Import specifications ignore the Entity representation type Import specifications will import all entities as icons, any import specifications that contain different representation types such as theme lines will import the entities, but they will display as icons.
Values specified in Link Occurrence Options are ignored If you set Link Occurrence Options values in Import Details, they are ignored when the import runs.
Selected Charting Scheme is not updated When a change to the charting scheme is applied and then that change is undone, the styling changes are reversed on the chart surface, but the Charting Scheme selection remains unchanged.
Search results cannot be added to a chart If you attempt to add the results of a search to a chart when the search results are no longer cached on the server, you see the following message: Failed to copy records to the chart. To copy the results, run the search again.
System governed records are not used in matching when copying to the chart from external searches Analyst governed records are matched with records copied from an external search. Get Matches can be used to copy system governed records to the chart.
Long-running operations that access the Information Store timeout If operations that involve the Information Store are unable to complete, one of the following error messages might be displayed:
  • Error in web response
  • Unexpected error: Unable to execute javascript at this time
Language support The different components of Enterprise Insight Analysis are translated into different languages groups based on demand. Depending on the deployment pattern in use, and the language that is selected, some components might display in the default language (US English).
Zoom level set to greater than 100% might cause blurring If the operating system zoom level is set to more than 100%, some of the text and symbols in Analyst's Notebook Premium might appear blurred.
Opal charts are not compatible with earlier versions Charts created in Analyst's Notebook Premium version 9.2.1 cannot be used in earlier versions. If charts created in earlier versions are opened in version 9.2.1, the charts are upgraded.
Pan and zoom does not automatically reset on map When several address entities are added to the map, the zoom sets to the most recently added entity and does not adjust to display the other entities.
Chromium Embedded Framework (CEF) version incompatibility can cause errors in third party plug-ins. The CEF component can only be initialized once within an application process. Third party plug-ins that depend on a different version to the version running within the Analyst's Notebook Premium process might experience errors. To avoid these errors, use the same version of CEF contained in Analyst’s Notebook Premium and check whether CEF is already running before starting your plug-in.
Analyze web client
Table 2. Analyze web client
Problem Description
Keyboard navigation does not work within visualizations Attempting to navigate around records that contain visualizations, the visualization cannot be accessed using the tab key. If the tab key is pressed when an item in the visualization is selected, focus is removed from the visualization.
Blocks of text are clipped when printing in Firefox If large amounts of text (more than will fit on a printed page) are entered into a record property, note, or source reference, the text will be clipped if the record is printed.
Using reserved terms in the highlight-queries-configuration.xml file can cause issues when results are expanded in the Show More view. Reserved terms should not be used as the id value in the highlight-queries-configuration.xml for example:
<highlightQuery title="Suspects">
    <path>
      <segments>
        <segment>
          <Listed_In-I />
          <Person-I>
            <exportFields>
               <propertyField propertyType="last_name-P" aggregatingFunction="MAX" id="term" />
            </exportFields>
           </Person-I>
         </segment>
       </segments>
     </path>
     <sortBy>
       <field id="term" order="ASC" />
     </sortBy>
 </highlightQuery>
If reserved terms are added to the id value, the system will try and interpret them as system specific commands causing unexpected behavior. The following list of reserved terms should not be used as values for id in thehighlight-queries-configuration.xml file:
    version
    id
    full_text
    full_text_reversed
    item_type_id
    link_from_id
    link_to_id
    is_link
    link_direction
    merged_record_info
    record_version
    data_source_created
    data_source_modified
    data_source_seen
    data_source_name
    data_store_created
    data_store_modified
    data_store_seen
    record_first_uploaded_by
    record_last_uploaded_by
    record_id
    text_facet
    source_references_id
    source_references_ref_type
    source_references_source_name
    source_references_location
    source_references_image
    source_references_description
    source_references_is_modifiable
Information Store
Table 3. Information Store
Problem Description
Some non-English characters are replaced in the Information Store table and column names.

This replacement of characters can change the names that you expect to see, when you are completing operations such as ingesting data. For example, the German language esszett character (written 'ß') is replaced by an underscore in Information Store table and column names.

Origin identifiers changed between versions In i2 Analyze version 4.1.2, backslash (\) characters are removed from origin identifiers when they are created. In later versions, backslash characters are not removed when origin identifiers are created.

If the information that is used to create your origin identifiers contains backslashes, records that you ingest are identified as new records rather than updates to existing records. To update existing data, you must clear any data from your system and reingest the data.

Information Store does not support Read Cloaked The security classification Read Cloaked is not supported in the Information Store.
i2 Analyze Opal services
Table 4. i2 Analyze - Opal services
Problem Description
Existing Solr collections are not encrypted automatically when SSL is enabled. Secure Socket Layer (SSL) encryption can be applied to a deployment at any time, but existing Solr collections are not encrypted by default. In order to use SSL you must recreate your Solr Collections, or modify the Solr configuration manually to enable decryption. For deployments that contain large amounts of data, contact IBM support.
Visual Query timeout for Geospatial searches of large datasets Depending on the scale and geographic distribution of geospatial data in the system, Visual Query searches can return results slowly, or even timeout. To improve the performance of Visual Queries that use geospatial information, you can create geospatial indexes manually.
Messages when Solr Starts or stops If you are using third-party tools that contain a find executable, you might see messages that indicate files cannot be found:
find: unable to access "TCP ":
The system cannot find the file specified.
find: unable to access ":0 ":
The system cannot find the file specified.
find: unable to access ":8983 ":
The system cannot find the file specified.
These messages might indicate that the system variable that defines the environment path has the path to the third-party tool before the system files. Verify that the Path= system variable contains paths that point to the third-party command line tools added after the paths that point to the system folders.
Searches can stop running after i2 Analyze is restarted If the WebSphere® Liberty Application Server is restarted while searches are running, the search might time out. To prevent this issue, ensure that the HTTP server is restarted when you restart the Application Server.
Analyst's Notebook
Table 5. Analyst's Notebook
Problem Description
Unable to use Google Earth to map chart items
One of the following error messages might be displayed when you try to map chart items to Google Earth:
  • Unhandled exception has occurred in a component in your application. If you click Continue, the application will ignore this error and attempt to continue.
  • Google Earth failed to initialize. Please check that Google Earth version 4.2 or higher is installed, it is configured correctly and that your connection to the Google Earth server is working.
These errors can result if:
  • The Google Earth installation has been corrupted.
  • Google Earth is not registered correctly.
  • The version of Google Earth is not compatible with Analyst's Notebook.
Refer to the following technote for details of potential resolutions:
  • Repair the Google Earth installation.
  • Register the Google Earth executable file.
  • Install a different version.

IBM i2 Analyst's Notebook crashes when trying to map chart items to Google Earth

Embedded help files cannot render italic text in Arabic When you view the embedded help in Arabic on systems that use Windows 10, any text that set to italics does not render correctly.
Opening embedded help files causes Analyst's Notebook to stop responding If you have i2 Esri Maps installed, and you attempt to search the embedded help for a connected product such as IBM i2 iBase, Analyst's Notebook can stop responding. If this problem occurs, close Analyst's Notebook and restart it.
In environments that connect to multiple data sources, Infotips can stop displaying When Analyst's Notebook is connected to two or more data sources and i2 Esri Maps is installed and enabled, Infotips can stop displaying. If this problem occurs, close one of the connections.
Import specifications that use Hierarchy layout are not always compatible If you create an import specification that uses the Hierarchy layout in Analyst's Notebook version 9.0.1 or earlier, or version 9.0.5 or later, an error occurs if you try to edit that import specification by using Analyst's Notebook versions 9.0.2, 9.0.3, or 9.0.4.
An entity type's icon is not shown after you delete a picture from an event frame Deleting a picture from an event frame does not revert to showing the entity type's icon. To show the entity type's icon, right-click Display > Type Icon, or select Type Icon on the Display page of the Edit Event Frame window.
Displaying OLE objects Analyst's Notebook can display .bmp, .jpeg, and .gif OLE objects without the requirement for a third-party OLE server. However, the following limitations apply:
  • When you drag files from a browser, an Unexpected file format error message might be displayed.
  • When you drag an unrecognized file type onto the chart the error message Unexpected file format is displayed, and subsequent drag operations to the chart from Windows Explorer might fail.
To avoid these problems, select the Home tab, and then, in the Insert Entities group, insert the image by selecting OLE Object > Picture. Use the Edit Item Properties window to add a picture to an entity representation.
Performance problems when you disconnect from the network When you disconnect from the network, but a network printer remains set as the default printer, switching between tabs in Analyst's Notebook can take several seconds. When you disconnect from a network, change the default printer to a local printer. Then, in Analyst's Notebook select a local printer.
Note: The following registry key value causes Analyst's Notebook to ignore the user selected printer, and can be deleted: HKEY_CURRENT_USER\Software\i2\Default\Printer.
Potentially unable to save entire charts when you Save as Picture If your computer has insufficient memory, you might be unable to save large charts when you select File > Save as > Save Entire Chart as Picture. To avoid this problem, save the chart in sections by selecting File > Save As > Save Current View as Picture, or save the chart in PDF format by selecting File > Print > Print to PDF.
Untranslated system attribute names are displayed when you search for attribute classes In a non-English version of Analyst's Notebook, when you search for attribute classes in the Insert from Palette task pane, the names of system attributes are not displayed in their translated form.
Unable to expand items after their data records are purged If you purge data records from items that are added to the chart from data sources, any attempt to expand these items results in an error.
Colors window is not translated The Colors window always contains US English text, regardless of the user's settings.
In Arabic and Hebrew, black and white application windows might appear when you use the Copy to New Association Chart feature When you run in Arabic or Hebrew, selecting the Copy to New Association Chart feature might result in a black and then white application window, when the layouts are applied. A "Windows not responding" message might also appear. However, Analyst's Notebook then recovers and continues normally.
i2 Esri Maps not loading If the i2 Esri plug-in does not load correctly, ensure that the Microsoft Visual C++ 2015 runtime is installed.
Display issues with drawings that cross the International Date Line The following problems might occur when a drawing on an i2 Esri Map crosses the International Date Line:
  • Duplicate labels might appear for the drawing.
  • When you edit the drawing, the edit box might be positioned away from the drawing.
  • A line might appear drawn through the shape.
  • When you try to export the drawing through the API, it is exported as two shapes.
Labels not refreshing on the map In i2 Esri Maps, if you replace a textual label on a drawing with a blank label, parts of the original label might remain on the map.
Large circles do not render correctly In i2 Esri Maps, drawing a large circle or ellipse that overlaps itself causes the shape to be drawn incorrectly.
Problems drawing polygons or polylines on some maps In i2 Esri Maps, you might encounter instability when you are drawing a polygon or polyline on some map types, for example British National Grid. Problems can occur when you select and move the grab handles that lie between the vertices of the polygon or polyline.
Using i2 Esri Maps in a virtual environment takes longer to render the graphics layer Using i2 Esri Maps in a virtual environment requires access to a physical graphics card that supports DirectX 11. Many virtualization solutions enable access to physical graphics cards on a server and support client access through RDP or their proprietary container. However, if a remote desktop is used to access a virtual machine, i2 Esri Maps uses only WARP (software rendering). When i2 Esri Maps uses WARP, it can take longer to render the graphics layer.

In some configurations, reverting to WARP is unsupported. For example, if you are using Windows 7 in a virtual environment. In these situations, the map window displays an ArcGISRuntimeException error and you are unable to use i2 Esri Maps.

Analyst's Notebook Premium - Onyx connector
Table 6. Analyst's Notebook Premium - Onyx connector
Problem Description
Language support

The different components of Enterprise Insight Analysis are translated into different languages groups based on demand. Depending on the deployment pattern in use, and the language that is selected, some components might display in the default language (US English).

Note: Note: Connector Creator is English-only.
Silverlight installation requires a restart afterward Silverlight must be installed to use the Onyx connector. After you install Silverlight, you must restart your computer before you start Analyst's Notebook Premium.
Some user names and folder names prevent connection to the Analysis Repository If your Windows user name or the name of your folder within C:\Users contains non-ASCII characters, then Analyst's Notebook Premium cannot connect to the Analysis Repository. When you start Analyst's Notebook Premium, select a schema, and then click OK, the following error message is displayed: Error connecting to the Analysis Repository.
The volume of data that can be returned from a data access on-demand data source is limited Running Expand or Get Context on a data access on-demand data source is unable to return large volumes of data to Analyst's Notebook Premium or the Intelligence Portal. Users might encounter a memory limit error due to the number of items (or the number of properties on items) when the application returns the results of these commands.

For more information about changing the maximum number of items that can be returned, see Limitation on Expand, Show Context and Get Context via data access on-demand.

The strength of links is not transferred from connected iBase databases When links are retrieved from an iBase database by using the iBase connector, the strength information that is associated with those links is not transferred. The links are displayed as solid lines.
Bidirectional text can be displayed incorrectly Although i2 Analyze supports right-to-left text, the following problems can occur in environments that use right-to-left text:
  • Visual Query search conditions do not display correctly when you are using right-to-left text.
  • Negative numbers display incorrectly in edit mode.
  • Some tooltips for left-to-right text in a right-to-left enabled system are displayed with the text mirrored.
Entering some combinations of multibyte Unicode characters displays an incorrect glyph Certain combinations of multibyte Unicode characters display as a square in the Intelligence Portal, rather than the expected glyph.
Japanese text uses Chinese font for punctuation Certain Japanese punctuation characters are displayed as the equivalent Chinese characters when you enter Japanese text.
The Intelligence Portal does not highlight information when the Starts With operator is used If a column filter or a search condition uses the Starts With operator, i2 Analyze does not supply highlighting information.
Potential latency when you attach documents A delay might occur between creating items with documents attached and being able to download the documents. When you run in a group Analysis Repository environment, if you make a document download request before the document is available, an error is displayed.
Double-byte characters cannot be used to input date and time values i2 Analyze cannot accept double-byte characters as input into date properties and time properties. More specifically, you cannot use the wider representations of western numbers that double-byte character sets include.
The Intelligence Portal does not support non-Gregorian calendars In locales with non-Gregorian default calendars, a Gregorian calendar is used instead for entry and display of dates.
Item label appears to be updated after edits are canceled If you change an item that if saved would cause the item label to change, and then click Cancel to discard your changes, the item label changes to include the canceled edits. The data is not saved and the label change is not persisted. If you close the tab and then reopen the item, the original label is displayed.
Search types vary in non-English-language regions Some limitations exist with exact and fuzzy matching in non-English-language regions.
  • Western European script (Brazilian, French, German, Italian, Spanish) and Cyrillic scripts (Russian):

    Exact matching produces successful results. Matches that are based on synonyms or similar spellings might return less useful results. Evaluate the results for similar spelling and synonym matching behaviors, and if necessary, you can modify the search configuration for a language during deployment.

  • Semitic and East Asian scripts (Arabic, Hebrew, Japanese, Korean, Simplified Chinese, Traditional Chinese):

    Exact matching produces mixed results. The indexing process is heavily reliant on word boundaries (for example, a space). As these scripts do not reflect the same word boundaries as western scripts, exact matching can provide weak or no results for text fragments. However, exact matching works in whole character sequences, such as the equivalent to English sentences. Matches based on synonyms can return less useful results than in English. Matches based on similar spellings are unlikely to return useful results. You can modify the search configuration for a language during deployment.

If connected to a Group Analysis Repository and you drag items from a data access source palette to a chart, an error message is displayed If you are connected to a DAOD source that is read-only, if you try to drag items from data access source palette, an error message is displayed. You must use the Analysis Repository palette or Data Sources pane to create items in an Analysis Repository.
Chart names are ignored when charts are created in the Analysis Repository If you create a chart in the Analysis Repository, then save it and open it in Analyst's Notebook, the chart opens but the chart name is ignored. The default chart name is used. When any changes are made to that chart, the chart is treated as a standard Analyst's Notebook chart and the changes are not automatically saved back into the Analysis Repository. When you close and reopen Analyst's Notebook, a message might be displayed indicating that a temporary chart cannot be found. To avoid this problem, create your chart in Analyst's Notebook and upload it to the Analysis Repository. When you next Save the chart, any changes you made to it are automatically saved back into the Analysis Repository.
New custom icons that have a shading color set are not saved in the chart When you create a new custom icon and set a shading color, it is not saved as part of the chart. If you remove the image file from the custom icons folder or open the chart on a different computer, the icon is displayed as a circle.
Items that contain a very large amount of data can affect performance If the Analysis Repository contains items that have many cards, or many properties on each card:
  • Performance might be affected.
  • Information can be harder to find.
For data that produces more than a hundred properties on a single card, or hundreds of cards on a single item, consider changing the structure of the data.
Help window does not always appear when opened from the Data Sources task pane When the Data Sources task pane is docked, and you click the Help button, the Help window might disappear and reappear when you click it. To close the Help window, undock the Data Sources task pane first. After you close the Help window, you cannot invoke it again from the Data Sources task pane when the task pane is undocked. To avoid these problems, open the Help from the Data Sources area of the Home tab of the ribbon. The Help window opens with the "Working with Analyst's Notebook Premium" topic open.
Analyst's Notebook Premium might not connect to the Local Analysis Repository automatically The Local Analysis Repository entry might appear in the Data Sources task pane, but Analyst's Notebook Premium might not connect to it automatically. To correct the problem, close and restart Analyst's Notebook Premium.
Anti-virus software can affect performance To improve the performance of the Local Analysis Repository, ensure that anti-virus check software does not monitor the Local Analysis Repository folder: %LOCALAPPDATA%\IBM i2\Local Analysis Repository.
Unable to use Analyst's Notebook Premium in a Citrix or Remote Desktop Services environment If you are using Citrix or Remote Desktop Services with Admin permissions (or SeCreateGlobalPrivilege set), multiple users cannot use the Analyst's Notebook Premium Onyx connector at the same time.
i2 Analyze Onyx services
Table 7. i2 Analyze - Onyx services
Problem Description
Unable to create database tables at deployment When you run deploy or deployExample, if your Db2 database is not configured correctly you might see the following message:
Database ds/WriteStore-write1
 is at version CleanInstall. 
Upgrading to latest version 4.1.
If you see this message, ensure that the database is correctly configured in topology.xml, that the database is running, and can be accessed by using the details that you supplied.
iBase connector does not support i2 Analyze schemas that contain duplicate type names If your deployment of iBase connector is based on an existing deployment of i2 Analyze, then the i2 Analyze schema must not define entity and link types that have matching names. If this situation arises, the toolkit appears to generate the iBase schema correctly, but iBase is unable to create a database from it.

To resolve this issue, rename the entity type or the link type in the i2 schema.

In iBase connector, some data types in the schema are incorrectly transformed In the i2 Analyze schema that is created from an iBase schema, any Multi-Line Text (Append Only) fields are incorrectly transformed to single-line data types. If required, after the schema is created, you can manually change the field types to Multi-Line Text.
Multiple iBase connectors are not supported i2 Analyze supports a single iBase connector that connects to a single iBase database. However, other data access on-demand connectors can still be installed, and Connector Creator supports connections to multiple databases.
The downloaded Connector Creator configuration file can be invalid In some circumstances, a Connector Creator configuration file that you download can be different from the file that was originally uploaded to the server.
  • If a <resource> element in the original configuration file did not have any child <queries> elements, the downloaded version contains an invalid <queries/> element.
  • If a <parameter> element within a query in the configuration file did not have any child <select> elements, the downloaded version contains an invalid <select/> element.
Before you reupload a previously downloaded Connector Creator configuration file, search for and remove any instances of <queries/> and <select/> elements.
Intelligence Portal
Table 8. Intelligence Portal
Problem Description
The volume of data that can be returned from a data access on-demand data source is limited Running Expand or Get Context on a data access on-demand data source is unable to return large volumes of data to Analyst's Notebook Premium or the Intelligence Portal. Users might encounter a memory limit error due to the number of items (or the number of properties on items) when the application returns the results of these commands.

For more information about changing the maximum number of items that can be returned, see Limitation on Expand, Show Context and Get Context via data access on-demand.

The strength of links is not transferred from connected iBase databases When links are retrieved from an iBase database by using the iBase connector, the strength information that is associated with those links is not transferred. The links are displayed as solid lines.
Pan and zoom does not automatically reset on map When several address entities are added to the map, the zoom sets to the most recently added entity and does not adjust to display the other entities.
Bidirectional text can be displayed incorrectly Although i2 Analyze supports right-to-left text, the following problems can occur in environments that use right-to-left text:
  • Visual Query search conditions do not display correctly when you are using right-to-left text.
  • Negative numbers display incorrectly in edit mode.
  • Some tooltips for left-to-right text in a right-to-left enabled system are displayed with the text mirrored.
Entering some combinations of multibyte Unicode characters displays an incorrect glyph Certain combinations of multibyte Unicode characters display as a square in the Intelligence Portal, rather than the expected glyph.
Japanese text uses Chinese font for punctuation Certain Japanese punctuation characters are displayed as the equivalent Chinese characters when you enter Japanese text.
The Intelligence Portal does not highlight information when the Starts With operator is used If a column filter or a search condition uses the Starts With operator, i2 Analyze does not supply highlighting information.
Potential latency when you attach documents A delay might occur between creating items with documents attached and being able to download the documents. When you run in a group Analysis Repository environment, if you make a document download request before the document is available, an error is displayed.
The Intelligence Portal does not support non-Gregorian calendars In locales with non-Gregorian default calendars, a Gregorian calendar is used instead for entry and display of dates.
Item label appears to be updated after edits are canceled If you change an item that if saved would cause the item label to change, and then click Cancel to discard your changes, the item label changes to include the canceled edits. The data is not saved and the label change is not persisted. If you close the tab and then reopen the item, the original label is displayed.
Microsoft Silverlight is not supported in some browsers The list of supported browsers is available in the system requirements. For more information, see Microsoft Silverlight may not work in recent versions of Google Chrome.
Search types vary in non-English-language regions Some limitations exist with exact and fuzzy matching in non-English-language regions.
  • Western European script (Brazilian, French, German, Italian, Spanish) and Cyrillic scripts (Russian):

    Exact matching produces successful results. Matches that are based on synonyms or similar spellings might return less useful results. Evaluate the results for similar spelling and synonym matching behaviors, and if necessary, you can modify the search configuration for a language during deployment.

  • Semitic and East Asian scripts (Arabic, Hebrew, Japanese, Korean, Simplified Chinese, Traditional Chinese):

    Exact matching produces mixed results. The indexing process is heavily reliant on word boundaries (for example, a space). As these scripts do not reflect the same word boundaries as western scripts, exact matching can provide weak or no results for text fragments. However, exact matching works in whole character sequences, such as the equivalent to English sentences. Matches based on synonyms can return less useful results than in English. Matches based on similar spellings are unlikely to return useful results. You can modify the search configuration for a language during deployment.

Chart names are ignored when charts are created in the Analysis Repository If you create a chart in the Analysis Repository, then save it and open it in Analyst's Notebook, the chart opens but the chart name is ignored. The default chart name is used. When any changes are made to that chart, the chart is treated as a standard Analyst's Notebook chart and the changes are not automatically saved back into the Analysis Repository. When you close and reopen Analyst's Notebook, a message might be displayed indicating that a temporary chart cannot be found. To avoid this problem, create your chart in Analyst's Notebook and upload it to the Analysis Repository. When you next Save the chart, any changes you made to it are automatically saved back into the Analysis Repository.
Items that contain a very large amount of data can affect performance If the Analysis Repository contains items that have many cards, or many properties on each card:
  • Performance might be affected.
  • Information can be harder to find.
For data that produces more than a hundred properties on a single card, or hundreds of cards on a single item, consider changing the structure of the data.

More information

For more information, see the following resources:


© Copyright IBM Corporation 2019.