IBM FileNet P8, Version 5.2            


< Previous | Next >

Configuring a Visual Studio Project

After creating a new project, you will reference the FileNet API DLL.

Starting Visual Studio

  1. On your system, launch the Visual Studio IDE.
  2. Close the Start Page pane.
  3. If the Solution Explorer is not open, click View > Solution Explorer in the Visual Studio menu bar.

Creating a Project

  1. In the Visual Studio menu bar, click File > New > Project.
  2. In the New Project dialog box, in the Project types section, expand Visual C#.
  3. Select Windows.
  4. In the Templates section, select Console Application.
  5. In the bottom portion of the New Project dialog box, enter the project Name, for example, com.ibm.filenet.net.sample.
  6. Enter the project Location, for example, C:\Visual Studio Projects.
  7. Enter the Solution Name, for example, P8ApiSample.
  8. Click OK.

Referencing the FileNet API DLL

  1. In the Solution Explorer pane, right-click your project, then click Add Reference.
  2. In the Add Reference window, click the Browse tab.
  3. In the Look in dropdown list, find the folder for FileNet.Api.dll.

    For the default location of FileNet.Api.dll, see Prerequisites.

  4. Select the DLL file.
  5. Click OK.
  6. In the Visual Studio menu bar, click File > Save All.
< Previous | Next >



Feedback



Last updated: October 2013

ss_vs_all003.htm



© Copyright IBM Corporation 2014.

This information center is powered by Eclipse technology. (http://www.eclipse.org)