Requirements for Microsoft Entity Framework support

To use IBM® Data Server Provider for .NET with Microsoft Entity Framework, you must have an environment with supported Microsoft Visual Studio software, an IBM data server client product, and the IBM Database Add-Ins for Visual Studio.

To use the Microsoft Entity Framework, you must have Microsoft .NET Framework 3.5 SP1 or later.

To manipulate entity data models by using the Microsoft Entity Data Model Wizard or Entity Designer, you also require Microsoft Visual Studio 2008 or later and the IBM Database Add-Ins for Visual Studio.
Important: Starting in Db2® Version 10.5 Fix Pack 5, the use of IBM data server products with Microsoft Visual Studio 2008 is deprecated.
The Entity Framework 5.0 features require the Microsoft .NET Framework version that supports those features and the Microsoft Visual Studio 2012 or later software. Microsoft .NET Framework Version 4.0 or later is required for the following Entity Framework 5.0 features:
  • Multiple diagrams per model
  • Batch import of stored procedures
Microsoft .NET Framework Version 4.5 or later is required for the following Entity Framework 5.0 features:
  • Enum support