Cognos Analytics 11.1.x deprecated and removed features

This section provides information about features that are deprecated or removed from IBM® Cognos® Analytics 11.1.x versions.

For a list of data servers that were deprecated or removed in different releases, see Data servers no longer supported in Cognos Analytics.

11.1.7 FP3 - June 2021

Deprecation of IBM JCC drivers prior to DB2 10.5 FP7
Support for IBM JCC drivers prior to DB2 10.5 FP7 will be removed in a future release of Cognos Analytics

11.1.7 - July 2020

Deprecation of some versions of data servers
Support for the following versions of data servers will be removed in a future release of Cognos Analytics:
  • Denodo (Platform 5.5 and Platform 6.0)
  • Exasol 6.1 and earlier
  • IBM Db2 Z (DB2 for z/OS 10.1 and earlier, and DB2 for z/OS 11.1.0 and earlier)
  • IBM Db2 LUW (9.7, 10.1, and 10.5)
  • IBM DB2 i5/OS 7.2 and earlier
  • IBM Informix 11.7 and earlier
  • IBM Planning Analytics prior to 2.0.6.
  • IBM TM1 (all versions)
  • MariaDB 10.1 and earlier
  • MemSQL 6.7.x and earlier
  • Microsoft SQL Server 2016 SP2 and earlier
  • Microsoft Analysis Services (OLEDB) prior to SQL Server 2016 Service Pack 2
  • Mongo BI-Connector 2.11 and earlier
  • MySQL 5.5 and earlier
  • ORACLE (11.2.0.4 and earlier, 12.1.0.2 and earlier, 12.2.0.1)
  • Oracle Essbase 11.1.2.4
  • Pivotal Greenplum 5.20.x and earlier
  • PostgreSQL 9.4 and earlier
  • Teradata 16.10 and earlier
  • Tibco Composite 7.0.8 and earlier
  • SAP Sybase ASE 15.7
  • SAP Sybase IQ 16.0
  • SAP HANA (1.0 SPS12 and earlier, and 2.0 SP3 and earlier)
  • Vertical (7.x and 8.x)
When a connection is tested, Cognos Analytics might indicate that the version detected is marked for deprecation in a future release. While the connection can still be used, it is recommend to update the connection to reference a newer, in-service version of the vendor's product.

Teradata Presto JDBC driver
Support for the Teradata Presto JDBC driver will be removed in a future release of Cognos Analytics. Existing connections will need to be changed to use the Presto JDBC driver class.

11.1.5 - December 2019

Removal of startup/shutdown scripts
Beginning in version 11.1.5 the following scripts will be removed from the product as they are not maintained and do not conform to desired JVM settings:
<caroot>/bin64/startup.bat
<caroot>/bin64/startwlp.bat
<caroot>/bin64/stopwlp.bat
<caroot>/bin64/shutdown.bat

<caroot>/bin64/startup.sh
<caroot>/bin64/startwlp.sh
<caroot>/bin64/stopwlp.sh
<caroot>/bin64/shutdown.sh

11.1.4 - October 2019

Deprecation of Computer Associates IDMS data server
Support for Computer Associates IDMS data server will be deprecated in a future release of Cognos Analytics.

11.1.3 - June 2019

Removed support for Pivotal HDB data server

Cognos Analytics no longer supports data server connections to the Pivotal HDB data server.

The associated data server type in the administration interfaces, Pivotal Greenplum and HDB, is changed to Pivotal Greenplum.

11.1.0 - September 2018

Translation of messages and user interface text is no longer supported in some languages

The translation of messages and user interface text is no longer supported in the following languages:

  • Catalan
  • Greek
  • Slovak
  • Indonesian
  • Malay