Supported platforms and hardware requirements

Learn more about supported platforms and hardware requirements for License Service.

Supported platforms

  • License Service that is integrated into an IBM Cloud Pak as a part of IBM Cloud Pak® foundational services is supported on the same platforms as foundational services.

Supported OpenShift versions and platforms

You can install IBM Cloud Pak for Integration on Linux® x86_64, Linux® on Power® (ppc64le), and Linux® on IBM® Z and LinuxONE with a supported version of OpenShift Container Platform.

IBM Cloud Pak foundational services follows the Red Hat® OpenShift® Container Platform lifecycle dates. When Red Hat OpenShift stops supporting an OpenShift Container Platform version, foundational services also stops supporting the version.

Table 1. Supported OpenShift versions
Platform IBM Cloud Pak foundational services installer version 3.19.17 – 3.19.19 IBM Cloud Pak foundational services installer version 3.19.12 – 3.19.16 IBM Cloud Pak foundational services installer version 3.19.8 – 3.19.11 IBM Cloud Pak foundational services installer version 3.19.3 – 3.19.7
Linux® x86_64 4.11, 4.12, 4.13, 4.14 4.11, 4.12, 4.13 4.11, 4.12 4.11
Linux® on Power® (ppc64le) 4.11, 4.12, 4.13, 4.14 4.11, 4.12, 4.13 4.11, 4.12 4.11
Linux® on IBM® Z and LinuxONE 4.11, 4.12, 4.13, 4.14 4.11, 4.12, 4.13, 4.11, 4.12 4.11

See the following notes:

  • IBM Cloud Pak foundational services installer versions 3.19.x are Long Term Service Release (LTSR).

  • Cloud Native PostgreSQL is supported on Linux x86_64, Linux on Power (ppc64le), and Linux on IBM Z and LinuxONE on OpenShift Container Platform versions 4.11 and 4.12.

  • User Data Services (UDS) is supported on Linux® x86_64 and Linux® on Power® (ppc64le) on OpenShift Container Platform versions 4.11 and 4.12.

  • Business Teams Service (BTS) is supported on Linux x86_64, Linux on Power (ppc64le), and Linux on IBM Z and LinuxONE on OpenShift Container Platform versions 4.11 and 4.12. For more information, see BTS version history.

  • Db2, which is installed with ibm-db2u-operator, is supported on Linux x86_64, Linux on Power (ppc64le), and Linux on IBM Z and LinuxONE on OpenShift Container Platform version 4.12 only.

  • You can deploy License Service on other Kubernetes-orchestrated clouds to collect license usage of IBM stand-alone containerized software. For deployment instructions and the full list of supporter platforms, see License Service for stand-alone products Opens in a new tab.

Hardware requirements

License Service uses the following hardware resources:

Platform CPU Request (m) CPU Limit (m) Memory Request (Mi) Memory Limit (Mi)
Linux® x86_64 200 300 430 850
Linux® on Power® (ppc64le) 300 400 230 543
Linux® on IBM® Z and LinuxONE 200 300 230 350