Upgrading Cloud Pak for Data

Use the following guidance to upgrade your existing IBM® Cloud Pak for Data installation.
  • You must upgrade your installation to Version 3.5 before you can upgrade to Version 4.0.x.

    For details on upgrading to Version 3.5, see Upgrading IBM Cloud Pak for Data control plane in the Version 3.5 documentation.

    Important: If you are running Red Hat® OpenShift® Container Platform Version 3.11, it is strongly recommended that you upgrade your cluster to Red Hat OpenShift Container Platform Version 4.5 before you upgrade your Cloud Pak for Data deployment.

    To upgrade from OpenShift Container Platform Version 3.11 to Version 4.5, you must install OpenShift Container Platform on a separate cluster. You can then migrate your existing Cloud Pak for Data deployment to the new cluster. For details, see Migrating Cloud Pak for Data from Red Hat OpenShift Version 3.11 to Version 4.5.

  • Remember: To obtain fixes, security updates, and new functionality, you must install the latest refresh of the Cloud Pak for Data software. The software includes the control plane, shared cluster components, and services.
    Restriction:
    If Cognos® Analytics is installed on your cluster, it is recommended that you:
    1. Backup your Cognos Analytics data store.
    2. Uninstall Cognos Analytics.
    3. Upgrade the Cloud Pak for Data platform
    4. Install Cognos Analytics.
    The documentation covers how to upgrade to the latest refresh of Cloud Pak for Data, Refresh 9 of Version 4.0.
    Upgrading to the latest refresh (recommended)
    If you are upgrading to the latest refresh, see Upgrading from IBM Cloud Pak for Data Version 3.5.

    If you cannot upgrade directly to the latest refresh from your current installation, review the list of supported upgrade paths to identify the path with the fewest steps.

    Upgrading to an earlier refresh
    If you are upgrading to an earlier refresh of 4.0, see the appropriate section of Documentation for previous 4.0.x refreshes.

    The following table lists the supported upgrade paths:

    If you are running this 3.5 refresh You can upgrade to
    Refresh 2 of Version 3.5 Refresh 9 of Version 4.0
    Important: Before you upgrade to Refresh 9 of Version 4.0, you must upgrade the Cloud Pak for Data control plane (lite assembly) to Version 3.5.4.

    You do not need to upgrade any of the services on 3.5 before you upgrade to Refresh 9 of Version 4.0.

    Version 3.5.4 was released as part of Refresh 8 of Version 3.5.

    Refresh 3 of Version 3.5 Refresh 9 of Version 4.0
    Important: Before you upgrade to Refresh 9 of Version 4.0, you must upgrade the Cloud Pak for Data control plane (lite assembly) to Version 3.5.4.

    You do not need to upgrade any of the services on 3.5 before you upgrade to Refresh 9 of Version 4.0.

    Version 3.5.4 was released as part of Refresh 8 of Version 3.5.

    Refresh 4 of Version 3.5 Refresh 9 of Version 4.0
    Important: Before you upgrade to Refresh 9 of Version 4.0, you must upgrade the Cloud Pak for Data control plane (lite assembly) to Version 3.5.4.

    You do not need to upgrade any of the services on 3.5 before you upgrade to Refresh 9 of Version 4.0.

    Version 3.5.4 was released as part of Refresh 8 of Version 3.5.

    Refresh 5 of Version 3.5 Refresh 9 of Version 4.0
    Important: Before you upgrade to Refresh 9 of Version 4.0, you must upgrade the Cloud Pak for Data control plane (lite assembly) to Version 3.5.4.

    You do not need to upgrade any of the services on 3.5 before you upgrade to Refresh 9 of Version 4.0.

    Version 3.5.4 was released as part of Refresh 8 of Version 3.5.

    Refresh 6 of Version 3.5 Refresh 9 of Version 4.0
    Important: Before you upgrade to Refresh 9 of Version 4.0, you must upgrade the Cloud Pak for Data control plane (lite assembly) to Version 3.5.4.

    You do not need to upgrade any of the services on 3.5 before you upgrade to Refresh 9 of Version 4.0.

    Version 3.5.4 was released as part of Refresh 8 of Version 3.5.

    Refresh 7 of Version 3.5 Refresh 9 of Version 4.0
    Refresh 8 of Version 3.5 Refresh 9 of Version 4.0
    Refresh 9 of Version 3.5 Refresh 9 of Version 4.0
    Refresh 10 of Version 3.5 Refresh 9 of Version 4.0
    Refresh 11 of Version 3.5 Refresh 9 of Version 4.0
    Refresh 12 of Version 3.5 Refresh 9 of Version 4.0
    Refresh 13 of Version 3.5 Refresh 9 of Version 4.0
  • Remember: To obtain fixes, security updates, and new functionality, you must install the latest refresh of the Cloud Pak for Data software. The software includes the control plane, shared cluster components, and services.

    The documentation covers how to upgrade to the latest refresh of Cloud Pak for Data, Refresh 9 of Version 4.0.

    Upgrading to the latest refresh (recommended)
    If you are upgrading to the latest refresh, see Upgrading from IBM Cloud Pak for Data Version 4.0.x.

    If you cannot upgrade directly to the latest refresh from your current installation, review the list of supported upgrade paths to identify the path with the fewest steps.

    Upgrading to an earlier refresh
    If you are upgrading to an earlier refresh of 4.0, see the appropriate section of Documentation for previous 4.0.x refreshes.

    The following table lists the supported upgrade paths:

    If you are running this 4.0 refresh You can upgrade to
    Initial release of Version 4.0 Contact IBM Software Support.
    Refresh 1 of Version 4.0 Refresh 9 of Version 4.0
    Refresh 2 of Version 4.0 Refresh 9 of Version 4.0
    Refresh 3 of Version 4.0 Refresh 9 of Version 4.0
    Refresh 4 of Version 4.0 Refresh 9 of Version 4.0
    Refresh 5 of Version 4.0 Refresh 9 of Version 4.0
    Refresh 6 of Version 4.0 Refresh 9 of Version 4.0
    Refresh 7 of Version 4.0 Refresh 9 of Version 4.0
    Refresh 8 of Version 4.0 Refresh 9 of Version 4.0