System requirements

Find out the hardware and software requirements for CICS TX.

For the latest software versions supported with the product, always check IBM Detailed System Requirements

Hardware requirements

CICS TX requires any x86 hardware that is capable of running Docker or Podman and Kubernetes. At least 5GB of disk space is required and at least 8GB RAM memory.

Operating system

CICS TX is a 32-bit product supported on x86 architecture. All libraries linked with CICS TX on Cloud must be 32-bit libraries.

CICS TX runs on Linux:
  • Red Hat Enterprise Linux (RHEL) 8
  • Red Hat Enterprise Linux (RHEL) Server 7

Software requirements

CICS TX includes Red Hat® Universal Base Image (UBI).

Before you install CICS TX, you must have installed the following software:
  • Either Docker runtime V17.12.1 or later, or podman 1.6.4 or later (supported only on RHEL 8).

Additional software requirements

To use all the functions of CICS TX, you will need some additional software:
Cloud Platform
  • Kubernetes version 1.19
  • Open Shift Container Platform 4.5 or later
  • If you use Kubernetes, you need the IBM License Service
Compilers and languages
  • COBOL-IT Compiler Suite Enterprise Edition 4.1.9
  • IBM COBOL for Linux on x86 1.1
Databases
  • IBM Db2 11.5
  • Oracle 19c
  • PostgreSQL 10
  • Redis 5.0.4
Integration
  • IBM MQ 9.4
  • TXSeries for Multiplatforms 9.1
  • CICS Transaction Server for z/OS 5.3
  • CICS Transaction Gateway for Multiplatforms 9.2