z/OS Explorer Quick Tips

These quick tips are frequently asked questions about the z/OS® Explorer views and operations. More detailed help is provided in the Help Contents.

Data Sets view FAQs

My FTP connection has dropped. How do I reconnect?
To reconnect, click the Connection icon The connection icon, which is in the connection status bar in the lower-right corner of the workbench. Back
How do I see all data sets for my user ID?
When connected, the Data Sets view shows all data sets for the user ID in the connection credential. To show the data sets for a different user ID, type the user ID in the text field and press Enter. Back
How do I see the high level qualifier for my data sets?
In the Data Sets view, click the View Menu iconThe View Menu icon and click Show High level Qualifier. Back
How do I submit a job?
Locate the JCL in the Data Sets view and right-click, then click Submit. Back
How do I create a new data set member?
In the Data Sets view locate the PDS where you want to create the member, right-click the PDS and click New Data Set member. Back
How do I edit a data set?
In the Data Sets view, locate the data set you want to edit, right-click and click Open. Alternatively, double-click the data set. Back
When editing a data set, how can I tell when I reach the 80 character position?
When you are in the Data Set Editor view, the file type, text mode, and line/column details are indicated in the workbench status bar Workbench status bars showing file type of Writable, text mode of Insert, and line/column as 4/23. Back
Can I submit a data set after I have edited it, but before I save it?
Yes. When you have finished editing the data set, you can right-click in the editor view and click Submit Job. Back

Jobs view FAQs

My FTP connection has dropped. How do I reconnect?
To reconnect, click the Connection icon The connection icon, which is in the connection status bar in the lower-right corner of the workbench. Back
How do I see all the jobs for my user ID?
When connected, the Jobs view shows all jobs for the user ID in the connection credential. Back
How do I see jobs for other users?
You can only see the jobs you are authorized for. To show jobs for a different user ID, type the user ID in the User field and press Enter. Back
How do I submit a job?
Locate the JCL in the Data Sets view and right-click, then click Submit. Back

z/OS UNIX Files view FAQs

My FTP connection has dropped. How do I reconnect?
To reconnect, click the Connection icon The connection icon, which is in the connection status bar in the lower-right corner of the workbench. Back
How do I see all the files in a specific folder?
When connected, the z/OS UNIX Files view shows all files in the root directory. To see the files in a specific folder, type the folder path in the text field and press Enter. Back
How do I open and edit a file?
In the z/OS UNIX Files view, locate the file you want to edit, right-click and click Open. Alternatively, double-click the file name. Back
How do I set file permissions and transfer mode?
In the z/OS UNIX Files view, right-click the file you want to change, then click Properties.

Console view FAQs

My Console view is grayed out. How do I activate it?
When you start z/OS Explorer the view is inactive. When you submit a job, or edit and save a file, the view will be activated automatically. Back
How do I clear my console entries?
To clear the console entries, click the Clear Console icon The Clear Console icon, which is located in the Console menu bar. Back
How do I save my console records?
Click anywhere in the console view and select all records. You can use the Ctrl+A (cmd+A for OS X) combination of keys. Copy the files to the clipboard using Ctrl+C (cmd+C for OS X) and then paste them into a file of your choice to save them. Back

Error data FAQ

How do I prepare error data for IBM service?
If you need to send the error logs and other information to an IBM® service representative, you can use z/OS Explorer to collect all necessary error information in a single compressed file, ready to send.

The error logs are stored in a folder in the local Eclipse workspace on your computer. The default workspace name is .zosexplorer. The location for the workspace depends on your operating system and is shown in the z/OS Explorer title bar.

To collect the error data, use the following procedure:
  1. Click File > Trace > Collect Service Data on the main menu for the workbench.
  2. In the Save Service data as file window, select the location where you want to save the compressed file, and click Save.

The service data is saved as a compressed file. The filename is in the format ExplorerServiceData-date-time.zip, where date and time are numbers that indicate the date and time of the collected data, for example ExplorerServiceData-20150318-080311.zip. Remember to record your actions at the time the failure occurred, to aid further analysis of the problem.