New Media changes

You can install or upgrade to the latest Fix Pack version of Sterling B2B Integrator in a single step without installing the intermediary version.

This change offers a hassle-free upgrade without getting stuck in between versions and also simplifies the build process from two steps to a single step.


Example 1:
Upgrade from 5.2.6.3_13 to 6.1.0.1
At present:
step 1) upgrade 5.2.6.3_13 to 6.1.0.0
step 2) upgrade 6.1.0.0 to 6.1.0.1
With new Media changes:
Directly upgrades 5.2.6.3_13 to 6.1.0.1 in a single step

Example 2:
Upgrade from 6.0.0.4 to 6.1.0.1
At present:
step 1) upgrade 6.0.0.4 to 6.1.0.0
step 2) upgrade 6.1.0.0 to 6.1.0.1
With new Media changes:
Directly upgrades 6.0.0.4 to 6.1.0.1 in a single step

Example 3:
Upgrade from 6.1.0.0 to 6.1.0.1
With new Media changes:
Applies only 6.1.0.1 changes

Changes on v6.1.0.1 and later versions

Note: With the new Media changes in place:
  • The Fix Pack installs the Media and the Fix Pack together. This makes it work like a regular Mod Pack for both install and upgrade.
  • The Media file size is increased to over 4GB. Due to the increase in file size, you cannot use the default unzip command.
Important: If you are on v6.1.0.0 and want to upgrade to the next Fix Pack, then the base version 6.1.0.0 is not installed again. The system installs only the Fix Pack changes.

Response File changes

The following are the changes as part of introducing the new Media changes for installation and upgrade.

Installation of Fix Pack v6.1.2.x

You can download and install the Media file of v6.1.2.x directly in a simple one-step process.

Upgrade to Fix Pack v6.1.2.x

For earlier versions, the Response File requires a Fix ID in the below format.

For v5.2.6.x
<offering profile='Sterling Integrator' id='fix_5.2.6.3_10'/>
For v6.1.X.x 
<offering profile='Sterling Integrator' id='fix_6.1.2.2'/>
For v6.1.2.x and later versions, the Response File has a new format.

<offering profile='Sterling Integrator' id='com.ibm.sterling.integrator.install.offering' 
features='<feature_list that you need to add>'/>

Additionally, you must provide JDK, JCE, and passphrase in the Response File during upgrade.

GUI changes

Following are the changes as part of introducing the new Media changes for installation and upgrade.

Installation of Fix Pack v6.1.2.x

You can directly install the Fix Pack without installing the base version just like a Media installation, with all the required parameters.

Upgrade to Fix Pack v6.1.2.x

For earlier versions, no parameters are required during upgrade.

For v6.1.2.x and later versions, you must provide JDK, JCE, and passphrase in the IIM panel during the upgrade.