IBM API Connect Version 10 software product compatibility requirements

Ensure that you install the minimum API Connect operating system requirements. Use the IBM® Software Product Compatibility Reports site to generate a requirements report appropriate for your API Connect version and environment.

Generating a Software Product Compatibility Report

To generate an API Connect requirements report, complete the following steps:
  1. Open the Detailed system requirements for a specific product page on the IBM Software Product Compatibility Reports site.
  2. Search for the IBM API Connect product.
  3. In the Search results list, select IBM API Connect.
  4. From the Version list, select the required version.
  5. Use the Filters to refine the contents of the requirements report.
  6. Click Submit to generate your requirements report.

Supported versions of Kubernetes

Table 1 provides a quick reference of the supported Kubernetes versions for each API Connect release:

Any upgrade can only progress from older versions of Kubernetes and API Connect to newer versions, and each stage must involve a combination that is represented with a check mark in the table.

Table 1. API Connect and Kubernetes (K8S) compatibility matrix
API Connect version K8S 1.22 K8S 1.23 K8S 1.24 K8S 1.25 K8S 1.26 K8S 1.27 K8S 1.28 K8S 1.29
10.0.1.7            
10.0.1.8            
10.0.1.9          
10.0.1.11          
10.0.1.12          
10.0.1.15          
10.0.4.0-ifix2 or later              
10.0.5.0            
10.0.5.1            
10.0.5.2          
10.0.5.3          
10.0.5.4        
10.0.5.5        
10.0.5.6        
10.0.5.7        

Upgrading to an API Connect release that uses a newer version of Kubernetes

When you upgrade API Connect, both your current deployment and your target release must support the same version of Kubernetes. After the API Connect upgrade, you can optionally update Kubernetes to the highest version supported by the new release of API Connect.

It is possible you will need to upgrade both Kubernetes and API Connect more than once to complete the process. For example, suppose that your current deployment is running API Connect 10.0.1.12 on Kubernetes v1.24 and you want to upgrade to API Connect 10.0.5.7. The highest version of Kubernetes supported with API Connect 10.0.1.12 is v1.26, but the lowest version of Kubernetes supported by API Connect 10.0.5.7 is v1.27, so a direct upgrade of API Connect is not possible.

In this scenario, you must make multiple upgrades of both Kubernetes and API Connect. For example, one option is to use API Connect 10.0.1.15 on Kubernetes v1.27 as your interim release by completing the following upgrades:
  1. On your API Connect 10.0.1.12 deployment, upgrade Kubernetes from v1.24 to v1.25, and then v1.26.
  2. Upgrade API Connect to 10.0.1.15 on Kubernetes v1.26.
  3. On the API Connect 10.0.1.15 deployment, upgrade Kubernetes to v1.27
  4. Upgrade API Connect to 10.0.5.7 on Kubernetes v1.27.
  5. On the API Connect 10.0.5.7 deployment, optionally upgrade Kubernetes to v1.28, and then to v1.29.

Supported versions of OpenShift

Table 2 provides a quick reference of the supported OpenShift versions for each API Connect release.

Any upgrade can only progress from older versions of OpenShift and API Connect to newer versions, and each stage must involve a combination that is represented with a check mark in the table.

Note: In the table, OpenShift 4.7, 4.8, and 4.9 are marked with * to indicate that they are available only as interim solutions to enable your upgrade from API Connect 10.0.1.7, 10.0.1.8, and 10.0.4-ifix2 on OpenShift 4.6.
Table 2. API Connect and OpenShift Container Platform (OCP) compatibility matrix
API Connect version OCP 4.6 OCP 4.7 OCP 4.8 OCP 4.9 OCP 4.10 OCP 4.12 OCP 4.14
10.0.1.7 ✅* ✅* ✅*    
10.0.1.8 ✅* ✅* ✅*    
10.0.1.9            
10.0.1.11            
10.0.1.12          
10.0.1.15          
10.0.4.0-ifix2 or later ✅* ✅* ✅*    
10.0.5.0            
10.0.5.1            
10.0.5.2          
10.0.5.3          
10.0.5.4          
10.0.5.5        
10.0.5.6        
10.0.5.7        

Upgrading to an API Connect release that uses a newer version of OpenShift

When you upgrade API Connect, both your current deployment and your target release must support the same version of OpenShift. After the API Connect upgrade, you can optionally update OpenShift to the highest version supported by the new release of API Connect.

Note: When you upgrade OpenShift, you must progress through every interim version; for example, to upgrade from 4.10 to 4.14, complete the following upgrades: 4.10 > 4.11 > 4.12 > 4.13 > 4.14.
Suppose you want to upgrade to API Connect 10.0.5.7:
  • If you are using API Connect 10.0.1.11 or earlier running on OpenShift 4.10:
    1. Upgrade API Connect to a newer version that supports both OpenShift 4.10 and OpenShift 4.12 (for example, to 10.0.1.12 or 10.0.1.15, or to 10.0.5.2, 10.0.5.3, 10.0.5.4, or 10.0.5.5).
    2. Upgrade OpenShift to 4.12.
    3. Upgrade API Connect to 10.0.5.7 (supported on OpenShift 4.12).
    4. Optionally upgrade OpenShift to 4.14 (the highest version supported by API Connect 10.0.5.7).
  • If you using API Connect 10.0.4.0-iFix2 running on OpenShift 4.6:, then you must first upgrade to OpenShift 4.10 before you can upgrade to API Connect to 10.0.5.0 or later:
    1. Upgrade OpenShift to 4.10.
    2. Upgrade API Connect to a newer version that supports both OpenShift 4.10 and OpenShift 4.12 (10.0.5.2, 10.0.5.3, 10.0.5.4, or 10.0.5.5).
    3. Upgrade API Connect to 10.0.5.7 (supported on OpenShift 4.12).
    4. Optionally upgrade OpenShift to 4.14 (the highest version supported by API Connect 10.0.5.7).