Installing an Interim Fix into a SPOT resource

Follow this procedure for installing an interim ifix into a SPOT resource, or to patch a shared operating system file or concurrent update of a thin server to disk.

Use the following procedure to install an interim fix into a NIM SPOT resource.

The interim fix is usually named <Label>.<Timestamp>.epkg.Z

Installation to a NIM SPOT

  1. 1. Check if an APAR containing the desired fix is installed on the NIM master and SPOT: For example:
    • AIX 5.1: APAR IY40088
    • AIX 5.2: APAR IY40236
    To check if the APAR is installed on the NIM master, type:
    # instfix -ik <APAR>
    To check if the APAR is installed on the NIM SPOT, type:
     # nim -o fix_query -a fixes=<APAR><Spot_Name>
  2. Create an interim fix path in any lpp_source (if it does not exist already). The path will be in the format of: lpp source path>emgr/ppc
    Example:
    # lsnim -a location 520lpp
    520lpp:
    location = /520/520lpp

    # mkdir -p /520/520lpp/emgr/ppc
  3. Copy the ifix package to the ifix path in the lpp_source:
    cp <EFix_File><LPP_Location>/emgr/ppc

    Example:
    # cp IY12345.050303.epkg.Z /520/520lpp/emgr/ppc
  4. Execute a nim "cust" operation on the SPOT specifying the LPP_SOURCE and the interim fix:
     # nim -o cust -a lpp_source=<LPP_Source>-a filesets=<Interim fix><Spot>
    Example
    # nim -o cust -a lpp_source=520lpp -a filesets=IY12345.050303.epkg.Z 520spot

List Interim Fixes Installed in a SPOT

To list out all interim fixes installed in a SPOT, use the lslpp nim query with an lslpp tag of e:

# nim -o lslpp -a lslpp_flags=e<Spot>

Example
# nim -o lslpp -a lslpp_flags=e 520spot
D    STATE   LABEL          INSTALL TIME               ABSTRACT
=== =====  ========== ================== ====================
1       S       IY12345        08/13/04 13:19:20          IY12345 AIX 5.2 efix

Uninstall Interim Fix from a SPOT

To uninstall the ifix from the SPOT, use the fix <Label> with a maint command on the SPOT (note: the label is related to, but not exactly the filename; it is the first part of the filename):
nim -Fo maint -a installp_flags=u -a filesets=<Label><Spot_Name>
Example
  # nim -Fo maint -a installp_flags=u -a filesets=IY12345 520spot
Note: Installing this interim fix will lock the affected fileset to prevent the installation of an update not containing the fix from regressing the system. Once the official fix is available, you may use the interim fix uninstall command to uninstall the ifix before applying the official APAR.