install_all_updates Command

Purpose

Updates installed software to the latest level on media and verifies the current recommended maintenance or technology level.

Syntax

install_all_updates -d Device [ -p ] [ -i ] [ -c ] [ -r ] [ -n ] [ -s ] [ -x ] [ -v ] [ -N ] [ -S ] [ -Y ] [ -V ] [ -D ]

Description

install_all_updates examines currently installed software and attempts to update it to the latest level that is available on the media. install_all_updates will not install any filesets that are present on the media, but not installed on the system except in the following situations:
  • the new filesets are installed as requisites of other filesets.
  • the /var/adm/ras/bosinst.data filesets ALL_DEVICES_KERNELS to yes.
For installp images, all installp requisites are enforced.
Note:
  1. Currently, install_all_updates processes installp images and rpm images. Because the rpm utility does not support automatic installation of requisites, some rpm software may not be installable with install_all_updates.
  2. install_all_updates verifies the current recommended maintenance or technology level by using the "oslevel" utility and checking with the latest recommended maintenance or technology level known to this version of install_all_updates.
  3. If install_all_updates locates an update to the install utilities (the bos.rte.install fileset), it first installs the update and then reinvokes itself to process the remaining updates. The "-i" flag can be used to update the install utilities only, this is useful when attempting to view an accurate preview.
  4. install_all_updates applies all installp updates unless the COMMIT flag (-c) is specified. For more information of APPLY vs. COMMIT please see the installp man page.
  5. install_all_updates will by default instruct installp to automatically install requisites and to do any necessary file system expansions. The "-n" will override the install requisite default, and "-x" will override the file system expansion default.
  6. The following flags apply to installp updates only: -c, -n, -x, -v, -S, and -V.
  7. Any library or executable program updated by an interim fix or service update which is in use by an active process will not be reflected in that process unless it is restarted. For example, an update that changes the ksh will not have the changes reflected in any ksh processes that are already running. Likewise, an update to the libc.a library will not be reflected in any process that is already running. In addition, any process that is using a library and does a dlopen operation of the same library after the library has been updated could experience inconsistencies if it is not restarted.
  8. If an attempt is made to update a fileset that is locked by the interim fix manager (the emgr command), a notice will be displayed indicating which filesets are locked. The lslpp command shows that any locked filesets are in the EFIXLOCKED state.
  9. If an attempt is made to update a file set that has an installed build date more recent than the build date of the selected fileset, a message will be displayed to indicate this.

Some installed software must ship new installation images instead of service updates in new technology levels or service packs of the AIX® operating system. For instance, a new installation image is required if the requisites of the installation image changes. When filesets are updated by using the smitty update_all or install_all_updates command, the most current version of the fileset is installed irrespective of whether filesets are updated by using the installation image or service update in the software source.

When a new installation image is installed, the history of the fileset in the system, which is the output of the lslpp -ah <fileset> command, is reset. The output of the lslpp -ah <fileset> command lists the new level of the fileset instead of original installation that was installed and all changes after that installation. . The following examples show the history of the bos.ecc_client.rte file before and after the installation image is installed.
  • Before a new installation image for the bos.ecc_client.rte file is shipped, the following output is displayed:
    # lslpp -ah bos.ecc_client.rte 
           Fileset         Level       Action       Status       Date       Time  
           ---------------------------------------------------------------------------
           Path: /usr/lib/objrepos  bos.ecc_client.rte                  
                           6.1.9.0     COMMIT       COMPLETE     04/26/17     16:49:31  
                           6.1.9.0     APPLY        COMPLETE     04/26/17     16:49:31   
                           6.1.9.15    APPLY        COMPLETE     04/26/17     21:02:55
                           6.1.9.45    APPLY        COMPLETE     04/27/17     08:11:05
           Path: /etc/objrepos  bos.ecc_client.rte                 
                           6.1.9.0     COMMIT       COMPLETE     04/26/17     16:49:42
                           6.1.9.0     APPLY        COMPLETE     04/26/17     16:49:42   
                           6.1.9.15    APPLY        COMPLETE     04/26/17     21:03:07  
                           6.1.9.45    APPLY        COMPLETE     04/27/17     08:11:19
  • After a new installation image for the bos.ecc_client.rte file is shipped and installed on the system, the following output is displayed:
    # lslpp -ah bos.ecc_client.rte
           Fileset         Level        Action       Status       Date         Time
           ---------------------------------------------------------------------------
    Path: /usr/lib/objreposbos.ecc_client.rte
                           6.1.9.100    COMMIT       COMPLETE     04/27/17     09:19:12
                           6.1.9.100    APPLY        COMPLETE     04/27/17     09:19:12
    
    Path: /etc/objreposbos.ecc_client.rte
                           6.1.9.100    COMMIT       COMPLETE     04/27/17     09:19:22
                           6.1.9.100    APPLY        COMPLETE     04/27/17     09:19:22

Flags

Item Description
-c Instructs installp to commit all newly installed updates. Updates are applied by default (Please see the installp man page for more explanation on applying vs. committing updates).
-d Device Specifies where the installation media can be found. This can be a hardware device such as tape or cdrom or it can be a directory that contains installation images. When installation media is a tape device it should be specified as no-rewind-on-close and no-retension-on-open.
-D Turns on install_all_updates debug output. This flag is for debugging the install_all_updates utility and should not be used for normal operations.
-i Update install utilities only.
-n Instructs installp to not automatically install requisites. Automatic installation of requisites is the default behavior.
-N Skip updating install utilities first.
Note: This flag is not recommended unless you are debugging a related problem.
-p Performs a preview of an action by running all preinstallation checks for the specified action. No software changes are made.
-r Update rpm images (if possible). This flag is not set by default.
-s Skip recommended maintenance or technology level verification. The verification is performed by default.
-S Instructs installp to suppress multi-volume processing of cdrom media.
-v Instructs installp to verify that all installed files in the fileset have the correct checksum value after the installation. This operation may require more time to complete the installation.
-V Instructs installp to run in verbose output mode.
-x Instructs installp to not automatically expand file systems. Automatic expansion of file systems is the default.
-Y Agrees to all software license agreements which are required for software installation.

Exit Status

0
All lppmgr related operations completed successfully.
>0
An error occurred.

Security

Only the root user can execute install_all_updates.

Attention RBAC users: This command can perform privileged operations. Only privileged users can run privileged operations. For more information about authorizations and privileges, see Privileged Command Database in Security. For a list of privileges and the authorizations that are associated with this command, see the lssecattr command or the getcmdattr subcommand.

Examples

  1. To install all installp updates on device /dev/cd0 and to verify the current recommended maintenance or technology level, enter:
    install_all_updates -d /dev/cd0
  2. To update any rpm images on your system, with newer technology levels from the /images directory, enter:
    install_all_updates -d /images -r
  3. To install the latest level of install utilities on device /dev/cd0 (bos.rte.install update), enter:
    install_all_updates -d /dev/cd0 -i

Files

Item Description
/usr/sbin/install_all_updates Contains the install_all_updates command.