multibos Command
Purpose
Creates, updates, and manages multiple versions of the Base Operating System (BOS) on a rootvg.
Syntax
multibos -s [-l device {-a | -f file | -b file | -x file}] [-e file] [-i file] [-L file] [-pntNX]
multibos -c -l device {-a | -f file | -b file | -x file} [-pnNX]
multibos -C [VG name]
Description
The multibos command allows the root user to create an instance of the Base Operating System (BOS) in the rootvg volume group.
The multibos setup operation creates a standby Base Operating System (BOS) that boots from a distinct boot logical volume (BLV). This creates two bootable sets of BOS on a given rootvg. The administrator can boot from either instance of BOS by specifying the respective BLV as an argument to the bootlist command or using system firmware boot operations. Two bootable instances of BOS can be simultaneously maintained. The instance of BOS associated with the booted BLV is referred to as the active BOS. The instance of BOS associated with the BLV that has not been booted is referred to as the standby BOS. Currently, only two instances of BOS are supported per rootvg.
The multibos command allows the administrator to access, install maintenance and technology levels for, update, and customize the standby BOS either during setup or in subsequent customization operations. Installing maintenance and technology updates to the standby BOS does not change system files on the active BOS. This allows for concurrent update of the standby BOS, while the active BOS remains in production.
In addition, the multibos command copies or shares logical volumes and file systems. By default, the BOS file systems (currently /, /usr, /var, and /opt,) and the boot logical volume are copied. The administrator can make copies of additional BOS objects (using the -L flag).
All other file systems and logical volumes are shared between instances of BOS. Separate log device logical volumes (for example, those that are not contained within the file system) are not supported for copy and are shared.
mksysb -M
command and use
the mksysb backup to populate a standby instance of the operating system on system A. - While the multibos command is running, ensure that system activity is minimal.
- Any logical volume or file system attributes that are new to the higher level are not implemented when the standby instance is created because the operating system at a lower level has no knowledge of the attributes.
- Do not keep both an AIX 6.1 instance and an AIX 5.3 instance for an extended period. You might not be able to switch between the instances because of incompatibilities. Commit to one of the instances and remove the other.
- If your operating system is running with the logical volumes in the active BOS
that have the multibos-created
bos_hd*
names, and no standby BOS in the rootvg directory, then a preservation or migration type of installation can occur starting with AIX 7200-00. The logical volumes that have thebos_hd*
names on the system arebos_hd5
,bos_hd4
,bos_hd2
,bos_hd9var
, andbos_hd10opt
. The operating system must not havehd5
,hd4
,hd2
,hd9var
, orhd10opt
logical volumes. If you created the multibos instance from anmksysb
image, which was created by using the mksysb command with the -M flag, thehd8
logical volume might also have been renamed tobos_hd8
. You can check this prerequisite with the lsvg -l rootvg command. Always back up your system before migrating. Also, copy the /usr/lpp/bos/pre_migration file from the media or your network installation manager (NIM) spot of the level to which you are migrating, to the target system and execute the file on the target system to check for any migration warnings.Before you perform a migration or a preservation type of operating system installation in this environment, verify that the disk control block has a valid level for your
rootvg
. You can run the /usr/lpp/bosinst/blvset -d /dev/hdiskN -g level command, wherehdiskN
is the disk that contains thebos_hd5
logical volume. If this command returns0.0
or an unexpected level, run the bosboot -ad /dev/ipldevice command to correct it, and rerun the blvset command to verify. It must return6.1
or7.1
. - In addition to the flags mentioned in the syntax section, the -V flag performs the verify operation from the inittab during boot. It is important that you do not modify this entry. The verify operation enables the multibos utility to synchronize changes in logical volumes and file systems between the active and standby instances. This entry also synchronizes the ODM and devices on initial boot after a mksysb restore. Without this operation, both the active and standby instances could become inconsistent with normal file system and logical volume operations.
Restrictions
- The multibos command is supported on AIX 5L Version 5.3 with the 5300-03 Recommended Maintenance package and later.
- The current rootvg must have enough space for each BOS object copy. BOS object copies are placed on the same disk or disks as the original.
- The total number of copied logical volumes cannot exceed 128. The total number of copied logical volumes and shared logical volumes are subject to volume group limits.
- Using the multibos command in a mirrored
rootvg volume group is not supported. You can remove the mirror of the
rootvg
volume group by running the unmirrorvg command. You can run the alt_disk_copy command to have a copy of the rootvg volume group that can be upgraded as needed. When you have the required instance of AIX, remove the volume group no longer needed by using thealt_rootvg_op
operation, and re-mirror the rootvg volume group.
Flags
Item | Description |
---|---|
-a | Specifies the update_all install option. Valid with setup and customization operation. |
-B | Build boot image operation. The standby boot image is created and written to the standby BLV using the AIX bosboot command. |
-b file | Specifies the install bundle to be installed during the setup or customization operation. The install bundle syntax should follow geninstall conventions. |
-c | Performs a customized update of the software in standby BOS. |
-C VG name | Allows you to vary on volume groups for syncing when it is appropriate, as the auto varied off volume groups are not varied on during the reboot, like the rootvg volume group, in order to be synced. The multibos -C VG name command should be used on auto varied off volume groups after the multibos command has created an alternative root volume group (operating system) on the disk and has been booted. |
-e file | Lists active BOS files to be excluded during the setup operation in regular expression syntax. |
-f file | Lists fixes (such as APARs) that are to be installed during the setup or customization operation. The syntax of the list follows instfix conventions. |
-i file | Specifies optional image.data file to use instead of the default image.data file created from the current rootvg. |
-L file | Specifies a file that contains a list of additional logical volumes to include in standby BOS. |
-l device | Installs device or directory for software update during the setup or customization operation. |
-m | Mounts standby BOS. |
-M file | Specifies a file that contains a mksysb image. The mksysb image
must have been created using the mksysb -M command
beginning with AIX 6.1 with 6100-02. |
-N | Skips boot image processing. This flag should only be used by experienced administrators that have a good understanding of the AIX boot process. |
-n | Does not perform cleanup upon failure. This option is useful to retain multibos data after a failed operation. |
-p | Performs a preview of the given operation. Valid with setup, remove, mount, unmount, and customization operations. |
-R | Removes all standby BOS objects. |
-S | Initiates an interactive shell with chroot access to the standby BOS file systems. |
-s | Creates an instance of standby BOS. |
-t | Prevents multibos from changing the bootlist. |
-u | Unmounts standby BOS. |
-x file | Runs the optional customization script before any other customized parameters, such as, update_all (-a), install bundle file (-b), and fix list file (-f). You must use a full pathname for the script. |
-X | Allows for automatic file system expansion if space is needed to perform tasks related to multibos. It is recommended that all multibos operations are executed with this flag. |
Exit Status
Item | Description |
---|---|
0 | All the multibos command operations completed successfully. |
>0 | An error occurred. |
Security
Only the root user can run the multibos command.
Examples
- To perform a standby BOS setup
operation preview, enter the following command:
multibos -Xsp
- To set up standby BOS,
enter the following command:
multibos -Xs
- To set up standby BOS with
optional image.data file /tmp/image.data and
exclude list /tmp/exclude.list, enter the
following command:
multibos -Xs -i /tmp/image.data -e /tmp/exclude.list
- To set up standby BOS and
install additional software listed as bundle file /tmp/bundle and
located in the images source /images, enter
the following command:
multibos -Xs -b /tmp/bundle -l /images
- To execute a customization operation on standby BOS with the update_all install
option, enter the following command:
multibos -Xac -l /images
- To mount all standby BOS file
systems, enter the following command:
multibos -Xm
- To perform a standby BOS remove
operation preview, enter the following command:
multibos -RXp
- To remove standby BOS,
enter the following command:
multibos -RX
- To use an existing mksysb file /backups/mksysb1 to
populate the standby instance of rootvg, enter the following command:
multibos -M /backups/mksysb1 -sX
Files
Item | Description |
---|---|
/usr/sbin/multibos | Contains the multibos command. |
/etc/multibos | Contains multibos data and logs. |