lsvg Command

Purpose

Displays information about volume groups.

Syntax

lsvg [ -L ] [ -o ] | [ -n descriptorphysicalvolume ] | [ -i ] [ -l | -M | -p ] [ -m ] [ -P ] volumegroup ...

Description

The lsvg command displays information about volume groups. If you use the volumegroup parameter, only the information for that volume group is displayed. If you do not use the volumegroup parameter, a list of the names of all defined volume groups is displayed.

When information from the Device Configuration database is unavailable, some of the fields will contain a question mark (?) in place of the missing data. The lsvg command attempts to obtain as much information as possible from the description area when the command is given a logical volume identifier.

Note: To determine a volume group's major number, use the ls -al /dev/VGName command. This command lists the special device file that represents the volume group. The volume group major number is the same as the major device number of the special device file. For example, for a volume group named ha1vg, enter the following command:
ls -al /dev/ha1vg

This command returns the following:

crw-rw---- 1 root system 52, 0 Aug 27 19:57 /dev/ha1vg

In this example, the volume group major number is 52.

You can use the System Management Interface Tool (SMIT) smit lsvg fast path to run this command.

Flags

Item Description
-i Reads volume group names from standard input.
-l Lists the following information for each logical volume within the group specified by the volumegroup parameter:
LV
A logical volume within the volume group.
Type
Logical volume type.
LPs
Number of logical partitions in the logical volume.
PPs
Number of physical partitions used by the logical volume.
PVs
Number of physical volumes used by the logical volume.
Logical volume state
State of the logical volume. Opened/stale indicates the logical volume is open but contains partitions that are not current. Opened/syncd indicates the logical volume is open and synchronized. Closed indicates the logical volume has not been opened.
Mount point
File system mount point for the logical volume, if applicable.
-L Specifies no waiting to obtain a lock on the Volume group.

Note : If the volume group is being changed, using the -L flag gives unreliable data.

-m Lists the mirror pool that each logical volume copy in the volume group belongs to.
-M Lists the following fields for each logical volume on the physical volume:
PVname:PPnum [LVname: LPnum [:Copynum] [PPstate]]
PVname
Name of the physical volume as specified by the system.
PPnum
Physical partition number. Physical partition numbers can range from 1 to 1016.
LVname
Name of the logical volume to which the physical partitions are allocated. Logical volume names must be system-wide unique names, and can range from 1 to 64 characters.
LPnum
Logical partition number. Logical partition numbers can range from 1 to 64,000.
Copynum
Mirror number.
PPstate
Only the physical partitions on the physical volume that are not current are shown as stale.
-n descriptorphysicalvolume Accesses information from the descriptor area specified by the descriptorphysicalvolume variable. The information may not be current, since the information accessed with the -n flag has not been validated for the logical volumes. If you do not use the -n flag, the descriptor area from the physical volume that holds the most validated information is accessed, and therefore the information displayed is current. The volume group need not be active when you use this flag.
-o Lists only the active volume groups (those that are varied on). An active volume group is one that is available for use.
-p Lists the following information for each physical volume within the group specified by the volumegroup parameter:
Physical volume
A physical volume within the group.
PVstate
State of the physical volume.
Total PPs
Total number of physical partitions on the physical volume.
Free PPs
Number of free physical partitions on the physical volume.
Distribution
The number of physical partitions allocated within each section of the physical volume: outer edge, outer middle, center, inner middle, and inner edge of the physical volume.
-P Lists the mirror pool that each physical volume in the volume group belongs to.

Information displayed if you do not specify any flags:

Item Description
VOLUME GROUP Name of the volume group. Volume group names must be unique systemwide and can range from 1 to 15 characters.
VOLUME GROUP STATE State of the volume group. If the volume group is activated with the varyonvg command, the state is either active/complete (indicating all physical volumes are active) or active/partial (indicating some physical volumes are not active).
PERMISSION Access permission: read-only or read-write.
MAX LVs Maximum number of logical volumes allowed in the volume group.
LVs Number of logical volumes currently in the volume group.
OPEN LVs Number of logical volumes within the volume group that are currently open.
TOTAL PVs Total number of physical volumes within the volume group.
ACTIVE PVs Number of physical volumes that are currently active.
VG IDENTIFIER The volume group identifier.
PP size Size of each physical partition.
TOTAL PPs Total number of physical partitions within the volume group.
FREE PPs Number of physical partitions not allocated.
ALLOC PPs Number of physical partitions currently allocated to logical volumes.
QUORUM Number of physical volumes needed for a majority.
VGDS Number of volume group descriptor areas within the volume group.
AUTO-ON Automatic activation at IPL (yes or no).
CONCURRENT States whether the volume group is Concurrent Capable or Non-Concurrent Capable.
AUTO-CONCURRENT States whether you should autovary the Concurrent Capable volume group in concurrent or non-concurrent mode. For volume groups that are Non-Concurrent Capable, this value defaults to Disabled.
VG MODE The vary on mode of the volume group: Concurrent or Non-Concurrent.
NODE ID Node id of this node if volume group is varied on in concurrent node.
ACTIVE NODES Node ids of other concurrent nodes that have this volume group varied on.
MAX PPs Per PV Maximum number of physical partitions per physical volume allowed for this volume group.
MAX PVs Maximum number of physical volumes allowed in this volume group. This information is displayed only for 32 and 128 PV volume groups.
LTG size Logical track group size of the volume group. The maximum amount of data that can be transferred in one I/O request to the disks of the volume group. The LTG size will be displayed in kilobytes unless the LTG size is greater than 1 MB, in which case megabytes will be used. If the volume group was created on AIX® 5.3, then it is capable of dynamically determining the LTG size based-on the disk topology and it is listed as Dynamic. If that capability is disabled by the user with the varyonvg -M option, then it will be listed as Static. If the capability does not exist because the volume group was created prior to AIX 5.3, then the VG will not be listed as Static or Dynamic.
BB POLICY Bad block relocation policy of the volume group.
SNAPSHOT VG Snapshot volume group name if the snapshot volume group is active, else snapshot volume group identifier.
PRIMARY VG Original volume group name of a snapshot volume group if the original volume group is active, else original volume group identifier.
PV RESTRICTION Displays the existing PV type restriction on the physical volumes comprising the volume group. A value of none indicates no PV restriction exists for the volume group. A value of SSD indicates the volume group has a PV restriction requiring all PVs to be SSD type PVs. No other values are supported.
INFINITE RETRY Lists the infinite retry option of the volume group.
CRITICAL VG Lists whether the Critical VG option is turned on or off for the volume group.
FS SYNC OPTION Lists whether the logical volume manager resynchronizes the blocks allocated only by the Enhanced Journaled File System (JFS2), if JFS2 is mounted.
CRITICAL PVs Lists Critical PVs option of the volume group. This information is available in IBM® AIX 7.2 with Technology Level 1, or later.
ENCRYPTION Lists the data encryption option of the volume group. This information is available in AIX 7 with 7200-05, or later.

Examples

  1. To display the names of all active volume groups, enter the following command:
    lsvg  -o
  2. To display the names of all volume groups within the system, enter the following command:
    lsvg
  3. To display information about volume group vg02, enter the following command:
    lsvg vg02
    The characteristics and status of both the logical and physical partitions of volume group vg02 are displayed.
  4. To display the names, characteristics, and status of all the logical volumes in volume group vg02, enter the following command:
    lsvg  -l vg02

Files

Item Description
/usr/sbin Contains the directory where the lsvg command resides.