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Chapter 1. Administrator's guide
The following instructions are for administrators at sites with the license type concurrent license for IBM®
SPSS® Amos 27. This license allows you to install IBM SPSS Amos on any number of computers. However,
only the number of users for which you purchased the license can run the application concurrently.

Before you start
You will need your authorization code. The authorization code enables you to get a license for the
concurrent license manager. The concurrent license manager controls your concurrent license and
allows end users to run IBM SPSS Amos.
You should have received separate instructions for obtaining your authorization code. If you cannot find
your authorization code, contact Customer Service by visiting .
To ensure that you set up the concurrent license correctly, follow these steps:
1. Install the concurrent license manager. The concurrent license manager is the utility that will serve
up the concurrent licenses to end users. You can install the license manager on any computer on your
network. This is typically a server to which desktop computers can connect. See the topic “Installing
the concurrent license manager” on page 1 for more information.
2. License your product. This action will give the license manager the required information for serving up
the licenses.
3. Test the concurrent license manager. You should test license manager to make sure it is serving up
licenses. See the topic “Testing the license manager” on page 8 for more information.
4. Install IBM SPSS Amos on the local desktop computers. You or your end users will complete the full
installation on the desktop computers. During an installation, an end user can specify the computer on
which the license manager is running. When an end user tries to launch IBM SPSS Amos, the product
communicates with this license manager to get a license. If a license is available, IBM SPSS Amos
launches. See the topic “Installing the product on the local desktop computers” on page 9 for more
information.
No administration steps are required for the installation, but if any problems arise, see “Administering the
concurrent license” on page 12.

Ghosting
You can ghost the software by installing the license manager and then installing the product on a local
desktop that will be used for creating the ghosting image. Ghost the additional computers as needed.

Citrix and Terminal Services
You can install and publish the IBM SPSS Amos application on your Citrix or Terminal Services Server the
same way that you install and publish other Windows applications.

Installing the concurrent license manager
Before end users install IBM SPSS Amos on their desktop computers, you must install the concurrent
license manager. This utility is a continuously executing service or daemon that you will typically install on
one computer on your network. (You also have the option of installing on multiple computers, in which
case you would set up redundant license managers. For more information, see the topic “Setting up
redundant license servers” on page 14 .) You do not install the concurrent license manager on the end
users' desktop computers.
Whenever an end user starts a concurrent-licensed IBM SPSS application, the application will request a
license from the license manager. This utility will deliver licenses up to a fixed number of simultaneous
end users, determined by the license that you have purchased. After this number has been met, any

further requests for licenses will be refused. If you find that end users are often being refused licenses,
you can contact your sales representative to purchase a license that will allow more simultaneous users.
License managers are available on a separate DVD/CD. They can also be downloaded as an eImage.
Note: The license manager will record the number of active end-user sessions and information about
each session in a log file, which you can use to troubleshoot connection problems. See the topic
“Obtaining log information” on page 13 for more information.
Multiple operating systems
The platform on which the concurrent license manager is running does not have to match the platform on
which the client is running. For example, a Linux license manager can serve up licenses for Windows
clients.
•
Administering the license manager
You administer the license manager using the license manager administrator, which is available only for
Windows. Therefore, you need at least one Windows machine on which to install the license manager
administrator.
System requirements
The computer on which you install the concurrent license manager must meet the minimum operating
system requirements. The license manager does not require a server class machine.
Important: If a firewall is running on the computer on which the license manager is installed, you must
open port 5093 for UDP. Otherwise, client computers will not be able to retrieve a license from the license
manager. Furthermore, if you are using redundant license manager machines, you must open port 5099
for UDP to enable the license manager machines to communicate with each other.

Upgrading the license manager
If you have a previous version of the license manager installed, you must perform the following steps:
1. Go to the directory in which you installed the old license manager.
2. Copy the lservrc file. On Windows, look in the winnt subdirectory.
3. Save the lservrc file to a safe location.
4. If any users have checked out commuter licenses, make sure those users check the licenses back in.
See the topic “Configuring commuter licenses” on page 15 for information about obtaining a list of
checked out licenses.
5. Shutdown the license manager. See the topic “Starting and stopping the license manager” on page
17 for more information.
6. Unininstall the old license manager. See the topic “Uninstalling the license manager” on page 18 for
more information.
7. Install the new license manager. For information about installing on Windows, see the topic “Installing
the license manager on Windows” on page 3 . For information about installing on UNIX/Linux, see
the topic “Installing the license manager on non-Windows systems” on page 3. For information
about installing on macOS, see the topic “Installing the license manager on macOS” on page 3.
8. Copy the saved lservrc file to the directory in which you installed the new license manager. If you
accepted the default location on Windows, check the C:\Program Files (x86)\Common Files
\SafeNet Sentinel\Sentinel RMS License Manager\WinNT folder.

2 IBM SPSS Amos Concurrent License Administrator’s Guide

Installing the license manager on Windows
Note: You must launch the installer as administrator. When instructed to launch an installer file, rightclick the file and choose Run As Administrator.
Note: Ensure that the machine on which you are installing has Java installed.
1. Insert the concurrent licensing tools DVD/CD into the DVD/CD drive of the network computer on which
you want to run the license manager. Copy the archive that contains the license manager and tools for
your Windows operating system from the DVD/CD.
-orIf you downloaded an eImage file, use an archive utility such as WinZip to extract all the files in the
appropriate eImage.
2. Extract the contents of the archive that contains the license manager and tools.
3. Run setup.exe from the extracted manager directory and follow the instructions that appear on the
screen.
4. To install the license manager administrator on the same machine as the license manager, run
setup.exe from the extracted tools directory and follow the instructions that appear on the screen.
You also have the option of installing the license manager administrator on another Windows machine
if you want to administer the license manager remotely.
Important: If you choose to install the tools (installs the license manager administrator) on the same
machine as the manager, then the manager must be installed first. Also, if you choose to install in a
location that is different from the default location, then both the manager and tools must be installed to
that same location.

Installing the license manager on non-Windows systems
1. Insert the concurrent licensing tools DVD/CD into the DVD/CD drive of the network computer on which
you want to run the license manager. Look for the archive that contains the license manager and tools
for your operating system.
-orIf you downloaded an eImage file, go to the location where you downloaded the file.
2. Go to the location where you downloaded your eImage file.
3. Extract the contents of the archive that contains the license manager and tools to the location where
you want to install the license manager.
4. Install the license manager administrator on a Windows machine. See the topic “Installing the license
manager administrator ” on page 4 for more information.
5. Refer to “Starting and stopping the license manager” on page 17 for information about starting the
license manager.

Installing the license manager on macOS
1. Insert the concurrent licensing tools DVD/CD into the DVD/CD drive of the network computer on which
you want to run the license manager. Look for the archive that contains the license manager and tools
for your operating system.
-orIf you downloaded an eImage file, go to the location where you downloaded the file.
2. Extract the contents of the archive that contains the license manager and tools to the location where
you want to install the license manager.
3. Install the license manager administrator on a Windows machine. See the topic “Installing the license
manager administrator ” on page 4 for more information.
4. Refer to “Starting and stopping the license manager” on page 17 for information about starting the
license manager.
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Installing the license manager administrator
The Windows-only license manager administrator is used to administer the license manager. If you
installed the license manager on a non-Windows machine, you must install the license manager
administrator on a Windows machine.
1. Insert the concurrent licensing tools DVD/CD into the DVD/CD drive of the Windows network computer
on which you want to run the license manager administrator. Copy the archive that contains the
license manager and tools from the DVD/CD.
-orIf you downloaded an eImage file, use an archive utility such as WinZip to extract all the files in the
appropriate eImage.
2. Extract the contents of the archive that contains the license manager and tools.
3. Run setup.exe from the extracted tools directory and follow the instructions that appear on the
screen.

Licensing your product
After the main part of the installation is complete on Windows, click Finish to launch the License
Authorization Wizard. The License Authorization Wizard allows you to obtain a license for IBM SPSS
Amos. On other operating systems, you must install the license from the command prompt after installing
the license manager.
If you do not get a license now, you can enable IBM SPSS Amos to be used for a temporary usage period
by a limited number of users. After the temporary usage period has completed—and which begins when
the product is first used—IBM SPSS Amos will no longer run. Therefore, it is recommended that you obtain
a license as soon as possible. You must either obtain a license or enable for temporary usage to use IBM
SPSS Amos.
Note: Licenses are tied to the network computer's physical or virtual hardware with a lock code. If you
replace the network computer or its hardware, you will have a new lock code and will need to contact
your sales representative to obtain a new authorization code. If you are installing on a virtual machine,
you need to ensure that you select a lock code that does not change on restart. For more information, see
“Installing a license in a virtual environment” on page 4.
Important: The license is sensitive to time changes. If you must change the system time and then cannot
run the product, contact the Client Care team for assistance by visiting .

Installing a license in a virtual environment
If you installed the concurrent license manager in a virtual environment, there are special instructions for
licensing. On a virtual machine the hardware is virtual, and the locking code that ties the license manager
to the license might change when the virtual machine is restarted. To ensure the license manager works
correctly, you need to find a locking code that does not change when the virtual machine is restarted.
When you find a stable locking code, you will use it to license the license manager.
Important:
If you choose a locking code that does change on reboot, the license manager will stop working. The IBM
SPSS application will not be able to retrieve a license and will fail to start.
Checking the locking code
1. Open a command prompt.
2. Change to the following directory.
• Windows. If you accepted the default location during installation, the license manager installation
directory is C:\Program Files (x86)\Common Files\SafeNet Sentinel\Sentinel RMS
License Manager\WinNT.
• Other platforms. The license manager installation directory.
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3. At the command prompt, type echoid (Windows) or ./echoid64 (other platforms).
You will see something like the following in the output:
Locking Code 1 :

4-12A1B

The number that appears immediately before the hyphen (-) is the locking code criteria. The locking code
criteria is a number that represents the virtual hardware that is used for the locking code (in this example,
it is 4, which represents the OS volume serial ID). The number after the hyphen is the locking code itself
(in this example, it is 12A1B).
Following are the possible locking code criteria.
Locking code criteria

Virtual hardware

2

IP address

4

OS volume serial ID

8

Hostname

10

Ethernet card

Confirming that the locking code is stable
1. After checking the locking code, restart the virtual machine.
2. Check the locking code again (see “Checking the locking code” on page 4).
• If the locking code doesn’t change, reboot and check a few more times. If the locking code is stable,
you are ready to license (see “Licensing the license manager with the new locking code” on page
5).
• If the locking code does change, you need to update the locking code (see “Updating the locking
code” on page 5).
Updating the locking code
1. In a text editor, open echoid.dat, which you can find in the following directory.
• Windows. If you accepted the default location during installation, the license manager installation
directory is C:\Program Files (x86)\Common Files\SafeNet Sentinel\Sentinel RMS
License Manager\WinNT.
• Other platforms. The license manager installation directory.
2. You will see a single hexadecimal number that represents the current locking code criteria. Change
this number to one of the acceptable locking code criteria in hexadecimal format.
Locking code criteria in hexadecimal format

Virtual hardware

0x002

IP address

0x004

OS volume serial ID

0x008

Hostname

0x010

Ethernet card

Licensing the license manager with the new locking code
After you find and update to a stable locking code, there are no further licensing steps that are particular
to virtual environments. Use the command prompt to complete installation of the license.

Chapter 1. Administrator's guide 5

Using the license authorization wizard (Windows only)
Note: You might be prompted for administrator credentials. Without the correct credentials, you will not
be able to run the License Authorization Wizard.
1. If you don't launch the License Authorization Wizard during installation or cancel the License
Authorization Wizard before obtaining a license, you can launch it by running law.exe, which can be
found the license manager installation directory. You must run as administrator. Right-click law.exe
and choose Run As Administrator.
2. When prompted, choose License my product now. If you want to enable for temporary usage instead,
refer to .
3. When prompted, enter one or more authorization codes.
You should have received separate instructions for obtaining your authorization code. If you cannot
find your authorization code, contact Customer Service by visiting .
The License Authorization Wizard sends your authorization code over the Internet to IBM Corp. and
automatically retrieves your license. If your computer is behind a proxy, click Configure proxy settings
and enter the appropriate settings.
If the authorization process fails, you will be prompted to send an e-mail message. Choose whether you
want to send the e-mail message through your desktop e-mail program or through a Web-based e-mail
application.
• If you choose the desktop option, a new message with the appropriate information will be created
automatically.
• If you choose the Web-based option, you must first create a new message in your Web-based e-mail
program. Then copy the message text from the License Authorization Wizard and paste it into your email application.
Send the e-mail message and respond to the prompt in the License Authorization Wizard. The e-mail
message will be processed almost instantaneously. You can click Enter License Code(s) to enter any
license code(s) that you receive. If you already closed the License Authorization Wizard, restart it and
select License my product now. On the Enter Codes panel, add the license code that you received and
click Next to complete the process.

Installing a license from the command prompt
You have two options for installing from the command prompt. You can use licenseactivator to get a
license from the Internet automatically, or you can use echoid to get a license manually.
Using licenseactivator to install a license automatically
The computer on which you are installing the license must be connected to the Internet. If it isn't, install
the license manually. See the topic “Installing a license manually” on page 7 for more information.
1. Log in as the user who installed the license manager.
2. Open a command prompt and change directories to the license manager installation directory. This is
the directory in which you installed the license manager, not the directory in which you installed IBM
SPSS Amos. If you accepted the default location on Windows, check the C:\Program Files
(x86)\Common Files\SafeNet Sentinel\Sentinel RMS License Manager\WinNT folder.
3. You typically have an authorization code. In the simplest case, you enter the following at the command
prompt. See below for more details about the command prompt usage.
licenseactivator <auth-code>
where <auth-code> is your authorization code.
You should see a message that the license was added successfully. If it wasn't, note the error code and
try installing the license manually. See the topic “Installing a license manually” on page 7 for more
information.
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When you use licenseactivator, it licenses the product and writes a log file to its directory. The name of
the log file is licenseactivator_<month>_<day>_<year>.log. If any errors occur, you can check the log file
for more information. This information is also useful if you contact IBM Corp. for support.
Using licenseactivator with authorization codes
licenseactivator is typically used with one or more authorization codes that you received when you
purchased the product. Enter all of the text on one line.
licenseactivator authcode1[:authcode2:...:authcodeN] [PROXYHOST=proxy-hostname][PROXYPORT=proxy-port-number]
[PROXYUSER=proxy-userid] [PROXYPASS=proxy-password]

Note: Use ./licenseactivator when working with macOS.
• Multiple authorization codes are separated by colons (:).
• The proxy settings are optional, but you may need them if your computer is behind a proxy. Which proxy
settings are needed depend on your specific proxy configuration. You might need all of them.
PROXYHOST
The server name or IP address of the proxy host
PROXYPORT
The port number for connecting to the Internet through the proxy
PROXYUSER
If required, the user ID for the proxy
PROXYPASS
If required, the password associated with the user ID
Using licenseactivator with license codes
In less common scenarios, IBM Corp. may have sent you a license.
licenseactivator licensecode[:licensecode2:...:licensecodeN]

Note: Use ./licenseactivator when working with macOS.
• Multiple license codes are separated by colons (:).
• When using license codes, licenseactivator does not connect to the Internet, so you do not need to
specify proxy information.
macOS-specific licenseactivator features
The following features and setting are specific to running licenseactivator on macOS systems.
Setting a network license
The following example demonstrates setting a network license:
./licenseactivator LSHOST= COMMUTE_MAX_LIFE=7

Licensing via the activation.properties file
The following example demonstrates using the activation.properties file to license the
product.
./licenseactivator -f activation.properties

An activation.properties file template is provided in <installation directory>/
Resources/Activation.
Note: Enter ./licenseactivator --help in a Terminal window to display the full list of
licenseactivator options.
Installing a license manually
1. Log in as the user who installed the license manager.
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2. Open a command prompt and change directories to the license manager installation directory. Note
that this is the directory in which you installed the license manager, not the directory in which you
installed IBM SPSS Amos. If you accepted the default location on Windows, check the C:\Program
Files (x86)\Common Files\SafeNet Sentinel\Sentinel RMS License Manager\WinNT
folder.
3. Get the lock code for the server machine. At the command prompt, type echoid (Windows) or ./
echoid64 (other platforms).
4. Send the lock code and your authorization code to IBM Corp. by calling your local office or sending an
e-mail message to spsscs@us.ibm.com. IBM Corp. will then provide a license code or a file containing
a license code.
5. Use licenseactivator to enter the license code or codes.

Enabling for temporary usage
If you did not install the license, you can enable IBM SPSS Amos for temporary usage.
1. If you have physical installation media, make sure that the DVD/CD is in the DVD/CD drive. If you
downloaded an eImage, open and/or extract the contents of the eImage.
2. Start the WlmAdmin application. See the topic “Starting the WlmAdmin Application” on page 13 for
more information.
3. In the left pane of the WlmAdmin application, click the + sign next to Subnet Servers. If the license
manager server is not listed, specify the computer by choosing Defined Server List from the Edit
menu.
4. Right-click the name of the network computer on which the license manager is running and choose:
Add Feature > From a File > To Server and its File
Note: If you select To Server rather than To Server and its File, the temporary usage information is
stored in memory. You will lose this information when the network computer is rebooted.
5. In the Open dialog box, type D:\Windows\Administration\Licensing
\NeworkLicenseManager\lservrc.temp , where D is your installation disk drive. If you are not
using D for the disk drive, enter the appropriate drive location. If you downloaded an eImage, type
<eImage>\Administration\Licensing\NeworkLicenseManager\lservrc.temp, where
<eImage> is the location where you opened/extracted the eImage files.
6. When the application displays your license, click OK. For information about viewing the license's
details, see “Viewing details about a license” on page 13 .

Adding a license
You may want to add a license at a later time. The process for adding a license is the same as installing
the original license.

Viewing your license
You can view your concurrent license (including the number of users) in the WlmAdmin application. For
information about the WlmAdmin application and specifics about viewing the license, see “Administering
the concurrent license” on page 12 .

Testing the license manager
To make sure the license manager is serving up licenses correctly, you should test it.
1. If you haven't installed the license manager administrator on another machine, install it on a Windows
machine that is not running the license manager you want to test. See the topic “Installing the license
manager administrator ” on page 4 for more information.
2. Install another license manager on a Windows machine that is not running the license manager you
want to test. See the topic “Installing the license manager on Windows” on page 3 for more
information.
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3. Start the WlmAdmin application. See the topic “Starting the WlmAdmin Application” on page 13 for
more information.
4. Add the remote license manager server that you want to test. See the topic “Adding a server” on page
13 for more information.
5. View the licenses on the remote server. See the topic “Viewing details about a license” on page 13
for more information.
If you are able to view the license, the license manager is ready for local desktop computers to connect to
it. You can proceed with installing the product on local desktop computers. If you are not able to view the
license, review the previous steps to ensure the license manager was installed correctly.

Installing the product on the local desktop computers
You have two options for installing the full product locally on an end user's computer. You can manually
install on each computer, or you can use an application like Systems Management Server (SMS) to push
the installation to the computers running Windows.
To manually install on a local desktop
1. Make the installation media available. Download the eImage for the product and extract the files to
a shared network drive. If you have physical installation media, make as many copies of the DVD/CD as
you need or place it on a shared network drive.
2. Copy the installation instructions and prepare licensing information. Make as many copies of the
product installation instructions as you need. The installation instructions are available from the
download site or, if you received physical installation media, in the directory on the DVD/CD. Look for
the instructions that correspond to your license type. After installation, the end user must enter the IP
address or the name of the network computer on which the concurrent license manager is running. Fill
out this information in the space provided at the beginning of the instructions before copying them.
3. Distribute the installation materials to end users. Distribute the downloaded file (or network
location, or installation DVD/CD), the installation instructions, and the licensing information to end
users who can manually install on each computer as needed.
To push to the local desktops running Windows
Because IBM SPSS Amos installations are compatible with Microsoft Windows Installer (MSI), you can
push an installation to the end-user desktop computers.

Pushing an installation to Windows computers
Pushing an installation is a method for remotely distributing software to any number of end users without
any user intervention. You can push the full installation of IBM SPSS Amos to the end-user desktop
computers running Windows. The technology that you are using for pushing the installation must support
the MSI 3.0 engine or higher.
Uninstalling a Previous Version
If you are going to push to the same directory in which a previous version of IBM SPSS Amos was
installed, you need to uninstall the old version. You can push the uninstallation as you push an
installation. See the topic “Pushing an uninstallation” on page 12 for more information.
Properties for push installations
Following are the properties that you can use for push installations. All properties are case sensitive.
Values must be quoted if they contain spaces.
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Table 1. Properties for push installations
Property

Description

Valid values

INSTALLDIR

The directory where IBM A valid path such as
SPSS Amos should be
C:\Amos.
installed on the end
user's desktop
computer. This property
is optional. If it is
excluded, the default is
C:\Program Files\IBM
\SPSS\AMOS\27 .

LICENSETYPE

The license type. The
value is case sensitive.

Network

LSHOST

The IP addresses or the
names of the network
computer or computers
on which the concurrent
license manager is
running.

One or more valid IP
addresses or network
computer names.
Multiple addresses or
names are separated by
tildes (for example,
server1~server2~server3
).

DISABLE_COMMUTE

Disables the commuter
license functionality on
the end user's desktop
computer. If commuter
licenses are disabled, no
shortcuts for the
commuter license will
be installed on the
desktop computer. For
more information about
commuter licenses, see
“Configuring commuter
licenses” on page 15 .

1, which indicates that
commuter licenses are
disabled.

C:\Program Files\IBM
\SPSS\AMOS\27

1

0, which indicates that
commuter licenses are
enabled.

COMMUTE_MAX_LIFE

The maximum number
A number between 1
of days for which an end and 30.
user can check out a
commuter license. See
the topic “Configuring
commuter licenses” on
page 15 for more
information.

COMPANYNAME

The name of your
company.

ENABLE_CONNECTIONS Enables and disables
Internet connectivity
features (information
sharing, error reporting,
and welcome screen
updates).

Default (If Applicable)

Any string.
YES or NO
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MSI files
The IBM SPSS Amos 27.msi file is located under the Windows\Amos directory on the DVD/CD . If you
downloaded the software, you must extract the contents of the eImage to access the MSI file.
Command line example
Following is a command line that you could use to push a product installation. Enter all of the text on one
line.
MsiExec.exe /i "IBM SPSS Amos 27.msi" /qn /L*v logfile.txt
INSTALLDIR="C:\Amos" LICENSETYPE="Network" LSHOST="mylicserver"
Using SMS to push the installation
The basic steps for using Systems Management Servers (SMS) to push IBM SPSS Amos are:
1. Copy the appropriate subdirectory under the Windows\Amos directory on the DVD/CD to a directory on
a network computer. If you downloaded the software, you must first extract the contents of the
eImage.
2. Edit the IBM SPSS Amos 27.sms file located in the copied directory. Using a text editor, modify the
value of CommandLine by adding the appropriate properties. For a list of the available properties, refer
to “Properties for push installations” on page 9 . Make sure to specify the correct MSI file in the
command line.
3. Create a package from the IBM SPSS Amos 27.sms file and distribute the package to the end-user
desktop machines.
Using Group Policy or related technology to push the installation
1. Copy the appropriate subdirectory under the Windows\Amos directory on the DVD/CD to a directory on
a network computer. If you downloaded the software, you must first extract the contents of the
eImage.
2. Using an application like ORCA, edit the Properties table in the appropriate IBM SPSS Amos 27.msi file
under the copied folder. ORCA is part of the Windows 2003 Server SDK, which you can find at http://
www.microsoft.com/downloads by searching for the SDK. For a list of the properties that you can add
to the Properties table, refer to “Properties for push installations” on page 9 . Make sure to use the
correct MSI file.
3. Create a package using the edited IBM SPSS Amos 27.msi file and distribute the package to the enduser desktop computers.
Pushing the installation to a non-English system
You can push to a non-English system without additional specification. However, the installer language (if
pushing an interactive installation) will appear in English, the user interface will appear in English, and the
help will appear in English. Users can change the user interface language after installation, but localized
help will not be available.
You can use the TRANSFORMS property to specify one of the MST files available on the DVD/CD or in the
downloaded eImage. The MST file will ensure the installer, user interface, and help appear in the
specified language. MST files are not available if you downloaded IBM SPSS Amos. Users will need to
manually install the language packs for the localized help and manually change the user interface
language in the product.
The TRANSFORMS property is a parameter for MsiExec.exe. The following example uses the TRANSFORMS
property to push a French installation. The installer will appear in French, the user interface will appear in
French, and French help will be installed. (You can also override the help language with the HELPCHOICE
property. See the topic “Properties for push installations” on page 9 for more information. ) Enter all of
the text on one line.
MsiExec.exe /i "IBM SPSS Amos 27.msi" /qn /L*v logfile.txt
INSTALLDIR="C:\Amos" LICENSETYPE="Network" LSHOST="mylicserver" TRANSFORMS=1036.mst
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The following language MST files are located in the Windows\Amos directory on the DVD/CD . If you
downloaded an eImage, these files are located at the root of the extracted eImage files.
Table 2. Language MST Files
Language

MST File

English

1033.mst

Japanese

1041.mst

Pushing an uninstallation
Note: When you push the uninstall command, the end user loses customizations. If specific users require
customizations, you can exclude those users from the distribution and ask them to install the product
manually.
If you push an installation of a later version of IBM SPSS Amos, you may want to uninstall first. You can do
this silently by pushing the following command. Enter all of the text on one line.
MsiExec.exe /X{A24026D3-0E0B-49F1-8FC8-65E254EB421F} /qn /L*v logfile.txt
ALLUSERS=1 REMOVE="ALL"

This command will uninstall IBM SPSS Amos 27. The following table lists the uninstall IDs for this and
previous releases.
Table 3. Uninstall IDs for IBM SPSS Amos
Version

Uninstall ID

27.*

{5714B6D0-2C14-49BB-B560-25CB36AE2AF3}

26.*

{C31442F6-4B76-4022-9822-7F60F3EA70D8}

25.*

{28C51A52-9B61-4589-91DE-8C5FAEA00B10}

24.*

{A24026D3-0E0B-49F1-8FC8-65E254EB421F}

23.*

{2B603859-DCA2-45DD-92DF-98542E78BAA8}

22.*

{DEB57287-C937-4DE9-939A-5ED3AB8F052D}

21.*

{304B71E3-1017-4717-86BC-F1D18519FEF2}

20.*

{58C50F5A-B7E2-4149-8911-B14CEC825F57}

19.*

{B132EFD2-BF03-48AA-8EC8-404E4C5199C5}

18.*

{65D9DA69-4C22-46CA-B762-A338CAC94599}

17.*

{9DB2E18E-2A1F-4D65-A258-9CB446903C3E}

16.*

{4DA782CB-C9A0-462F-9D18-17D301BC507C}

Administering the concurrent license
The license manager maintains your concurrent license. To administer the license manager itself and to
view information about the concurrent licenses that it is maintaining, you can use the WlmAdmin
application, which is the main user interface for the license manager administrator. The license manager
administrator is installed automatically with the concurrent license manager on Windows. If you are
administering a license manager on a non-Windows machine or a remote Windows machine, install the
license manager administrator on a separate Windows machine. See the topic “Installing the license
manager administrator ” on page 4 for more information.
Note: If you need additional administration information, refer to the SafeNet documentation, which is
installed with the license manager administrator. This documentation is in the help\Content directory in
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the license manager administration installation directory (for example, C:\Program
Files(x86)\Common Files\SafeNet Sentinel\Sentinel RMS License Manager\WinNT).

Starting the WlmAdmin Application
From the Windows Start menu, choose:
[All] Programs > IBM > SPSS License Tools > <version> > Sentinel RMS Server Administration

Adding a server
Before you can administer a license manager, you need to add its server to the WlmAdmin application.
You have two options for adding the server.
To manually add a server
1. From the WlmAdmin application menus, choose:
Edit > Defined Server List
2. In the Defined Server List dialog, enter the name or IP address of the server on which the license
manager is running.
3. Click Add.
4. Click OK.
The server now appears in the Defined Servers lists in the left pane of the WlmAdmin application.
To view a list of servers on the subnet
1. In the left pane of the WlmAdmin application, click the + sign next to Subnet Servers.
A list of license manager servers on your subnet appears. If you can't find a specific server with this
method, manually add it as described above.

Obtaining log information
If end users have difficulty checking out licenses, the log files may contain useful information. You can
use the LSERVOPTS environment variable and the -f <trace-log-file> and -l <usage-logfile> options to specify that log files should be created. For more information about this environment
variable and its options, refer to the SafeNet documentation in the Content directory in the license
manager administrator installation directory.

Viewing details about a license
You can view details about licenses that you added either manually or through the License Authorization
Wizard.
1. In the left pane of the WlmAdmin application, click the + sign next to the license manager server to see
the license(s).
2. Click the name of the license. The right pane displays details about the license. Codes are used to
identify the licenses. The first part of the code indicates the feature. The second part indicates the
version.
To see the names associated with the feature codes
1. Using a command prompt, change to the directory in which the license manager administrator is
installed.
2. Type lmshowlic <server> (Windows) or ./lmshowlic <server> (other operating systems),
where <server> is the name or IP address of the server on which the license manager is running.
The output lists all the features available on the server, grouped by product and version.
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Setting up redundant license servers
You can set up multiple, redundant license servers that support the same users. Redundant servers can
help prevent any interruption that may occur when a server crashes. Another redundant server can take
over the management of the license when the first server crashes.
You will need a special license code to enable the redundancy feature, as described in the following
steps. For assistance with creating a redundant license key or any other licensing issue, contact IBM
Support by phone or e-mail. You can find contact information at http://www.ibm.com/planetwide.
There must be an odd number of servers (at least three of them), and a majority must be running at the
same time. For example, if there are three redundant license servers, two of them must be running.
To prepare each redundant license server
1. Install the license manager. See the topic “Installing the concurrent license manager” on page 1 for
more information.
2. Using a command prompt, change to the directory in which you installed the license manager.
3. Get the lock code for each server machine. At the command prompt, type echoid (Windows) or ./
echoid64 (other operating systems).
4. Write down the lock code. You will need the lock code for the next steps.
5. Repeat these steps for each redundant license server.
To activate the redundant licenses
1. Go to the IBM SPSS License Key Center (https://spss.subscribenet.com/control/ibmp/login).
2. Create a concurrent authorization code.
3. After the concurrent authorization code is created, click the code and then scroll down until you see
the fields for Lock Code. You will now have the ability to add multiple lock codes to the license key.
4. Using the lock codes from the previous steps, enter the lock codes into the appropriate fields.
5. Click Submit.
To set up the redundant license server pool
1. If a license manager is running on any of the redundant license servers, stop the license manager on
each computer.
2. From the WlmAdmin application menus, choose:
Edit > Redundant License File
This action opens the WrlfTool application.
3. From the WrlfTool application menus, choose:
File > New
4. For each redundant license server, click Add to specify the hostname and IP address of each server.
5. Change the order of the servers to indicate the order in which the redundant license servers are used.
The first one in the list is the primary server.
6. Click Add License to add the license(s) that you received from Customer Service or your local office. If
you received multiple licenses, be sure to add every one.
7. Click OK.
8. Click Done when you are finished.
To save the redundant license file
1. From the WrlfTool application menus, choose:
File > Save As
14 IBM SPSS Amos Concurrent License Administrator’s Guide

2. Save the redundant license file (lservrlf) to an easily accessible location. You will need to copy the file
in the next steps.
To configure the redundant license servers
1. Copy the redundant license file (lservrlf) to the winnt subfolder of the license manager installation
directory on Windows. If you accepted the default location, check the C:\Program Files
(x86)\Common Files\SafeNet Sentinel\Sentinel RMS License Manager\WinNT folder.
On other operating systems, copy the file directly to the license manager installation directory. There
must be at least three redundant license servers.
2. Start the license manager on each redundant license server.
To configure end-user computers
When the end user installs the product, the user specifies all redundant servers, with the server names or
IP addresses separated by a tilde (for example, server1~server2~server3). The setup program then adds
the necessary configuration information to the end user's computer. If the product is already installed on
the desktop computers, you can perform the following manual steps to add the configuration information.
You can also push an uninstall followed by a new install that defines all the servers. Refer to “Pushing an
installation to Windows computers” on page 9 for information about pushing installations.
1. Using a text editor, open spssprod.inf. On Windows, this file is located in the product installation
directory on the desktop computer.
2. Change the value of DAEMONHOST to the server names or IP addresses separated by a tilde (~). For
example:
DAEMONHOST=server1~server2~server3

3. Save spssprod.inf.

Configuring commuter licenses
Commuter licenses allow your end users to check out licenses from the license manager, so that they can
use the license when not connected to the network. On Windows, commuter licenses are not enabled by
default. They are enabled by default on other operating systems. Instructions for actually checking out
the commuter license appear in the end user installation instructions.
You can restrict the percentage of licenses that are enabled for commuting on the license manager
server. It's a good idea to restrict commuter licenses to prevent all the licenses (tokens) from being used
up by commuters. After the specified percentage of licenses have been used by commuters, no more will
be available until the commuter licenses expire or are checked back in. You can also configure the
maximum duration for which an end user can check out a license. The default maximum duration is seven
days.
Important: If you are using redundant license servers with commuter licenses, only the primary license
server allows users to check out and check in commuter licenses. If the primary license server is down,
end users will not be able to check out and check in licenses.
To set the percentage of available commuter licenses
1. Create an LSERVOPTS environment variable on the license manager server. This variable is created
during the license manager installation on Windows, so you need to complete this step only for the
other operating systems.
2. Edit the value of the LSERVOPTS environment variable to include -com <percentage>, where
<percentage> is a numeric value between 0 and 100 indicating the percentage of licenses that are
available for commuting. Specifying 0 disables commuter licenses. This switch is included by default
on Windows and is set to 0.
3. Restart the computer on which the license manager is running.
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To set the maximum duration for commuter licenses
The maximum length of time a user can check out a commuter license is specified by the
CommuterMaxLife setting in the spssprod.inf file on the desktop computer. On Windows, this file is
located in the product installation directory on the desktop computer. Open spssprod.inf and look for
CommuterMaxLife . Set the value of this option to the maximum number of days for which an end user
can check out a commuter license. This should be a number between 1 and 30. You can also set this
value when you push the installation. See the topic “Pushing an installation to Windows computers” on
page 9 for more information.
Note: This functionality works off the date, not the time. For example, if you set the CommuterMaxLife
option to one day, then check a license out at 9 a.m., this license does not get checked back in until
midnight on the following day. So although CommuterMaxLife is set to one day, the license is actually
held for 39 hours.
To obtain a list of checked out licenses from the command line
You can find out which users have checked out licenses.
1. Using a command prompt, change to the directory in which the license manager administrator is
installed.
2. Type lsmon <server> (Windows) or ./lsmon64 <server> (other operating systems), where
<server> is the name or IP address of the server on which the license manager is running. You can
omit the license server name if you want to view checked out licenses for only the localhost server.
To obtain a list of checked out licenses from the WlmAdmin application
You can also view checked out licenses in the WlmAdmin application:
1. In the left pane of the WlmAdmin application, click the + sign next to the license manager server.
2. Click the + sign next to Clients. Clients using the concurrent license are listed. If no clients are listed,
no users are using the concurrent license.
3. Select a particular Client to view whether the client has a checked out license. Review the Detailed
Information area in the right pane after selection.

Configuring license reservations
You can create a reservation file, which specifies how many licenses are reserved for specific users or
groups of users. Users are identified by network IDs or computer names (not IP addresses). For example,
you can set up a reservation file that reserves the license for a group of power users. Licenses will always
be available for these users. You can also use the reservations to prevent certain users from accessing the
license.
To create a new reservation file
1. From the WlmAdmin application menus, choose:
Edit > Reservation File
This action opens the Wlsgrmgr application.
2. From the Wlsgrmgr application menus, choose File > New.
To add licenses and users to the reservation file
1. From the Wlsgrmgr application menus, choose:
Feature > Add
2. Click Next on the first screen of the wizard.
3. Specify the feature code associated with the license that you want to reserve. Refer to “Viewing details
about a license” on page 13 for information about getting the feature codes associated with licenses.
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Also define a specific version, which is entered as it appears in the WlmAdmin application (for
example, 160). The version is not optional. Ignore the Capacity controls, because capacity licenses are
not supported.
4. Click Next.
5. Specify a name for a group of users. The name is arbitrary, but you should make it descriptive (for
example, Sales).
6. Specify the number of licenses that are reserved for the group. Group members can still access all
licenses, but the number of licenses you specify will no longer be available for users who are not
included in the group. That is, if you have 10 licenses and you reserve five, members of the group have
10 licenses available to them, while other users have only five.
7. On the Members window, click Add to specify a user or computer name associated with the group (do
not use IP addresses). If the user or machine is included in the group, that user or machine can use the
reserved license. If the user or machine is excluded from the group, that user or machine cannot
access the license at all. Specify as many users or machines as needed. Note that groups must be
mutually exclusive. Therefore, different groups for the same license cannot contain common users or
computers.
8. Click Finish when all users have been added to the group.
9. Add other groups or licenses as needed. You can also modify or delete licenses and groups by rightclicking one and choosing Properties.
To save the reservation file
1. When finished defining the reservation file, from the menus choose:
File > Save As
2. Save the file to an easily accessible location. You will need to copy the file in the next step.
3. To enable the license server to automatically find the lsreserv file at start up, copy the file to the winnt
subfolder of the license manager installation directory on Windows. If you accepted the default
location, check the C:\Program Files (x86)\Common Files\SafeNet Sentinel\Sentinel
RMS License Manager\WinNT folder. On other operating systems, copy the file directly to the
license manager installation directory.
4. If you want the same reservations to apply for all redundant servers, copy the reservation file (lsreserv)
to each server.
5. Restart each license manager when finished.

Starting and stopping the license manager
The method for starting the license manager depends on your operating system.
Windows
On Windows machines, the license manager is a System Service. The service is automatically started by
default. However, if you need to start it manually:
1. In the Windows Control Panel, double-click Administrative Tools.
2. Double-click Services.
3. Locate Sentinel RMS License Manager in the Services list.
4. Right-click the service and choose Start or Stop.
Other operating systems
On other operating systems, the license manager is a daemon service. Complete the following steps to
start it manually. You can also configure the license manager to start automatically (instructions follow).
1. Using the command prompt, browse to the directory in which you installed the license manager.
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2. Starting. As root, type ./lserv64 & at the command prompt and press Enter.
3. Stopping. As root, type ./lsrvdown64 <hostname> at the command prompt, where <hostname> is
the network name of the computer on which the license manager is running. Then press Enter.
Configuring the license manager to start automatically
Windows
1. In the Windows Control Panel, double-click Administrative Tools.
2. Double-click Services.
3. Locate Sentinel RMS License Manager in the Services list.
4. Right-click the service and choose Properties.
5. Set the Startup type to Automatic.
6. Click OK.
Other operating systems
1. Add ./lserv64 & to one of the operating system startup files.

Uninstalling the license manager
Windows
1. From the Windows Start menu, choose:
Settings > Control Panel
2. Double-click Add/Remove Programs.
3. Select Sentinel RMS License Manager and then click Remove.
4. Click Yes when prompted to remove the license manager.
Other operating systems
1. Using the command prompt, browse to the directory to which you installed the license manager.
2. As root, stop the license manager by typing ./lsrvdown64 <hostname> at the command prompt,
where <hostname> is the network name of the computer on which the license manager is running.
Then press Enter.
3. Remove the directory where the license manager is installed.

Uninstalling the license manager administrator
1. From the Windows Start menu, choose:
Settings > Control Panel
2. Double-click Add/Remove Programs.
3. Select IBM SPSS License Tools and then click Remove.
4. Click Yes when prompted to remove the concurrent licensing tools.

Troubleshooting Desktop Computers
If the end users' desktop computers are having trouble finding the license manager:
1. Run lswhere (Windows) or ./lswhere64 (macOS and Linux) to verify that the desktop computer can
find the network computer on which the license manager is running. See the topic “Running lswhere”
on page 19 for more information.
2. Make sure the license manager service is running on the network computer.
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3. Check the appropriate spssprod.inf file. On Windows, this file is located in the product installation
directory on the desktop computer. Open spssprod.inf and make sure DAEMONHOST is set to the
correct name or IP address of the computer on which the license manager is running. If you are using
redundant servers, this should define all of them. Each name is separated by a tilde (~) character. For
example, if the license manager computers are SERVER1, SERVER2, and SERVER3, DAEMONHOST is set
to SERVER1~SERVER2~SERVER3.
Running lswhere
You can run lswhere (Windows) or ./lswhere64 (macOS and Linux) from an end user's desktop
computer to check which computer is running the concurrent license manager.
1. Using a command prompt, change the current directory to the IBM SPSS Amos installation directory.
2. Type lswhere or ./lswhere64.

Service and Support
To contact IBM Corp. Technical Support, visit http://www.ibm.com/support and submit a case. You will
need to register with IBM Corp. Technical Support if you haven't done so previously.
IBM Corp. provides public training seminars for IBM Corp. products on a regular basis. You can also
arrange to have training presented onsite. For information on training seminars, visit http://
www.ibm.com/training/spss.
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