Решение проблем функциональной совместимости спецификации WS-Security, Часть 2. Использование WebSphere Web Services Gateway

Из архивов сайта developerWorks

Чед Смит и Дэвид Ли

Дата архивации: 22.05.2019 | Впервые опубликовано: 15.02.2012

Узнайте, как использовать компонент WebSphere® Web Services Gateway из состава WebSphere Application Server Network Deployment для подключения клиентских приложений J2EE 1.3 к Web-сервисам J2EE 1.4, требующих использования WS-Security. Функциональная несовместимость версий спецификации WS-Security (рабочая версия Draft 13 и версия 1.0) не позволяет потребителям Web-сервисов J2EE 1.3 взаимодействовать с поставщиками Web-сервисов J2EE 1.4, использующими спецификацию WS-Security версии 1.0. Из этой статьи вы узнаете о том, как использовать Web Services Gateway в качестве безопасного прокси между потребителем Web-сервиса J2EE 1.3, и поставщиком Web-сервиса J2EE 1.4.

Этот контент больше не обновляется и не поддерживается. Полный текст статьи предоставляется "как есть" в формате PDF. Учитывая стремительное развитие технологий, некоторые шаги и иллюстрации могут быть изменены.



static.content.url=http://www.ibm.com/developerworks/js/artrating/
SITE_ID=40
Zone=SOA и web-сервисы
ArticleID=793849
ArticleTitle=Решение проблем функциональной совместимости спецификации WS-Security: Часть 2. Использование WebSphere Web Services Gateway
publish-date=02152012