IBM Rational ClearCase and IBM Rational ClearQuest Evaluation Guide Part 3: ClearCase

An introduction to IBM's software configuration management products

Skill Level: Intermediate

Paul Boustany (pboustan@us.ibm.com)
Software engineer
IBM

31 Oct 2006

This tutorial is intended to serve as a guide for an online demonstration of IBM® Rational® ClearCase®. Part 1 of this series is intended to help you through an online demonstration of Unified Change Management, IBM Rational's change and configuration management solution, while Part 2 guides you through an online demonstration of IBM Rational ClearQuest®.

Section 1. Before you start

In this tutorial, you will learn some of the basic tasks for using Rational ClearCase for software configuration management. You will learn how to create views to team artifact repositories (VOBs), see the history of changes to the files and display version trees, and compare and merge differences. Additionally, we'll touch on some of the basic concepts of how Rational ClearCase is used as part of a comprehensive software change and configuration management solution: Unified Change Management.

About this series
This series is for users interested in trying some of the change and configuration management capabilities of Rational ClearCase and Rational ClearQuest without installing or configuring the tools. This evaluation provides both tools in a ready to use state from inside a single Eclipse-based shell. By the end of the evaluation, you should have a feel for how Rational ClearCase and Rational ClearQuest work together to provide a complete change and configuration management solution.

About this tutorial

This tutorial provides a basic introduction to using IBM Rational ClearCase for software configuration management. Part 1, presents an overview of the Rational Unified Change Management (UCM) solution and how it uses Rational ClearCase and Rational ClearQuest to manage the software development lifecycle. Part 2 describes how to perform the basic change management tasks in IBM Rational ClearQuest.

Objectives

In this tutorial you will be fulfilling the role of a software developer, Alex, to connect to a ClearCase server, create a private copy area (view) and development stream for your working copies of team artifacts. You will then learn how to compare and merge your changes, and deliver the changes back to team's integration stream. Additionally, we'll provide a brief introduction to Unified Change Management.

Prerequisites

Basic knowledge of Rational ClearCase or software version control concepts is helpful, but not required. Once you start the trial, you have three hours to explore the application. We recommend that if you are new to Rational ClearCase, you use our evaluation guide to explore some core features.

System requirements

The online trial program uses the Citrix® Access Gateway™ platform to provide you a connection from your workstation to a remote server running the IBM product you are evaluating. You will need to download Citrix client software before using the online trial program. You can download the Citrix MetaFrame® Presentation Server™ client at no charge from the Citrix site; many versions, including versions for Windows® and Linux® platforms, are available. After you install the client, you
will be asked to restart your browser. If you do not have the Citrix client installed when you attempt to access the online trial, you will be prompted to install the client.

Section 2. Introduction to Rational ClearCase

Getting started with Rational ClearCase

IBM Rational® ClearCase® software configuration management products enable you to effectively manage and control software assets to help you deliver better applications faster and at lower cost. With features such as version control, baseline management, and build and release management, you can provide all team members with instant, controlled access to the information they need to create, update, build, deliver, reuse and maintain the software critical to your business.

For more information:
IBM Rational would be happy to work with you to determine if IBM Rational ClearCase is the right solution for you. Please do not hesitate to contact us at 1-800-728-1212 for more information.

Views and VOBs

Rational ClearCase uses views to provide access to your source code repositories, or VOBs (versioned objects bases). The views contain a series of rules which act as your configuration guide to determine which versions of the files and directories are presented.

Rational ClearCase offers two types of views: dynamic and snapshot. Dynamic views maintain a constant connection with the Rational ClearCase servers, so they automatically have the latest configuration. Snapshot views are created at a point in time and their nature suggests that they require updates to refresh their status. For this evaluation, only snapshot views will be created. To create a view, follow these steps:

1. Navigate to the ClearCase perspective, if not already there.
2. From the ClearCase menu, select Create ClearCase View.
3. You will need to connect to the ClearCase server, enter the ClearCase
web server URL:
http://localhost/ccrc

4. Enter the username/password alex/alex.

5. Keep the default entries under:
   - Copy area path name
   - Use the default config spec...
   - View Text Mode

7. Before clicking Finish to create the view, click the View config spec button.

8. This will allows you to review the configuration selection rules. By default, Rational ClearCase creates views with two rules:

   NaN The first rule will select any checkedout element.

   NaN The second rule will select the latest version on the main branch of any element.

Figure 1. Creating a view
To facilitate parallel development, Rational ClearCase views allow different users to work on the same files by specifying different configurations. Users can have views that automatically create private branches so that they can develop in a controlled workspace until their changes are to be integrated with the rest of the project.
8. Now click **Finish** to create the view.

Once the view is created, you will be prompted to load the view with elements from the VOB.

9. Click **Yes** to start the ClearCase View Configuration tool.

**Figure 2. Adding load rules for the view**
10. Select the **Show all VOBs** checkbox. Then click the **HelloWorldApp** folder and click **OK**.

The ClearCase View Configuration Window will show you the results of the snapshot view load operation.
Figure 3. Results of loading the view

Viewing change histories

This section helps to acquaint you with the variety of ways that Rational ClearCase can help you manage your project. As mentioned previously, the Rational ClearCase Remote Client (CCRC) offers a mechanism called *Snapshot* views. These types of views are characterized by the need to periodically refresh their status so that you can get an accurate view of all the artifacts. To that end, you can perform updates from a variety of locations in the Rational ClearCase Remote Client. For example, you can right-click on the view from the ClearCase Navigator and select Update Resource.

Rational ClearCase also offers a History Browser (see Figure 4):

1. Right-click on an object and select **History**.
2. Navigate to the `src` directory under the root of the `HelloWorldApp` VOB. You should find several `.java` files here.
3. Right-click on the file `HelloWorld.java` and from the Tools menu, and select **Show History**.

This report will show you the entire history of any given file or element including information about what versions, branches and labels were created and when.

Figure 4. A history report on a file
Comparing files with previous versions

Eventually you can reach the point where you need to understand how a file has changed over time. Rational ClearCase offers a diff tool (see Figure 5) that lets you compare different versions of files. Note that the Rational ClearCase Diff Merge tool has its own toolbar, the buttons of which allow you to perform actions unique to comparing and merging files. The diff tool can be accessed from many different places within the Rational ClearCase perspective.

The most common way to access the diff tool is by right-clicking on a file or directory, and from the Tools menu, clicking Compare With Predecessor. From the History menu, you can also right-click on a particular version and select Compare with Predecessor.

- Right-click on the /main/2 version from the history browser (the entry should be at the top of the list), and select Compare With Predecessor.

Figure 5. Comparing two versions of a file
You can also examine the version tree of a file or directory to get a graphical representation of an element’s history. Again, the most common way to look at the version tree would be to:

- Right-click on a file or directory from the ClearCase Navigator, then select **Tools > Show Version Tree**.

Alternatively, from the History browser (tab), you can right-click on the `/main/2` version and select Show Version Tree.

**Figure 6. The version tree of a file**

In looking at the version tree, we can determine which version is being selected by our view by looking for the magnifying glass icon. We can also see other interesting information from the version tree such as which versions have branches or labels. In this example, we can see that version 3 is being selected and version 2 is labeled with REL1. Close the Rational ClearCase Version Tree window.

Now, let’s use our config spec to select the version of this file that contains the label REL1.

1. From the ClearCase Navigator, right-click on the view and select **Show ClearCase View Configuration**. This will bring up a window similar to the one that results from a view update operation.
2. At the bottom of the workspace, click the **Version Selection Rules** tab.

**Figure 7. Version selection rules**

Now we will enter a rule that will select any version labeled with REL1. The first selection rule should read: `element * CHECKEDOUT`. This is the rule that will select `checkedout` versions above all else.

1. Put your cursor at the end of this first selection rule, and hit enter to create a new line.

2. Create a line that reads `element * REL1` (spacing and case is important).

3. Click on the checkmark button in the upper right of your workspace to apply this change.

**Figure 8. Updated version selection rules**

4. When prompted to continue, click **OK** without changing any of the options for *hijacked* files. There should be two updated files when the operation completes.

5. Navigate back to the file `HelloWorld.java` right-click it, and click **Tools > Show Version Tree**.
Your version tree should now show that you are viewing version 2. (If you didn’t previously close the version tree window, you will need to click Refresh to update the window.)

**Merging**

Rational ClearCase offers a four-step merge wizard that helps guide the merge process. The Merge Manager is a basic feature of Rational ClearCase. To evaluate the Merge Manager, we will first create a second view that will be the target for our merge operation.

1. From the ClearCase menu, select Create > ClearCase View.
2. Click Next to reuse the existing server connection and click Finish to create the view with the default options.
3. When prompted, select No to not load the view.

In this view, we will create an automatic branching rule so that all new versions created in this view will be on a private branch. However, before we create the branch rule in this view, we must first create the branch type. Branches, like labels and even versions are meta-data types that need to be defined in the VOB before they can be used.

1. From the Window menu, select Show View > ClearCase Metadata Explorer Navigator.
2. Expand the local server entry, then expand the HelloWorldApp vob. You should see Branch Types and Label Types.
3. Right-click on Branch Types and select Create Branch Type.
4. Name the branch type dev1 and click OK.

*Figure 9. Rational ClearCase Metadata Explorer*
5. Now go back to the ClearCase Navigator, right-click on the newly created view (alex_view_1) and select **Show ClearCase View Configuration**.

6. Next click on **Version Selection Rules**.

7. Create a new line after `element * CHECKEDOUT` that reads:
   
   ```
   element * .../dev1/LATEST
   ```

8. Next, put your cursor at the end of the line that reads `element *` 
   `/main/LATEST` and add the string:
   
   ```
   -mkbranch dev1
   ```

   These additions will tell your view to look for latest versions on the `dev1` branch first, and then versions on the `main` branch. It will also instruct the view to automatically create the `dev1` branch when a change is made to an element.

**Figure 10. Updated config spec rules**

9. Click the **Apply** button to accept these changes and click **OK** when prompted to continue.

10. Once that is completed, click on the **Load Rules** tab of the ClearCase
View Configuration Window for alex_view_1

11. From the upper right hand corner, click the Add button to select which VOBs to load.

12. Check the Show All VOBs checkbox and select the HelloWorldApp vob and click OK.

13. From the ClearCase Navigator, navigate to the HelloWorld.java file in the src directory.

14. Right-click on the file and select Checkout. Keep the defaults and click OK.

15. Double-click on HelloWorld.java to open the file for editing in Notepad.

16. Change the author information from jmattingly to your name. Save and close the file.

17. Right-click on the file again and select Checkin.

18. Keep the defaults and click OK.

Now that we have created a second view, let's merge the versions of elements from our first view to our second.

Starting the Merge Manager

1. In the ClearCase Navigator, click on the view alex_view_1

2. Click on the ClearCase Menu and select ClearCase Merge Search.

3. Make sure the integration view alex_view is selected as the Destination View and click Next.

4. Click the checkbox next to HelloWorldApp to select this VOB and click Next.

5. Select the first radio button Select latest from branch and click Browse.

6. Chose the branch dev1 and click OK.

7. The wizard will find the file that you change requires merging back to the
main branch. Click **Yes** on the confirmation window to automatically merge the change.

**Figure 11. Rational ClearCase Merge Manager**

8. Try to check in the file by right-clicking and selecting **Checkin**. You will be warned that there is a newer version of the element available. This is because we modified the `alex_view` view to use a label selector in its config spec. Therefore the view is no longer looking at the latest version on the main branch.

9. Click **Merge** to bring up the Merge Manager window.

**Figure 12. Rational ClearCase Diff Merge tool**
10. The Diff Merge tool has automatically resolved the difference, with zero merge points left to be resolved. Click **OK** to accept this confirmation.

11. Using the navigation buttons at the top of the window, you can navigate the differences found by the Diff Merge tool. Once you have reviewed all differences, save the results and close the window.

12. You will now be prompted to check in the results. Click the **Checkin Changes** button on the Diff Merge toolbar.

The merge wizard provides a great framework for merging but there is may be some element of human decision-making involved in reaching the objective of a final product. Rational ClearCase offers a variety of ways to get the information you need to make decisions on the state of the code and artifacts that comprise your project.

You may now wish to refresh the Version Tree browser of **HelloWorld.java**, so
you can see the final result of your merge operation. The merge is graphically represented by the line and arrow.

**Figure 13. Updated version tree for file**

This section showed you how to work in an organized configuration management environment. Rational ClearCase offers a variety of features to help order and support iterative team development efforts.

---

### Section 3. A look at Unified Change Management

IBM Rational Unified Change Management (UCM) is an important product feature, a value of Rational ClearCase that extends its mission beyond simple configuration management. This section provides an introduction to UCM, and a basic understanding of how UCM works, although a complete examination of UCM is beyond the scope of this tutorial.

UCM organizes development work into *projects*. The project includes policies that govern how developers get access to and update the *artifacts* (typically, the files and directories) used in their development effort. The concept of the UCM project involves working with *streams*, and more. Figure 14 shows the expanded workflow
activities of a Project Manager.

**Figure 14. Project manager sets up a UCM project**

Prior to working with streams, you need to set up a UCM project. First, from a tool context, Rational ClearCase offers you a ClearCase Metadata Explorer that helps to guide you through working with projects. You can start the Metadata Explorer from the Window menu in the Rational ClearCase perspective. Rational ClearCase offers a variety of wizards to help navigate the challenges of setting up a project that can sometimes be pretty complex in configuration.

**Figure 15. Clearase MetaData Explorer**
A Rational ClearCase work area is defined by both views and the concept of a *stream*. A project typically has at least one integration stream, which is part of the public workspace, and multiple development streams, each of which is part of a developer's private workspace. As you work with other developers, your work is delivered to the integration stream. Within the concept of the UCM, the ability to work with activities helps to provide overall team management and allows you some degree of isolation to work and collaborate undisturbed. In Figure 16 from the "IBM Rational ClearCase Guide to Building Software, 7.0," various developers have views to activities but they all are based upon the Versioned Object Base, or VOB, as symbolized by the foundational cube at the bottom of the figure.

**Figure 16. Concept architecture for the UCM project**
The stream really does the heavy lifting, meaning that it is a core feature that helps do the configuration and versioning. The stream is a critical member of a single UCM project and its job is to be the manager for the configuration. It identifies the right set of versions of objects. UCM uses baselines and activities to create and describe a stream configuration. The final objective in creating a release or deliverable is to integrate the various work of developers into a final integration stream. To this end, Rational ClearCase performs its magic of making sure code is checked in and baselines are correct, etc. As you’ll see in the next figure, merging is a key feature of any SCM system. Rational ClearCase helps you work through the challenge with a merge wizard.

**Figure 17. More concept architecture for the UCM project**
Rational ClearCase offers the project manager (role), a set of wizards that help to create the UCM infrastructure. In Figure 18 you can see a portion of the wizard that helps to create the set of streams. We'll start by looking at how to create a view.

1. From the Rational ClearCase menu, click the **Join a UCM Project** button.

2. Enter the ClearCase Web Server URL:
   http://localhost/ccrc

3. Enter the username/password: *alex/alex*

4. Expand the **CLSICS_pvob** menu and select the UCM Project **CLSICS_CD** and click **Next**, as shown in Figure 18.

**Figure 18. Choosing a project when creating a view**
5. Name the view copy area `C:\Documents and Settings\Administrator\alex_dev_stream` and click **Next**.

Typically, views are assigned to storage locations that are shared. The prefacing of a view name with the userid of the creator is a standard best practice and the default
for Rational ClearCase, as shown in Figure 19.

6. Click the checkbox next to **Create a new development stream**. Name the stream *alex_dev_stream* and click **Next**.

7. Name the view copy area *C:\Documents and Settings\Administrator\alex_CLSICS_CD_intg_view* and click **Finish**.

**Figure 19. Specifying a location for a view**
Rational ClearCase Remote Client provides you with the ability to create disconnected views, similar to web views or snapshot views from Rational ClearCase. It's important to note that Snapshot views (and web views) require periodic refreshing to display the latest team information.
8. Click **Yes** to use the ClearCase view configuration tool

9. Click the checkbox to **Select all VOBs**, then click the root of the **CLSICS_comp1** VOB and click **OK**, as seen in Figure 20.

**Figure 20. Loading Rational ClearCase elements to the view**
The Rational ClearCase Perspective provides a well designed ability to view your project. The status of a project is displayed in directory trees and the status of individual files is clearly indicated (files with green circles and check marks are checked out.)

Rational ClearCase provides many additional tools but two that assist with browsing files are the View Update as well as the Version Tree browser. As previously discussed, a Snapshot type view requires a periodic update to allow you to see the latest status of the files. The Snapshot View Update wizard provides a feedback report that tells you about the status of your project artifacts.

The Version Tree browser is available by right-clicking on an element and selecting the Tools context menu, and shows you a graphical rendering of the version history for any one specific file artifact. Figure 21 shows how to access the Version Tree browser from the pop-up context menu.

**Figure 21. Browsing the Version Tree for a project artifact**
It can also be helpful to look at the role and activities of the developer in working to create an application deliverable. Figure 22 is found in the "IBM Rational ClearCase
Guide to Building Software, 7.0" documentation. (See the Resources section for links to product documentation.)

**Figure 22. The UCM Developer workflow for creating a deliverable**

![UCM Developer workflow diagram]

**Summary**

Rational ClearCase is a facilitation tool for the contextual collaboration that supports team communication necessary for parallel development of project artifacts. The bottom line is that Rational ClearCase helps you organize projects and through UCM, you have a software development best practice that helps manage development. This tutorial only introduced Rational ClearCase and provided a brief overview of the Rational ClearCase Remote Client and its feature set. For more information on Rational ClearCase and its full capabilities, please refer to the change and configuration management product page on [ibm.com](http://ibm.com).
Resources

Learn

• This tutorial is intended to serve as a guide for an online demonstration of IBM Rational ClearCase.

• Part 1 of this series, Unified Change Management, is a tutorial that is intended to serve as a guide for an online demonstration of the IBM Rational change and configuration management solution.

• See also Part 2 of this series, a tutorial intended to guide you through an online demonstration of change management using IBM Rational ClearQuest.

• To learn more about IBM Rational products, visit the developerWorks Rational zone. You'll find technical documentation, how-to articles, education, downloads, product information, and more.

• Find more resources for ClearCase users and administrators in the ClearCase area of the developerWorks Rational zone, including articles and whitepapers, plug-ins, scripts and triggers; and links to training, discussion forums, product documentation and support.

• ClearQuest users and administrators can find more resources in the ClearQuest area of developerWorks Rational, including ClearQuest hooks, Eclipse plug-ins, product documentation, articles and whitepapers.

• To get your team up to speed on IBM Rational product technology as quickly as possible, IBM Global Services offers a variety of classroom training. Attend a public session, or arrange to have the course delivered at your site. If you prefer a self-paced, online training experience, there are a variety of web-based training modules available.

• Read about the latest release of the IBM Rational Software Development Platform in the developerWorks article: Accelerating global software delivery.

• Learn more about how to benefit from IBM Rational products and technologies in The Rational Edge e-zine.

• Browse the technology bookstore for books on these and other technical topics.

• Learn about upcoming events; including webcasts, seminars, trade shows, user group meetings, and the IBM Rational Software Development User Conference.

• Product manuals, installation guides, and other documentation are available in the IBM Rational Online Documentation Center.

• Whitepapers, analyst reports, and datasheets for IBM Rational ClearCase are
available [here](#).

- IBM Rational software has helped thousands of companies worldwide achieve success in their software development efforts. Read about some of them [here](#).

**Discuss**

- The [ClearCase discussion forum](#) on developerWorks is a great place to post questions and get answers about configuration management and UCM with IBM Rational ClearCase.

- You can also join the [Rational ClearQuest forum](#) on developerWorks to post questions and communicate with other ClearQuest users.

**About the author**

Paul Boustany
Paul Boustany works for IBM Rational's marketing engineering group and specializes in change and configuration management tools.