IBM Rational Developer for i

Advanced tutorial for Remote System Explorer
Customizing RSE
Customizing the Remote System Explorer

Introduction

This tutorial teaches you how to maintain a payroll application written in ILE RPG using the Remote System Explorer.

Learning objectives

- Start the product and open the Remote System Explorer perspective
- Use tools and views in this perspective to connect to an IBM i system
- Customize Remote System Explorer

Skill level

Introductory

Audience

IBM i developer

System requirements

- IBM® Rational® Developer for i, V7.5 and all software updates through the IBM Installation Manager.
- IBM i V5R3 or V5R4 or V6R1

Prerequisites

- Basic Microsoft Windows operations such as working with the desktop and basic mouse operations such as opening folders and performing drag-and-drop operations
- It will also help if you understand ILE RPG.

This tutorial is divided into a number of modules, each with its own learning objectives. Each module contains several lessons that must be completed in order for the tutorial to work properly.

Expected results

Upon completion of this tutorial you will know how to customize the Remote System Explorer.

Starting the product and the Remote System Explorer

This module teaches you about the workbench, the workspace, a perspective and specifically the Remote System Explorer perspective.

Learning objectives

- Start the product
- Set the default workspace
- Access unique tools and views targeted towards IBM i application development tasks

Starting the product
First you must start the product. Follow these steps to start the product:

1. Click **Start** on the task bar of your desktop.
2. Select **Programs > IBM Software Delivery Platform > IBM Rational Developer for i > IBM Rational Developer for i**

If you are working with the RDI SOA version of the product you will see slightly different product names.

A dialog will appear. Here you specify the directory of the workspace where your projects and other resources such as folders, subfolders and files that you are developing in the workbench will reside.

3. (Optional) Change the field in this dialog and use a unique directory name, for example, RSELABxx (where **xx** is a unique number).
   Don’t worry about the directory path it might vary from one workstation to the other.
4. Click **OK** to open the workbench.
5. Click **Select a topic** to view a list of available information. Select any of the entries and explore the topic. When you are done, click the X next to the Welcome tab to close the Welcome page.

Closing the Welcome page will take you to the Remote System Explorer perspective.

**Tip:** To open the Welcome page again, select **Help > Welcome**.

6. Click the maximize button to maximize the workbench.
You have started the product and opened the workbench. The workbench refers to the desktop development environment. The workbench aims to achieve seamless tool integration and controlled openness by providing a common paradigm for the creation, management, and navigation of workbench resources. Each workbench window contains one or more views and an editor.

**Working with the Remote System Explorer perspective**

In the Remote System Explorer (RSE) perspective.

1. If you are not sure which perspective is open at the moment you can check for the name of the perspective in the workbench title bar.
What is a perspective?

A perspective defines the initial set and layout of views in the Workbench window. Within the window, each perspective shares the same set of editors. Each perspective provides a set of capabilities aimed at accomplishing a specific type of task or working with specific types of resources. For example, the Java™ perspective combines views that you would commonly use while editing Java source files, while the Debug perspective contains views that you would use while debugging a program. Perspectives contain views and editors and control what appears in certain menus and tool bars.

If you see a different perspective, not the Remote System Explorer open in the workbench or no perspective:

2. Click Window > Open Perspective > Remote System Explorer from the workbench menu.

The Remote System Explorer perspective opens.

You work in the Remote System Explorer perspective in the workbench. This perspective is for an IBM i developer to display the connections that you have already configured, create a new connection, connect to and disconnect from the connections that you have defined, work with IBM i files, commands, jobs, and integrated file system files.

This perspective will be active when you start the product with a new workspace. If you had used the workspace before then, the workbench would come up with the perspective that you last opened. You will learn more about the Remote System Explorer perspective in the coming exercises as this is where you launch the IBM i developer tools and use the views from the workbench.

You have opened the Remote System Explorer perspective.
Configuring a connection to IBM i and connecting to a server

This module teaches you how to create a connection to an IBM i server, find a library in your library list, select objects from a library and finally open a member in the Remote Systems LPEX Editor. You also learn about several views such as the Remote Systems view, IBM i Table view, and the Outline view.

- Create a connection to an IBM i server
- Connect to a IBM i server
- Add a library to your library list

Configuring a connection to IBM i

When you first open the Remote System Explorer, you are not connected to any system except your local hard drive on your workstation. To connect to a remote system, you need to define a connection. When you define a connection, you specify the name or IP address of the remote system and you give your connection a unique name that acts as a label in your workspace so that you can easily connect and disconnect. When you connect to the remote system, the workbench prompts you for your user ID and password on that host.

All connections, filters, and filter pools belong to a parent profile. Filters are described in a later lesson. Profiles are discussed when you create your first connection.

Remember you have already opened the Remote System Explorer perspective in the previous module.
In the Remote Systems view,

1. Click the plus sign + to expand New Connection if it is not already expanded to show the various remote systems types you can connect to through the Remote System Explorer.

To connect to an IBM i remote server
2. Click the plus sign + beside IBM i to configure a connection to a remote system. The Remote IBM i System Connection page opens.

Here you specify the information for your connection. The Parent profile defaults to the name of the workstation. Your profile will be different from the one shown here. The cursor on this page is positioned in the Host name field.

1. In the Host name field, type the IP address or the name of your host system. The Connection name is automatically filled with the host name. Leave it this way. This name displays in your Remote Systems view and must be unique to the profile.
2. Leave the Parent profile default value. You don’t need to change it.
3. Leave the Verify host name check box selected.
4. Click **Finish** to define your system.

**Connecting to an IBM i system**

After you configure a connection to an IBM i system, you can easily connect and expand your new connection to reveal your subsystems. Subsystems are pre-defined filters grouping the various types of remote resources that can be explored in the remote system. There are four subsystems.

**Objects**
A PDM-like group, allowing access to libraries, objects and members.

**Commands**
Contains predefined commands and allows you to create command sets each of which contain one or more often used commands. When run, all commands in a command set are sent to the remote system and executed, and the results are displayed in the Commands log view.

**Jobs**
Allow you to see various jobs, subset by job attributes, and to perform a number of operations on those jobs.

**IFS Files**
Allow you to explore folders and files in the Integrated File System of the remote IBM i system.

To connect to an IBM i system:

1. Click on the plus sign + to expand connection in this example s400a.
   In the Remote Systems view, your new connection is expanded to reveal your subsystems. The **Objects** subsystem is the subsystem you will use most often! It is very similar to PDM, in that it allows you to access objects in the QSYS file system, and perform actions on those objects.
2. Click on the plus sign + to expand the Objects subsystem. Notice the first three entries under the Objects subsystem are named after the PDM options, because they have similar capabilities

- **Work with libraries** (similar to WRKLIBPDM)
- **Work with objects** (similar to WRKOBJPDM)
- **Work with members** (similar to WRKMBRPDM)

In addition there are entries for working with library lists and user libraries:
  - **Library list** (to simulate PDM's WRKLIBPDM you can start with the pre-defined Library list filter, that when expanded lists all libraries in your library list.)
  - **User libraries** (allows you to work with all user libraries you can access on that server.)

You also have more entries to work with under the connection itself and you can see from these entries that Remote System Explorer goes well beyond PDM! It allows you to explore IBM i jobs and commands and the IFS filesystem.

Now let's work with a library in your library list and add the library that you'll be using in this tutorial:

a. Right-click **Objects** and click **Properties** on the pop-up menu.
b. Select **Initial Library List** on the left pane.

c. In the **Library** field, type `RSELABxx` where **XX** is your team number.

d. Click **Add**.

e. Click **OK**.

This will add the library `RSELABxx` to your library list every time you use this connection.

**Tip:** You can also change your library list using the pop-up menu items **Add Library List Entry** or **Change Current Library** on the **Library list** folder in the Objects subsystem. These changes are only valid until you disconnect.
1. Expand the Library list entry.

2. Now the connection will be activated and you will be prompted for user ID and password. By default, the user ID field contains the user name that you used to log on to the workstation.

3. Enter your user ID and password

4. Select the Save user ID check box

5. Select the Save password check box

6. Click OK.

As you know, you can use the properties of any of the subsystems to set connection information such as adding a library to the library list.

Back in the workbench in the Remote Systems view you will see the libraries in your job’s library list.
Notice that the s400a connection icon now has a small green to indicate it is an active connection. For each library, you can right-click and select from a number of actions. For example, there is an action to create a new source file within the selected library. Common actions like delete, move, copy, etc. are valid for all kinds of objects.

You have connected to an IBM i system and used the Remote Systems view to view libraries in the library list.
Customizing the Remote System Explorer

This module teaches you how to use the Remote System Explorer perspective. You will learn how to define filters, perform actions and define your own actions. In short, you’ll see how Remote System Explorer can organize and integrate your work and make that work easier.

This module also teaches you how to move, re-size or close existing views. You learn how to open other views that you want to add to the perspective. You then save the customized layout as a new perspective.

Learning objectives

• Know the features of Remote System Explorer
• Move, dock, rearrange, resize, hide, close, reopen and add views
• Save and reset a customized perspective
• Create a filter to show specific libraries
• Change the filter to add more libraries
• Create a filter to show all the source files in a library
• Access members to edit from your filter
• Create a user action that copies a source file with data to a new source file in the same library
• Specify user action parameters
• Specify a restriction on a user action
• Try the user action
• Create a user action for jobs
• Create a user action for IFS folders and files
• Create your own compile command
• Edit an existing compile command
• Use Run configurations

More about Remote System Explorer

Remote System Explorer is the replacement for PDM (Program Development Manager) on the workstation, but it is not just a replacement.

Remote System Explorer allows you to:
1. Simplify your work by giving you quick access to lists of IBM i libraries, objects, members, IFS files, UNIX® files, and local files.
2. Use the context-sensitive pop-up menus on these lists to perform actions such as start the Remote Systems LPEX Editor, or Integrated IBM i Debugger or other common IBM i actions.
3. Use the Work with User Actions option to create and manage your own user-defined actions and have them appear in the pop-up menus.
4. Use the command support to increase your productivity by allowing you to enter and repeat IBM i or local commands without switching to an emulator session.

Customizing the perspective

Perspectives can be modified to fit your work style. You can move, resize, or close existing views. You can open other views that you want to add to the perspective.
To move the Outline view:

a. From the Remote Systems view double-click member MSTDSP in the QDDSSRC source file.

   The Remote Systems LPEX Editor opens.

b. In the Remote Systems view, double-click member PAYROLL in the QRPGLESRC source file.

   This member will be loaded into the editor as well. Your perspective will look something like:

   Notice the two tabs in the Editor window.
   Now let’s customize the perspective.

c. Click the title bar of the Outline view in the workbench window and drag the view across the Workbench window. Do not release the left mouse button yet.

d. While still dragging the view around on top of the workbench window, note that the various drop cursors appear. These drop cursors indicate where the view will dock in relation to the view or editor area underneath the cursor when you release your mouse button. To see the drop cursor change, drag the view over the left, right, top, or bottom border of another view or editor.
e. Dock the view in any position in the Workbench window, and view the results of this action.

f. Click and drag the Outline view over the Remote Systems view. You will see a stack cursor.
h. When you release the mouse button the Outline view will be stacked on top of the Remote Systems view.

You can also move a view by using the pop-up menu for the view. Right-click anywhere else in the view’s title bar.
Tip: A group of stacked views can be dragged using the empty space to the right of the view tabs. You can rearrange the order of stacked views.
   i. Click on the Outline view tab and drag it left to the Remote Systems view tab. The cursor should show the stack.
   j. Release the mouse button when the Outline view tab is in the desired location. The view that you selected is now moved.

To resize the Outline view:
   a. To resize the Outline view, select the right border and drag the mouse pointer to the right to increase the size of the Outline view.
   b. Click on any of the other stacked views such as Remote Systems view and you will see this view has the same size as the Outline view.

To hide a view:
You can create fast views to quickly open and close frequently used views. They work like other views except they do not take up space in your Workbench window when they are hidden.

To create a fast view:
   a. You can dock views on the shortcut bar at the bottom of the workbench. Click the title bar of the Outline view.
   b. Hold the mouse button down.
   c. Drag the view to the shortcut bar at the bottom left of the window and release the mouse button. A toolbar button for that view that you dragged now appears on the shortcut bar.
d. Click the toolbar button on the shortcut bar to make the view available to be used as before.

e. Click somewhere else outside the view to hide the view again.

**Tip:** You can also create and restore fast views by selecting Fast View from the context menu of the view’s title bar.

f. Right-click the toolbar button on the shortcut bar and click **Fast View** on the pop-up menu to deselect it. This will show the view again for the next lesson.

To dock a perspective: By default, the shortcuts for the open perspectives are displayed at the top right of the workbench. You can dock these shortcuts somewhere else in the workbench.
• To dock the shortcuts, right-click in the top right area of the workbench and select **Dock On > Left**.

The shortcuts are docked on the left of the workbench.

Once you are familiar with the shortcut icons for the open perspectives, you can remove the text to save space.

• Right-click the shortcut for an open perspective and deselect **Show Text** on the pop-up menu.

The text for all shortcuts for the open perspectives disappears.
To close, reopen and add other views:

You can remove views, reopen views and add new views to a perspective.

a. To remove the Outline view from the Remote System Explorer perspective, click the Close icon, the X, in the top right-hand corner of the tab.

b. Reopen the Outline view by clicking Window > Show View > Other. The Show Views dialog opens.

c. Expand General and select Outline.

d. Click OK. The Outline view opens in the workbench at the location where it resided last.

You can add views to the perspective.

f. To add more IBM i views, click Window > Show View > Other.

g. In the Show View dialog, expand IBM i and choose a view from the list of views, for example Job Status.
h. Click **OK**. The Job Status view is added to the perspective.

Now you know how to add, move, hide, and close views. Manipulating the RSE perspective allows you to work with a highly flexible, and customized workbench. You could for example change the perspective so that the editor takes up most of the space, the Object Table view resides below the editor and all other views are either closed or moved to the bottom as fast views, as shown here:
You have customized the Remote System Explorer perspective.

**Saving the perspective**

If you have modified a perspective by adding, deleting, or moving (docking) views, you can save your changes for future use.

1. Click **Window > Save Perspective As**
2. Type a new name for the perspective into the **Name** field.

2. Click **OK**.

The name of the new perspective is added to the Select Perspective dialog. Try it out and look at the Open perspective list by:

1. **Window > Open Perspective** menu then select
2. **Other**
You have saved the perspective and looked at the updated perspective list.

**Tip:** You can also make the new perspective the default by selecting **Window > Preferences**, expanding **Workbench** and then clicking **Perspectives**. You then select the new perspective and make it the default by clicking **Make Default**. The next time you open the workbench, this will be your default perspective.

### Resetting the perspective

If you have modified a perspective and don’t like the changes that you have made you can reset the perspective to its original layout.

1. Move some views around in the current perspective
2. Click **Window > Reset Perspective**. The Reset Perspective confirmation message dialog appears.
3. Click **OK**. The perspective returns to its original layout.
4. Click **Window > Open Perspective** and select **Remote System Explorer**. This opens the default Remote System Explorer perspective, ready for the next exercise.

### Expanding files and folders

Typically you start using the Remote System Explorer by just expanding libraries to show the objects and expanding the source files to show the members. You can also expand the Home directory to see folders in `\home` in IFS. But sometimes this produces lists that are too big. You really want to keep lists small, to a few hundred at most.

One very quick way to reduce the amount of items in a list is to use the Expand To object for libraries. It allows you to expand a library to see only objects of a particular type. This subsetting remains in effect, even when you expand with the plus sign, until you subsequently choose All or any other expand-to criteria.
To expand files and folders:
1. In the Remote Systems view, right-click library RSELABxx.
2. Click **Expand To > Source Files** from the pop-up menu.

All the source files display

3. Right-click RSELABxx and click **Expand To > Data Files** on the pop-up menu. All the data files display.
4. Right-click RSELABxx
5. Click Expand To > All on the pop-up menu.
All the files display

You have learned how to expand a library to show just the objects of a specific type.

**Introducing filters**

Eventually you will find the need to see a subset list. That is what filters offer and the Remote System Explorer has extensive filter support. On each subsystem you can create filters. In the Objects subsystem you can create a library filter, an object filter and a member filter. In the Commands subsystem you can create a command set filter. In the Jobs subsystem you can create a job filter. In the IFS Files subsystem you can create a filter.

You can also use the Work with libraries, Work with objects, and Work with members prompts under Objects to create filters.

There are several predefined filters as shown below under the Remote Systems view.

![Remote Systems view with filters]

You have learned what predefined filters exist in each subsystem and how to create a filter.

**Creating a library filter**

In the Remote System Explorer perspective, you now need to get to the i5/OS objects you want to work with.
In the previous modules you have worked with the Library list. Now you will create your own library filter. Library filters list a set of libraries from your IBM i system in the Remote Systems view. But first let’s understand what filters are all about.

Filters allow you to easily organize elements within your system. You use the filter function to list IBM i native file system objects (such as libraries, objects, or members).

To create a library filter:
1. In the Remote Systems view expand the connection that connects to your IBM i system if it’s not already expanded.
2. Expand Objects if it’s not already expanded.
3. Expand Work with Libraries. (You can also right-click Objects and click New > Library Filter on the pop-up menu).

Expanding Work with libraries corresponds to the WRKLIBPDM command, plus creates the filter in the Remote Systems view.

The New Library Filter page opens:

You are going to create a filter to specify the libraries you want to work with, so they will show in Objects. You want to create a filter that shows all libraries on the IBM i system with the name RSExxxxxx and VARxxxxxx, xxx being any character.

Note: You may need to select different libraries that appear on your system if libraries with the above names do not exist.

You specify the first filter string that selects the libraries starting with RSE.

4. Type RSE* into the Library field, using the * wild card character.

5. Click Next.

The Name Library Filter page opens.
Customizing Remote System Explorer

Tip: You can choose between creating the filter for all connections or for this specific one only. By default, the filter is created for the selected connection only.

6. In the Filter name field, type **All RSE and VARPG libraries**.
   You give your filters a name because the Remote System Explorer saves them for future use, unlike PDM, which does not save filters.

7. Click **Finish**.
   Back in the Remote Systems view under **Objects** you will see the new filter. Expand it to see the list of all RSE* libraries.
   Now you need to add the VARPG libraries.

8. To change the library filter:
   a. Right-click the filter **All RSE and VARPG libraries** and click **Change**.

   The **Change Library Filter** window opens.
b. Select **New filter string** from the **Filter strings** list.

c. In the **Library** field, type **VAR**.

d. Click **Create**.

The **VAR** filter string is added to the list.

e. Click **OK**.

You are now back in the Remote Systems view.

You will see the list expanded to include your filter. Now you can work with the libraries directly and can drill down to the object you want to work with.

You have created a filter to show specific IBM i libraries and changed that filter to add more IBM i libraries.

**Creating an object filter**

Now create an object filter. Object filters list a set of objects from your IBM i host in the Remote Systems view.

To create an object filter:

1. In the Remote Systems view, expand your connection and then expand **Objects** if not already expanded.

2. Expand **Work with objects**. You can also right-click **Objects** and click **New > Object filter** on the pop-up menu.
Tip: Expanding Work with objects corresponds to the WRKOBJPDM command. The Create a new object filter page opens:
Now create a filter to show all your source files in your RSELABxx library.

3. In the Library field, type RSELABxx.
4. Click Browse beside the Object type field.
The Select Object Type window opens.

5. Select *FILE under the Select an object type list.
6. Click **OK**.
   The Create a new object filter page displays with the object type updated.

   ![New Object Filter](image)

   7. Click **Browse** beside the **Object attribute** field.
      The Select Object Attribute window opens.
   8. Select **PF-SRC** from the **Select an object attribute** list.
   9. Click **OK**

   ![Select Object Attribute](image)

10. Click **Next**.
    The Name Object Filter page opens.
11. In the **Filter name** field, type *My source files*.

12. Click **Finish**.

The new object filter displays in the Remote Systems view under Objects.

Note: If you end up with too many filters, you can create filter pools. They allow you to group filters. You will learn about filter pools later.

Now you know how to create filters and tailor your development environment. Filters can also be specified for non IBM i servers and your local system.

From the filters, you can work with the objects you have in your Remote Systems view like you worked in PDM with a subset of libraries, objects, or members.

Let’s assume you want to edit the member PAYROLL in the source file QRPGLSRC using this object filter.

13. To edit a member from your own object filter:
   - a. Expand QRPGLSRC.
   - b. Right-click member PAYROLL.
   - c. Click **Open With > Remote Systems LPEX Editor** on the pop-up menu.

This will download the source member and open the editor with this member. After you have edited the member you could save it and then compile it from the Remote Systems view by using...
the pop-up menu options on this member. You can also create your own actions in addition to the default actions. You will learn about creating user actions later.

You have created a filter to show all the source files in your library and accessed members to edit from your filter.

**Showing Filter Pools**

If you have been using the Remote System Explorer for some time, your workspace might contain too many filters to navigate easily. Or, you might just want to keep groups of filters separate if, for example, you need to represent two distinct IBM i environments in the Remote System Explorer, regardless of how many filters you have. In either case, you can group filters into filter pools. Without filter pools, all of your filters appear together either in the specified connection or in all connections.

When you create filter pools, however, any filter you create within that filter pool is distinct to that connection, and will not appear in any other connection.

1. Create a connection to the same host. (Expand New Connection then IBM i). Give your new connection the name s400b.

2. To illustrate the use of filter pools, Click the menu button on the toolbar for the Remote Systems view, and select **Show Filter Pools**

Under Objects you can now see the default filter pool with the pre-defined filters and a connection specific filter pool which contains your user defined filters.
To create a new Filter Pool:

Right-click **Objects** and select **New > Filter Pool**.
Enter a pool name and click **Finish**. (You do not need to change your profile selection.)

Your new filter pool displays underneath your connection.

The filter pool is added only to the connection from which it was created.

1) Right-click your new filter pool and select **New > Library filter**.
2) Complete the wizards as you did before. Use *LAB* as the generic library name for the library filter. Give your filter any name you like. Click **Finish**.

When you are finished, you can see your new library filter displayed underneath the new filter pool.

If you decide not to work with filter pools anymore, click the menu button on the toolbar for the Remote Systems view, and select **Show Filter Pools** again to clear the check mark.
For each filter pool, you can right-click and select from a number of actions. For example, you can rename, copy, move or delete a filter pool.

You have learned how to group filters into filter pools and how to create a new filter pool.
Sharing filter pools

You can share filter pools among many connections through the use of a filter pool reference. A filter pool reference is a mechanism that displays a filter pool from one connection in any other connection, so that when you make a change to the original filter pool, your change is reflected in your filter pool reference. Before you create a filter pool reference, ensure that you have already completed the following:

You have defined more than one connection to the same IBM i server. You have defined more than one filter pool. You have enabled Show Filter Pools from the Remote Systems view toolbar.

To use filter pool references:

1. Make sure you have another connection established.
2. In the Remote Systems view, expand the connection where you want to display a filter pool that exists in another connection.

3. Right-click Objects and select New > Filter Pool Reference > your profile > pool name.
4. Look under Objects again and you will see the filter pool reference.

Next, you make a change to the filter pool in order to see that change also occur in the filter pool reference.

5. Add new object filter called RPG. Right-click your new filter pool and select New > Object filter. Complete the wizards. When you are finished you will see the referenced filter is available in both connections.
6. To delete a filter pool reference, right-click it and select **Remove reference**

7. You can also move your filter pools up and down with the pop-up menu.
You have learned how to share filters.

Creating a user action

In PDM you can create user actions in addition to using the pre-supplied system actions. In Remote System Explorer you can do the same. You define user actions through the Work With User Actions window. User actions can be defined for IBM i libraries, objects, members and jobs as well as folders and files in any remote UNIX, Windows, Linux, Local, or IFS system.

To open the Work with User Actions wizard:

1. Expand your IBM i connection and expand Objects if not already expanded.
2. Expand the Library list filter if not already expanded.
3. Right-click RSELABxx.
4. Click User Actions > Work with User Actions on the pop-up menu.
   The Work with User Actions window opens.
5. In the right pane of the Work with User Actions window, expand **New** in the list, if it is not expanded already.
6. Select **Object action**.
   You want to create a user action that copies a source file with data to a new source file called QJUNKSRC in the same library.

7. In the **Action name** field, type *Copy source file* for the user action name.
8. In the **Comment** field, type *Copy source files with data*.
9. In the **Command** field, type *CRTDUPOBJ* for the command to execute.
10. Click **Prompt** to open the command prompter for this command.

![Image of command prompt window](image)

This is the command you will be running:

```
CRTDUPOBJ OBJ(&N) FROMLIB(&L) OBJTYPE(&T) NEWOBJ(QJUNKSRC)
DATA(*YES)
```

11. To specify user action parameters:
   a. In the **From Object** field, type `&N` to indicate to use the name of the selected object in the Remote Systems view.
   b. In the **From Library** field, type `&L` to pick up the library name from the selected object.
   c. In the **Object Type** field, type `&T` to pick up the object type from the selected object.
   d. In the **New Object** field, type `QJUNKSRC`.
   e. Select the **All parameters** check box to see the additional Duplicate data parameter.
      Now the Duplicate data parameter is also shown on the prompt window.
   f. Select *YES* from the **Duplicate data** list.
   g. Click **OK**.

You return to the Work with User Actions window.

**Tip:** You can use the **Prompt** button to enter the variables or you can type the command directly and when you type `,` you see a pop-up selection list, or you can use **Ctrl+ Space** or press the **Insert Variables** button. From the list, you can then double click to insert the selected variable, at the cursor position.
h. Select the **Refresh after** check box, so that the Remote Systems view gets refreshed after the action has been run.

**Tip:** Clicking the **Insert variable** push button displays a list of valid replacement variables with the explanation of what they do.

This user action is only valid for Source physical files. You need to specify this restriction so this user action will only show in pop-up menus when you right-click on a source physical file.

To specify a restriction on a user action:
1. Under the **Defined Types** list box, click **FILE_SRC**
2. Click **Add** beside the **Defined Types** list box.
   FILE_SRC is now one of the selected types. Actually since you only selected this one it is the only
one.
3. Click **Create** then **Close**.

Now, only when you right-click on a source file, will this user action appear on the pop-up menu. For any other object type it will not appear. Back in the workbench and the Remote System view, give it a try.

**Tip:** Remember to close all the source members if you opened any earlier.

To try a user action:

a. Locate your filter **My source files**.

b. Expand the filter **My source files**, if it is not already expanded.

c. Right-click the QCLSRC file.

d. Click **User Actions > Copy source file** on the pop-up menu.

The file gets duplicated and the list gets refreshed. Your new source file will show in the list. You can check the messages of the CL commands you are running in the RSE communications server job by looking at the Commands log view in the bottom right of the workbench.
e. Try other objects such as *pgm or *lib. Notice that the action that you just created is not there.
f. To delete the source file QJUNKSRC that you just created, right-click QJUNKSRC.

![](image)

g. Click Delete on the pop-up menu.
The Delete Confirmation dialog opens.
h. Click Delete.

You have created a user action that copies a source file with data to a new source file, specified user action parameters, specified restrictions on the user action and tried the user action.

**Creating user actions for jobs**

You can also create user actions for Jobs, which will appear in the User Actions popup menu for jobs in the Jobs subsystem under a connection. The substitution variables include variables for the selected job’s number, user and name.

To create a job action:
1. In the Remote Systems view, expand your IBM i connection, if not already, right-click Jobs, and select Work with > User actions.

![](image)

2. Select New Job action.

3. Type the text to display in the Action name field. For example, ENDJOB. This is a brief label for the action.

4. Type a longer, more descriptive text description for the action in the Comment field. For example, End Job.
Customizing Remote System Explorer

5. Type the actual workstation or IBM i command string to run when a user selects this action. For example: ENDJOB JOB(&IJR/&IJU/&IJN) OPTION(*IMMED).
   This command can use action substitution variables when you run the action. These variables are used when defining the command string to run for a particular action. Substitution variables keep you from having to explicitly code command parameter values.

6. Click Insert variable to view and select valid variables. Here is your completed job action:

![Work With User Actions](image)

7. Click Create then Close.
   Now let’s try this job action that you just created.
   Make sure you have a 5250 session.

8. Expand Jobs.

9. Expand My active jobs.

10. Expand QINTER.

11. Right-click the 5250 job

12. Select User actions > ENDJOB from the pop-up menu.
13. Switch to a 5250 session to verify that the job has ended.

Tip: Similar to user actions for objects and jobs, you can also create user actions for IFS.

You have created a user action for a job.

**Customizing compile commands**

In addition to user actions, there is specific support for creating compile commands too. You use the Work with Compile Commands window from the Objects subsystem under an IBM i connection to change IBM or vendor supplied compile commands or your own compile commands.

To create your own command:
1. In the Remote Systems view, expand RSELABxx, expand QRPGLESRC and right-click PAYROLLG.rpgle.
2. Click **Compile (Prompt) > Work with Compile Commands** in the pop-up menu.
   The Work with Compile Commands dialog opens.
Tip: You can also work with compile commands from the Compile option (Compile > Work with Compile Commands).

3. New command is already selected for you in the list of commands.

Tip: To edit an existing command, first find it by selecting the member type it applies to (or add a new member type if necessary) at the top of the Work with Compile Commands dialog, and select the command in the list of commands on the left. Edit the command and apply the changes. You can also right-click on a command to delete it, copy and paste it or re-order it. You cannot delete IBM-supplied commands, but after editing them, you can restore them to their shipped value.

4. In the Label field, type CRTBNDRPG - no debug command.
5. In the Command field, type CRTBNDRPG command.
6. Click Prompt.
   The Create Bound RPG Program (CRTBNDRPG) dialog opens.
7. Change the **Debugging Views** option to *NONE*.
8. Click **OK**.

The Work with Compile Commands displays.
9. Click **Create** to create this new command.

10. Click **Close**.

11. Right-click PAYROLLG.rpgle.

The new command is added to the list of available compile commands for members of the type specified in this command. The checkmark appears beside the last used compile command for the selected member’s type.

12. Click **Compile > CRTBNDRPG - no debug** on the pop-up menu and change the program name to PAYROLLN.

The member is compiled and the program object is created.

Any errors produced by the compile are displayed in the Error List window, where you can double-click to open the editor and position it at the error.

13. Right-click the program PAYROLLN and click **Debug As > Batch**. If you don’t see the program in the list, click the **Refresh** icon in the Remote Systems view.

An error message displays indicating that PAYROLLN cannot be added to debug since it does not have debug data.

**Using predefined commands**

For some of the frequently used commands, the Commands subsystem provides you with a number of predefined command sets. You can use these command sets or create new ones of your own. For example, to run the ADDLIBLE command set:

a. In the Remote Systems view, expand the Commands subsystem.

b. Right-click **Add library to library list** and click **Change**
From here you can now modify the existing command or create a new one.

c. Click Cancel.

Tip: There is a Preferences dialog that has many preferences which effect substitution variables for user actions and compile commands. Click Window > Preferences and then expand Remote Systems, then expand IBM i and select Command Execution.
You have created a new CRTBNDRPG command and looked at predefined command sets.

**Using Run configurations**

Run configurations are for powerful re-use. If you want to run a program that takes a number of parameters, or is not straightforward to launch, you can predefine this information into a named configuration. Once created, the configuration appears in the configuration list, and can be selected from there. Every configuration defined can be accessed from the pull down menu of the Run tool bar button through the Run option.
To change an existing run configuration:

1. Right-click CLR1 then **Run (Prompt) > Interactive** on the pop-up menu

The Edit Configuration window opens.
**My program for run (Interactive)** is the default name assigned to a configuration created on the fly when you select Run from the pop-up menu of a program. To save a configuration for later use, you would change this default name.

2. Change the name of the configuration to CLR1Run.
3. Click **Prompt**.

The Call Program (CALL) window opens.
4. In the Parameters field, type 'XX ', where XX is your workstation number.

5. Click OK.

The complete start command for the program appears.

6. Click Run.

The program runs.
If not, you may see this error message.

![Error message](image1.png)

The interactive connection has been shut down in the meantime. Go to your 5250 emulator and restart the interactive connection following the instructions in the message. You don’t have to cancel the message. It will be removed as soon as the connection between the interactive connection and the interactive session has been established.

The program runs and waits for input from the 5250-emulation session.

![Session A](image2.png)

7. Press F3 to end the program.

**Tip:** You can edit, delete and create run configurations by clicking the arrow beside the **Run** icon on the workbench toolbar and selecting **Run Configurations** from the list.
You can also click **Run** on the workbench menu and select **Run Configurations**.

The Run Launch Configurations window opens.
Here you can see the **CLR1Run** configuration that you just created. This is your saved configuration to run **CLR1** as an interactive application. Notice the list of configurations you can choose.

You have created and saved a run configuration.

Congratulations you finished the lab Customizing RSE
We hope you enjoyed working with the tools in
Rational Developer for System i
Additional resources

More information
Visit the RPG Café at:

Summary

This tutorial has taught you how to customize the Remote System Explorer. You learned how to start the product and open the Remote System Explorer perspective, how to change the location of the views, how to create user actions and compile commands and how to create and use Run Configurations.
Notices

© Copyright IBM Corporation 1992, 2009. All rights reserved.

U.S. Government Users Restricted Rights - Use, duplication or disclosure restricted by GSA ADP Schedule Contract with IBM Corp.

This information was developed for products and services offered in the U.S.A. IBM may not offer the products, services, or features discussed in this documentation in other countries. Consult your local IBM representative for information on the products and services currently available in your area. Any reference to an IBM product, program, or service is not intended to state or imply that only that IBM product, program, or service may be used. Any functionally equivalent product, program, or service that does not infringe any IBM intellectual property right may be used instead. However, it is the user’s responsibility to evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter described in this documentation. The furnishing of this documentation does not give you any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM Intellectual Property Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation
Licensing
2-31 Roppongi 3-chome, Minato-ku
Tokyo 106, Japan
The following paragraph does not apply to the United Kingdom or any other country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied warranties in certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically made to the information herein; these changes will be incorporated in new editions of the publication. IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for convenience only and do not in any manner serve as an endorsement of those Web sites. The materials at those Web sites are not part of the materials for this IBM product and use of those Web sites is at your own risk.

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the exchange of information between independently created programs and other programs (including this one) and (ii) the mutual use of the information which has been exchanged, should contact:

Intellectual Property Dept. for WebSphere Software
IBM Corporation
3600 Steeles Ave. East
Markham, Ontario
Canada L3R 9Z7

Such information may be available, subject to appropriate terms and conditions, including in some cases, payment of a fee.

The licensed program described in this documentation and all licensed material available for it are provided by IBM under terms of the IBM Customer Agreement, IBM International Program License Agreement or any equivalent agreement between us.

Any performance data contained herein was determined in a controlled environment. Therefore, the results obtained in other operating environments may vary significantly. Some measurements may have been made on development-level systems and there is no guarantee that these measurements will be the same on generally available systems. Furthermore, some measurements may have been estimated through extrapolation. Actual results may vary. Users of this document should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of those products, their published announcements or other publicly available sources. IBM has not tested those products and cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of those products.
All statements regarding IBM’s future direction or intent are subject to change or withdrawal without notice, and represent goals and objectives only.

**Copyright license**

This information contains sample application programs in source language, which illustrates programming techniques on various operating platforms. You may copy, modify, and distribute these sample programs in any form without payment to IBM, for the purposes of developing, using, marketing or distributing application programs conforming to the application programming interface for the operating platform for which the sample programs are written. These examples have not been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or imply reliability, serviceability, or function of these programs.

Each copy or any portion of these sample programs or any derivative work, must include a copyright notice as follows:

© (your company name) (year). Portions of this code are derived from IBM Corp. Sample Programs. © Copyright IBM Corp. 1992, 2009. All rights reserved

**Trademarks and service marks**

The following terms are trademarks or registered trademarks of International Business Machines Corporation in the United States, other countries, or both.

- IBM
- iSeries
- Rational
- System i
- WebSphere

Intel® and Pentium® are trademarks of Intel Corporation in the United States, other countries, or both.

Microsoft, Windows, Windows NT® and the Windows logo are trademarks of Microsoft Corporation in the United States, other countries, or both.

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other countries.

Linux is a registered trademark of Linus Torvalds in the United States, other countries, or both.

Other company, product or service names may be trademarks or service marks of others.