Topic
  • 4 replies
  • Latest Post - ‏2014-05-31T03:30:10Z by casau333
casau333
casau333
3 Posts

Pinned topic Help me !! Java connect to DB2 V8.2 throw exeption Unsupport CCSID locale 1129.

‏2014-05-23T03:37:19Z |

Hi all!

Im using java jdbc connect to Db2 version 8.2, but it throws below error.

I try searching this error, and know that this error is client don't have IBM-1129 class in charsets.jar.

but i can't download this class or jar

Please help me to solve this problem?

Reply here or send to email casau333@gmail.com

Thank you very much.

 

 

com.ibm.db2.jcc.am.DisconnectNonTransientException: [jcc][t4][10379][11959][4.11.69] Client disconnect exception encountered: [jcc][10275][10261]Unsupported ccsid, encoding, or locale: "1129". ERRORCODE=-4499, SQLSTATE=null
at com.ibm.db2.jcc.am.gd.a(gd.java:321)
at com.ibm.db2.jcc.am.gd.a(gd.java:347)
at com.ibm.db2.jcc.t4.cc.e(cc.java:2246)
at com.ibm.db2.jcc.t4.cc.e(cc.java:2135)
at com.ibm.db2.jcc.t4.ab.c(ab.java:4504)
at com.ibm.db2.jcc.t4.ab.b(ab.java:4449)
at com.ibm.db2.jcc.t4.ab.a(ab.java:4435)
at com.ibm.db2.jcc.t4.ab.l(ab.java:416)
at com.ibm.db2.jcc.t4.ab.d(ab.java:145)
at com.ibm.db2.jcc.t4.b.ad(b.java:1267)
at com.ibm.db2.jcc.t4.b.b(b.java:1185)
at com.ibm.db2.jcc.t4.b.a(b.java:5492)
at com.ibm.db2.jcc.t4.b.d(b.java:740)
at com.ibm.db2.jcc.t4.b.c(b.java:682)
at com.ibm.db2.jcc.t4.b.a(b.java:367)
at com.ibm.db2.jcc.t4.b.<init>(b.java:307)
at com.ibm.db2.jcc.DB2SimpleDataSource.getConnection(DB2SimpleDataSource.java:214)
at com.ibm.db2.jcc.DB2Driver.connect(DB2Driver.java:460)
at java.sql.DriverManager.getConnection(DriverManager.java:316)
at java.sql.DriverManager.getConnection(DriverManager.java:297)
at com.testMain.main(testMain.java:50)
Caused by: java.io.UnsupportedEncodingException: [jcc][10275][10261]Unsupported ccsid, encoding, or locale: "1129".
at com.ibm.db2.jcc.am.bb.a(bb.java:1153)
at com.ibm.db2.jcc.t4.cc.e(cc.java:2243)
... 18 more
  • nivanov
    nivanov
    9 Posts

    Re: Help me !! Java connect to DB2 V8.2 throw exeption Unsupport CCSID locale 1129.

    ‏2014-05-23T18:44:09Z  

    May be you need to reinstall the client? DB2 8.2 client packages are not available anymore, but DB2 9.1 should work with the downlevel server. You can find the latest fixpack for DB2 9.1 here: http://www-01.ibm.com/support/docview.wss?uid=swg27016878

  • casau333
    casau333
    3 Posts

    Re: Help me !! Java connect to DB2 V8.2 throw exeption Unsupport CCSID locale 1129.

    ‏2014-05-25T07:23:48Z  
    • nivanov
    • ‏2014-05-23T18:44:09Z

    May be you need to reinstall the client? DB2 8.2 client packages are not available anymore, but DB2 9.1 should work with the downlevel server. You can find the latest fixpack for DB2 9.1 here: http://www-01.ibm.com/support/docview.wss?uid=swg27016878

    Hi mr Navinov!

    Thank for your helps. 

    I had tried installing some version of DB2 client (9.1, 9.5, 9.7) but it still doesn't work. 

    I think that, my java version has not IBM-1129 charset. ( I used this command to create my database: CREATE DATABASE DBTEST USING CODESET IBM-1129 TERRITORY VN)

    Help please ?

     

  • YogeshGawali
    YogeshGawali
    10 Posts

    Re: Help me !! Java connect to DB2 V8.2 throw exeption Unsupport CCSID locale 1129.

    ‏2014-05-28T05:32:01Z  
    • casau333
    • ‏2014-05-25T07:23:48Z

    Hi mr Navinov!

    Thank for your helps. 

    I had tried installing some version of DB2 client (9.1, 9.5, 9.7) but it still doesn't work. 

    I think that, my java version has not IBM-1129 charset. ( I used this command to create my database: CREATE DATABASE DBTEST USING CODESET IBM-1129 TERRITORY VN)

    Help please ?

     

    I come across similar issue reported in following APAR.

     

    http://www-01.ibm.com/support/docview.wss?uid=swg1JR32368

     

    Please see if latest fixpack level of 9.7 helps you here. Otherwise I would suggest you to contact IBM officially.

     

    Regards,

    Yogesh.

  • casau333
    casau333
    3 Posts

    Re: Help me !! Java connect to DB2 V8.2 throw exeption Unsupport CCSID locale 1129.

    ‏2014-05-31T03:30:10Z  

    I come across similar issue reported in following APAR.

     

    http://www-01.ibm.com/support/docview.wss?uid=swg1JR32368

     

    Please see if latest fixpack level of 9.7 helps you here. Otherwise I would suggest you to contact IBM officially.

     

    Regards,

    Yogesh.

    Thank YogeshGawal !

    I see your post, it's the same with my problem. i download lasted fix pack, tried to apply with that driver, but it not work.

    May be Fix pack don't support CCSID 1129