Topic
1 reply Latest Post - ‏2013-09-30T20:32:57Z by JavaPoet
amyxhcui
amyxhcui
2 Posts
ACCEPTED ANSWER

Pinned topic How to avoid occurring swap space on Linux

‏2013-08-09T00:13:02Z |

Hello,

It occurs swap space quite often on Linux which has 16GB memory when running RD&T V8.5.
Tried to change the memory value for system z in 'devmap' from 14GB to 12GB(or 10GB, 9GB, 8GB, 6GB), but there is no big difference and the swap spaces still occur.

Checked z1090instcheck results everything is OK except below
<---
10. REDHAT kernel.core_pattern is |/usr/libexec/abrt-hook-ccpp which is BAD
--->

Is above the cause of the problem ?
Could you please tell me what other settings are needed to RD&T or Linux for avoiding the swap spaces happening.

Thanks.

  • JavaPoet
    JavaPoet
    11 Posts
    ACCEPTED ANSWER

    Re: How to avoid occurring swap space on Linux

    ‏2013-09-30T20:32:57Z  in response to amyxhcui

    I will admit that I don't have any great insight into why Linux may wish to use some swap space but unless it is causing you an operational issue there should not be any problem with using some swap space.

    For the kernel.core_pattern setting you may wish to review this to understand the meaning of this value better http://sigquit.wordpress.com/2009/03/13/the-core-pattern/  Your existing value is certainly unusual as it should specify the name for core dumps and I would not expect a filename to start with "|" nor would I expect core dumps to be saved in /usr/libexec so I expect you will wish to change this value.