Topic
2 replies Latest Post - ‏2013-05-13T13:58:04Z by markevans
giocot
giocot
155 Posts
ACCEPTED ANSWER

Pinned topic SQL Data Base connection problem

‏2013-05-11T10:56:39Z |

Hi all

i have created a simple project to display via SQL Service the content of an iSeries Table; i have created a "SQL Database Connection" that point to one of my iSeries, and it works well. Now i would point to another iSeries: i have created a new "SQL Database Connection" and changed the .eglbld files but when i run the preview in my RUIHandler i see always the data of my first connection. Can some one help me to understand where i'm wrong.

Thanks in advance

  • giocot
    giocot
    155 Posts
    ACCEPTED ANSWER

    Re: SQL Data Base connection problem

    ‏2013-05-12T19:46:27Z  in response to giocot

    Hi all

    i found the problem: i opened the files .eglbld  and i found that the tag "<BuildDescriptor" was present twice, one for Sistem i. I deleted one of them and now it works correctly; pheraps the .eglbld's file editor not work very well .

    By

     

     

    • markevans
      markevans
      2759 Posts
      ACCEPTED ANSWER

      Re: SQL Data Base connection problem

      ‏2013-05-13T13:58:04Z  in response to giocot

      Hi,

      An .eglbld file can contain more than one set of build descriptors.   In fact, it is pretty normal to have multiple depending on what target environments you generate for (Java Gen, JavaScript, COBOL)..and then one for Debug (which is what the RUI preview uses).

      I suspect you changed the one that was not used for RUI preview.

       

      The EGL Default Build Descriptor is used to set which build descriptor is used for Debug and/or generation.   These can be set at the file level, the folder level, the EGLSource level, the Project level, and the workspace preferences level (and they are searched for in the above order).