Topic
  • 7 replies
  • Latest Post - ‏2014-04-17T14:24:19Z by jan.bezdzietny@pl.ibm.com
jan.bezdzietny@pl.ibm.com
5 Posts

Pinned topic REST API Post call - "error 500 Internal server error"

‏2014-04-11T12:52:44Z |

REST API issue - Post Call doesn't work - error 500 internal server error

After executing api post call SA receiving error msg. "Error 500 internal server error". Parallel SA is able to execute same call on different IEM server and additionally he is able to successfully execute api get call on affected server. Do you know what can cause this issue and how to resolved it?

 

Thank you in advance.

Jan

  • jgstew
    jgstew
    52 Posts

    Re: REST API Post call - "error 500 Internal server error"

    ‏2014-04-14T16:31:46Z  

     

    Could be a permissions issue. Is one a Master Operator, and the other is not?

     

  • jan.bezdzietny@pl.ibm.com
    5 Posts

    Re: REST API Post call - "error 500 Internal server error"

    ‏2014-04-17T11:45:36Z  
    • jgstew
    • ‏2014-04-14T16:31:46Z

     

    Could be a permissions issue. Is one a Master Operator, and the other is not?

     

    System admin is NOT an Master Operator in both IEM consoles. I have double checked and compered admin's working and NOT working IDs and both are setup in the same way. Additionally admin provides me his id/pass and I was able to login into API via IEM.exe and what's strange I was even able to successfully execute "iem post action\<action_id>\stop" call. But for some unknown reasons admin after executing post call via Rest Api (on this particular server) is receiving error 500: internal server error code. Any ideas what can cause this issues?

  • jgstew
    jgstew
    52 Posts

    Re: REST API Post call - "error 500 Internal server error"

    ‏2014-04-17T13:24:53Z  

    System admin is NOT an Master Operator in both IEM consoles. I have double checked and compered admin's working and NOT working IDs and both are setup in the same way. Additionally admin provides me his id/pass and I was able to login into API via IEM.exe and what's strange I was even able to successfully execute "iem post action\<action_id>\stop" call. But for some unknown reasons admin after executing post call via Rest Api (on this particular server) is receiving error 500: internal server error code. Any ideas what can cause this issues?

     

    I really can't see why there would be a difference.  It sounds like one user account can do it on the server, but another user account cannot on the same server. Is there any difference in the way the permissions are assigned? Are the servers the same version? Can you try creating another account to see if it behaves similarly? Can the account with the issue log in to the console and change it's password and try again? 

    I would recommend filing a PMR.

     

  • jan.bezdzietny@pl.ibm.com
    5 Posts

    Re: REST API Post call - "error 500 Internal server error"

    ‏2014-04-17T13:42:25Z  
    • jgstew
    • ‏2014-04-17T13:24:53Z

     

    I really can't see why there would be a difference.  It sounds like one user account can do it on the server, but another user account cannot on the same server. Is there any difference in the way the permissions are assigned? Are the servers the same version? Can you try creating another account to see if it behaves similarly? Can the account with the issue log in to the console and change it's password and try again? 

    I would recommend filing a PMR.

     

    You have wrongly understand me, actually there are 2 different IEM server and one administrator who got 2 separate ID's. His IDs are setup in the same way on both IEM server. SA is able to initiate action via API on one server and not able to doing this one the second server. The PMR is opened, but in the mean time I have tried to find any help on this forum.

  • jgstew
    jgstew
    52 Posts

    Re: REST API Post call - "error 500 Internal server error"

    ‏2014-04-17T13:49:10Z  

    You have wrongly understand me, actually there are 2 different IEM server and one administrator who got 2 separate ID's. His IDs are setup in the same way on both IEM server. SA is able to initiate action via API on one server and not able to doing this one the second server. The PMR is opened, but in the mean time I have tried to find any help on this forum.

     

    Can anyone successfully use the REST API this way on the server with the problem?

    Are both servers the same version?

     

  • jan.bezdzietny@pl.ibm.com
    5 Posts

    Re: REST API Post call - "error 500 Internal server error"

    ‏2014-04-17T14:02:44Z  
    • jgstew
    • ‏2014-04-17T13:49:10Z

     

    Can anyone successfully use the REST API this way on the server with the problem?

    Are both servers the same version?

     

    Both server have the same version. On problematic server no one can successfully execute REST API post calls. However every one can successfully execute get calls.

  • jan.bezdzietny@pl.ibm.com
    5 Posts

    Re: REST API Post call - "error 500 Internal server error"

    ‏2014-04-17T14:24:19Z  
    • jgstew
    • ‏2014-04-17T13:49:10Z

     

    Can anyone successfully use the REST API this way on the server with the problem?

    Are both servers the same version?

     

    Both server have the same version. On problematic server no one can successfully execute REST API post calls. However every one can successfully execute get calls.