Topic
3 replies Latest Post - ‏2013-08-01T05:56:37Z by mschuere
lbarckmann
lbarckmann
2 Posts
ACCEPTED ANSWER

Pinned topic Preparing Redhat 6.2 OS for TBSM

‏2013-07-22T23:07:24Z |

My question relates to the info directly below - has anyone developed a method for installing the 32 bit packages listed below on a RedHat (or Centos) 6.2 machine that already has the 64 bit packages?  I have it hooked up to a yum repository and have googled for advice - but all of the advice seems to take me to

Error: Package: xxx

Requires libc.so.6

it is already in /lib64/

How do I get the 32 bit package install with yum or rpm?  As you can see the instructions get vague below when the going gets tough ...

installing the packages later through the appropriate rpm or yum commands.

 

In the following link

http://pic.dhe.ibm.com/infocenter/wasinfo/v7r0/index.jsp?topic=%2Fcom.ibm.websphere.installation.base.doc%2Finfo%2Faes%2Fae%2Ftins_prepare.html

Under Redhat Linux 62 is the following instructions

By default, RHEL 6 only installs 64-bit runtime support on these platforms. However, various applications included with WebSphere Application Server products and packages also require the 32-bit runtime support. Therefore, you must install the 32-bit runtime support.

Install the following required 32-bit packages by selecting to customize the packages during the RHEL 6 installation or by installing the packages later through the appropriate rpm or yum commands.

Platforms that support both 32-bit and 64-bit applications require both the 32-bit and 64-bit versions of the following packages:
  • compat-libstdc++-33-3.2.3-69
  • compat-db-4.6.21-15
  • libXp-1.0.0-15.1
  • libXmu-1.0.5-1
  • libXtst-1.0.99.2-3
  • pam-1.1.1-4
  • libXft-2.1.13-4.1
  • gtk2-2.18.9-4
  • gtk2-engines-2.18.4-5

 

 

  • randybrown
    randybrown
    59 Posts
    ACCEPTED ANSWER

    Re: Preparing Redhat 6.2 OS for TBSM

    ‏2013-07-23T15:38:38Z  in response to lbarckmann

    Hello,

    I had similar problems when I tried to install TBSM into a Red Hat 6 system that only had 64-bit libraries. I am not very experienced with Linux, and also was working with a system that did not have access to a repository that could be configured with yum.

    I finally got the system configured by installing packages with rpm, though I must admit I don't remember exactly the steps I ended up taking. Hopefully the following information can provide some hints for your situation.

    I ran "rpm -qa --last" and it shows the packages I installed were as follows:

    pam-1.1.1-10.el6_2.1.i686                     Mon 01 Apr 2013 11:57:42 AM CDT
    compat-libstdc++-33-3.2.3-69.el6.i686         Mon 01 Apr 2013 10:07:28 AM CDT
    cracklib-2.8.16-4.el6.i686                    Mon 01 Apr 2013 10:07:19 AM CDT
    db4-4.7.25-17.el6.i686                        Mon 01 Apr 2013 10:07:13 AM CDT
    libselinux-2.0.94-5.3.el6.i686                Mon 01 Apr 2013 10:07:01 AM CDT
    libstdc++-4.4.6-4.el6.i686                    Mon 01 Apr 2013 10:06:52 AM CDT
    libgcc-4.4.6-4.el6.i686                       Mon 01 Apr 2013 10:06:43 AM CDT
    audit-libs-2.2-2.el6.i686                     Mon 01 Apr 2013 10:06:17 AM CDT
    glibc-2.12-1.80.el6.i686                      Mon 01 Apr 2013 10:06:04 AM CDT
    glibc-common-2.12-1.80.el6.x86_64             Mon 01 Apr 2013 10:05:37 AM CDT
    nss-softokn-freebl-3.12.9-11.el6.i686         Mon 01 Apr 2013 10:04:57 AM CDT

    With one exception, these were all 32-bit packages required by the TBSM installer. Based on my command history, it appears I used the rpm --nodeps and --force options to get the glibc package to install both 64 and 32 bit packages.

    245  rpm -i glibc-common-2.12-1.80.el6.x86_64.rpm --nodeps --force
    246  ls
    247  rpm -i --nodeps --force  glibc-2.12-1.80.el6.i686.rpm

    Sorry I don't have a complete account of my experience, but hopefully with the proper use of the rpm --force you can install all the required packages.

    Regards...

     

    Randy Brown

    • lbarckmann
      lbarckmann
      2 Posts
      ACCEPTED ANSWER

      Re: Preparing Redhat 6.2 OS for TBSM

      ‏2013-07-24T22:11:07Z  in response to randybrown

      Thanks Randy - got it to work - but it still seems - wrong.  Since it came with many of the 64 bit libraries installed - when the system needed both libraries - I installed the 64 bit with a simple'yum install' - which is prefered I guess because it checks all the dependencies.

      For the 32 bit libraries - if I tried to use yum install it would typically give me something like (see below at bottom)

       

      but when I did it your way it 'jammed' it in

      rpm -iv rpm-build-4.8.0-12.el6.i686.rpm --nodeps
      warning: rpm-build-4.8.0-12.el6.i686.rpm: Header V4 DSA/SHA1 Signature, key ID 192a7d7d: NOKEYPreparing packages for installation...
      rpm-build-4.8.0-12.el6
      

      I did that for each package required - and eventually got the prereq tool to PASS everything. (see attached results)

       

      But since many of these packages have problesm such as listed below - isn't that going to come back and bite me?

       

      And if so - I am not sure what to do - because I googled all over for a method to do this - and there are many suggestions but I could make none of them work consistantly.

       

      I'll go ahead with the install and report if I begin to see problems

       

      Lee

       

      yum install rpm-build-4.8.0-12.el6.i686.rpmLoaded plugins: product-id, refresh-packagekit, security, subscription-managerUpdating certificate-based repositories.Setting up Install ProcessExamining rpm-build-4.8.0-12.el6.i686.rpm: rpm-build-4.8.0-12.el6.i686Marking rpm-build-4.8.0-12.el6.i686.rpm to be installedResolving Dependencies--> Running transaction check---> Package rpm-build.i686 0:4.8.0-12.el6 will be installed--> Processing Dependency: rpm = 4.8.0-12.el6 for package: rpm-build-4.8.0-12.el6.i686--> Processing Dependency: libacl.so.1 for package: rpm-build-4.8.0-12.el6.i686--> Processing Dependency: libbz2.so.1 for package: rpm-build-4.8.0-12.el6.i686--> Processing Dependency: libdb-4.7.so for package: rpm-build-4.8.0-12.el6.i686--> Processing Dependency: libelf.so.1 for package: rpm-build-4.8.0-12.el6.i686--> Processing Dependency: libelf.so.1(ELFUTILS_1.0) for package: rpm-build-4.8.0-12.el6.i686--> Processing Dependency: liblua-5.1.so for package: rpm-build-4.8.0-12.el6.i686--> Processing Dependency: liblzma.so.0 for package: rpm-build-4.8.0-12.el6.i686--> Processing Dependency: libmagic.so.1 for package: rpm-build-4.8.0-12.el6.i686--> Processing Dependency: libnss3.so for package: rpm-build-4.8.0-12.el6.i686--> Processing Dependency: libpopt.so.0 for package: rpm-build-4.8.0-12.el6.i686--> Processing Dependency: libpopt.so.0(LIBPOPT_0) for package: rpm-build-4.8.0-12.el6.i686--> Processing Dependency: librpm.so.1 for package: rpm-build-4.8.0-12.el6.i686--> Processing Dependency: librpmbuild.so.1 for package: rpm-build-4.8.0-12.el6.i686--> Processing Dependency: librpmio.so.1 for package: rpm-build-4.8.0-12.el6.i686--> Processing Dependency: libselinux.so.1 for package: rpm-build-4.8.0-12.el6.i686--> Processing Dependency: libz.so.1 for package: rpm-build-4.8.0-12.el6.i686--> Finished Dependency ResolutionError: Package: rpm-build-4.8.0-12.el6.i686 (/rpm-build-4.8.0-12.el6.i686)           Requires: libz.so.1Error: Package: rpm-build-4.8.0-12.el6.i686 (/rpm-build-4.8.0-12.el6.i686)           Requires: libpopt.so.0Error: Package: rpm-build-4.8.0-12.el6.i686 (/rpm-build-4.8.0-12.el6.i686)           Requires: libacl.so.1Error: Package: rpm-build-4.8.0-12.el6.i686 (/rpm-build-4.8.0-12.el6.i686)           Requires: librpmio.so.1Error: Package: rpm-build-4.8.0-12.el6.i686 (/rpm-build-4.8.0-12.el6.i686)           Requires: libpopt.so.0(LIBPOPT_0)Error: Package: rpm-build-4.8.0-12.el6.i686 (/rpm-build-4.8.0-12.el6.i686)           Requires: liblua-5.1.soError: Package: rpm-build-4.8.0-12.el6.i686 (/rpm-build-4.8.0-12.el6.i686)           Requires: libnss3.soError: Package: rpm-build-4.8.0-12.el6.i686 (/rpm-build-4.8.0-12.el6.i686)           Requires: libbz2.so.1Error: Package: rpm-build-4.8.0-12.el6.i686 (/rpm-build-4.8.0-12.el6.i686)           Requires: libmagic.so.1Error: Package: rpm-build-4.8.0-12.el6.i686 (/rpm-build-4.8.0-12.el6.i686)           Requires: liblzma.so.0Error: Package: rpm-build-4.8.0-12.el6.i686 (/rpm-build-4.8.0-12.el6.i686)           Requires: libdb-4.7.soError: Package: rpm-build-4.8.0-12.el6.i686 (/rpm-build-4.8.0-12.el6.i686)           Requires: librpm.so.1Error: Package: rpm-build-4.8.0-12.el6.i686 (/rpm-build-4.8.0-12.el6.i686)           Requires: libselinux.so.1Error: Package: rpm-build-4.8.0-12.el6.i686 (/rpm-build-4.8.0-12.el6.i686)           Requires: librpmbuild.so.1Error: Package: rpm-build-4.8.0-12.el6.i686 (/rpm-build-4.8.0-12.el6.i686)           Requires: rpm = 4.8.0-12.el6           Installed: rpm-4.8.0-19.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201111171049.x86_64/6.2)               rpm = 4.8.0-19.el6Error: Package: rpm-build-4.8.0-12.el6.i686 (/rpm-build-4.8.0-12.el6.i686)           Requires: libelf.so.1Error: Package: rpm-build-4.8.0-12.el6.i686 (/rpm-build-4.8.0-12.el6.i686)           Requires: libelf.so.1(ELFUTILS_1.0) You could try using --skip-broken to work around the problem** Found 82 pre-existing rpmdb problem(s), 'yum check' output follows:compat-db-4.6.21-15.el6.i686 has missing requires of compat-db42(x86-32) = ('0', '4.2.52', '15.el6')compat-db-4.6.21-15.el6.i686 has missing requires of compat-db43(x86-32) = ('0', '4.3.29', '15.el6')compat-db-4.6.21-15.el6.x86_64 has missing requires of compat-db43(x86-64) = ('0', '4.3.29', '15.el6')compat-libstdc++-296-2.96-144.el6.i686 has missing requires of libgcc_s.so.1compat-libstdc++-296-2.96-144.el6.i686 has missing requires of libgcc_s.so.1(GLIBC_2.0)compat-libstdc++-33-3.2.3-69.el6.i686 has missing requires of libgcc_s.so.1compat-libstdc++-33-3.2.3-69.el6.i686 has missing requires of libgcc_s.so.1(GCC_3.0)compat-libstdc++-33-3.2.3-69.el6.i686 has missing requires of libgcc_s.so.1(GCC_3.3)compat-libstdc++-33-3.2.3-69.el6.i686 has missing requires of libgcc_s.so.1(GLIBC_2.0)glibc-2.12-1.107.el6.i686 is a duplicate with glibc-2.12-1.47.el6.x86_64glibc-2.12-1.107.el6.i686 has missing requires of glibc-common = ('0', '2.12', '1.107.el6')glibc-2.12-1.107.el6.i686 has missing requires of libfreebl3.soglibc-2.12-1.107.el6.i686 has missing requires of libfreebl3.so(NSSRAWHASH_3.12.3)gtk2-2.18.9-4.el6.i686 has missing requires of libX11.so.6gtk2-2.18.9-4.el6.i686 has missing requires of libXcomposite.so.1gtk2-2.18.9-4.el6.i686 has missing requires of libXcursor.so.1gtk2-2.18.9-4.el6.i686 has missing requires of libXdamage.so.1gtk2-2.18.9-4.el6.i686 has missing requires of libXext.so.6gtk2-2.18.9-4.el6.i686 has missing requires of libXfixes.so.3gtk2-2.18.9-4.el6.i686 has missing requires of libXi.so.6gtk2-2.18.9-4.el6.i686 has missing requires of libXinerama.so.1gtk2-2.18.9-4.el6.i686 has missing requires of libXrandr.so.2gtk2-2.18.9-4.el6.i686 has missing requires of libXrender.so.1gtk2-2.18.9-4.el6.i686 has missing requires of libatk-1.0.so.0gtk2-2.18.9-4.el6.i686 has missing requires of libcairo.so.2gtk2-2.18.9-4.el6.i686 has missing requires of libcups.so.2gtk2-2.18.9-4.el6.i686 has missing requires of libfontconfig.so.1gtk2-2.18.9-4.el6.i686 has missing requires of libfreetype.so.6gtk2-2.18.9-4.el6.i686 has missing requires of libgio-2.0.so.0gtk2-2.18.9-4.el6.i686 has missing requires of libglib-2.0.so.0gtk2-2.18.9-4.el6.i686 has missing requires of libgmodule-2.0.so.0gtk2-2.18.9-4.el6.i686 has missing requires of libgobject-2.0.so.0gtk2-2.18.9-4.el6.i686 has missing requires of libjasper.so.1gtk2-2.18.9-4.el6.i686 has missing requires of libjpeg.so.62gtk2-2.18.9-4.el6.i686 has missing requires of libpango-1.0.so.0gtk2-2.18.9-4.el6.i686 has missing requires of libpangocairo-1.0.so.0gtk2-2.18.9-4.el6.i686 has missing requires of libpangoft2-1.0.so.0gtk2-2.18.9-4.el6.i686 has missing requires of libpng12.so.0gtk2-2.18.9-4.el6.i686 has missing requires of libpng12.so.0(PNG12_0)gtk2-2.18.9-4.el6.i686 has missing requires of libtiff.so.3gtk2-2.18.9-6.el6.x86_64 is a duplicate with gtk2-2.18.9-4.el6.i686gtk2-engines-2.18.4-5.el6.centos.i686 is a duplicate with gtk2-engines-2.18.4-5.el6.x86_64gtk2-engines-2.18.4-5.el6.centos.i686 has missing requires of libatk-1.0.so.0gtk2-engines-2.18.4-5.el6.centos.i686 has missing requires of libcairo.so.2gtk2-engines-2.18.4-5.el6.centos.i686 has missing requires of libfontconfig.so.1gtk2-engines-2.18.4-5.el6.centos.i686 has missing requires of libfreetype.so.6gtk2-engines-2.18.4-5.el6.centos.i686 has missing requires of libgio-2.0.so.0gtk2-engines-2.18.4-5.el6.centos.i686 has missing requires of libglib-2.0.so.0gtk2-engines-2.18.4-5.el6.centos.i686 has missing requires of libgmodule-2.0.so.0gtk2-engines-2.18.4-5.el6.centos.i686 has missing requires of libgobject-2.0.so.0gtk2-engines-2.18.4-5.el6.centos.i686 has missing requires of libpango-1.0.so.0gtk2-engines-2.18.4-5.el6.centos.i686 has missing requires of libpangocairo-1.0.so.0gtk2-engines-2.18.4-5.el6.centos.i686 has missing requires of libpangoft2-1.0.so.0libXft-2.1.13-4.1.el6.i686 has missing requires of libX11.so.6libXft-2.1.13-4.1.el6.i686 has missing requires of libXrender.so.1libXft-2.1.13-4.1.el6.i686 has missing requires of libfontconfig.so.1libXft-2.1.13-4.1.el6.i686 has missing requires of libfreetype.so.6libXmu-1.0.5-1.el6.i686 has missing requires of libX11.so.6libXmu-1.0.5-1.el6.i686 has missing requires of libXext.so.6libXmu-1.0.5-1.el6.i686 has missing requires of libXt.so.6libXp-1.0.0-15.1.el6.i686 has missing requires of libX11.so.6libXp-1.0.0-15.1.el6.i686 has missing requires of libXau.so.6libXp-1.0.0-15.1.el6.i686 has missing requires of libXext.so.6libcap-2.16-5.5.el6.i686 has missing requires of libattr.so.1libcap-2.16-5.5.el6.i686 has missing requires of libattr.so.1(ATTR_1.0)openmotif-2.3.3-5.el6_3.i686 is a duplicate with openmotif-2.3.3-1.el6.x86_64openmotif-2.3.3-5.el6_3.i686 has missing requires of libICE.so.6openmotif-2.3.3-5.el6_3.i686 has missing requires of libSM.so.6openmotif-2.3.3-5.el6_3.i686 has missing requires of libX11.so.6openmotif-2.3.3-5.el6_3.i686 has missing requires of libXext.so.6openmotif-2.3.3-5.el6_3.i686 has missing requires of libXrender.so.1openmotif-2.3.3-5.el6_3.i686 has missing requires of libXt.so.6openmotif-2.3.3-5.el6_3.i686 has missing requires of libfontconfig.so.1openmotif-2.3.3-5.el6_3.i686 has missing requires of libfreetype.so.6openmotif-2.3.3-5.el6_3.i686 has missing requires of libjpeg.so.62openmotif-2.3.3-5.el6_3.i686 has missing requires of libpng12.so.0openmotif-2.3.3-5.el6_3.i686 has missing requires of libpng12.so.0(PNG12_0)openmotif22-2.2.3-19.el6.i686 has missing requires of libICE.so.6openmotif22-2.2.3-19.el6.i686 has missing requires of libSM.so.6openmotif22-2.2.3-19.el6.i686 has missing requires of libX11.so.6openmotif22-2.2.3-19.el6.i686 has missing requires of libXext.so.6openmotif22-2.2.3-19.el6.i686 has missing requires of libXt.so.6[root@tbsm61 lee]# ls -ltr
      

      Attachments

      Updated on 2013-07-24T22:13:18Z at 2013-07-24T22:13:18Z by lbarckmann
  • mschuere
    mschuere
    7 Posts
    ACCEPTED ANSWER

    Re: Preparing Redhat 6.2 OS for TBSM

    ‏2013-08-01T05:56:37Z  in response to lbarckmann

    I had something similar,

    e.g.  Couldnt instal the 32bit pam..   It complained about conflicting with my pam.x86_64

    however..  I noticed that the yum version of the pam.i686 was not the exact same version as the rpm/dvd installed version..

    so if you do a yum upgrade first (if allowed ) ,  you can install the i686 version..