Topic
1 reply Latest Post - ‏2013-08-08T06:24:11Z by FW11_SImon_Coote
FW11_SImon_Coote
FW11_SImon_Coote
2 Posts
ACCEPTED ANSWER

Pinned topic JazzSM DASH - navigation bar icons disappeared.

‏2013-08-07T11:49:33Z |

Problem description:  No icons (Settings, Favourites, Server Dashboards etc.) are available in the Navigation Bar.  This is the case for ALL users, including the 'wasadmin' id.

Platform:

SLES 11 SP2 64b

JazzSM 1.1, IBM Dashboard App Services 3.1, IBM infr. Mgmt. Dashboards for Servers 1.1.0.1

Configuration:

LDAP = MSAD + defaultWIMFileBasedRealm

After configuring the additional LDAP entry in the repository I restarted the app server.  I then logged in as wasadmin and added a LDAP group to the following Roles: administrator PlatformAdministrator iscadmins chartAdministrator

I restarted the app server again, and after logging in (trying both LDAP user and wasadmin) found all the icons had disappeared.

I am sure something has gone wrong with role mapping etc., but not sure where to start troubleshooting.  I have tried removing the LDAP entry and reverting to file based, but this has not helped.

Not sure what to try next......

 

Attachments

  • FW11_SImon_Coote
    FW11_SImon_Coote
    2 Posts
    ACCEPTED ANSWER

    Re: JazzSM DASH - navigation bar icons disappeared.

    ‏2013-08-08T06:24:11Z  in response to FW11_SImon_Coote

    I managed to find the root cause.  When configuring SSO through the admin console, under Global Security -> SSO -> General Properties, the option 'Requires SSL' was checked.  Not sure why it was checked as the default is 'unchecked'.  After restarting the app server things were back to normal.