Topic
  • 4 replies
  • Latest Post - ‏2013-09-13T16:48:54Z by Walt_Madden
bmwilli
bmwilli
41 Posts

Pinned topic Standalone segfault on Power7

‏2013-09-12T19:49:51Z |

I am just starting to work on  a Power7 RHEL 6 system.  I can start an instance, and run distributed jobs without any problem.

When I compile something as simple as HelloWorld.spl (beacon -> custom) in standalone mode, it will not run.

The compile works without any errors.  When I run the standalone app, it segmentation faults.

GDB shows the fault is occuring in initEnvironmentEv.

 

Any ideas what to look for?

  • Stan
    Stan
    76 Posts

    Re: Standalone segfault on Power7

    ‏2013-09-12T23:53:21Z  

    Please run he dependency checker :  $STREAMS_INSTALL/bin/dependency_checker.sh

    Check the OS vesion is 6.2 or higher  and look for warnings.

    Please post the error message and stack trace produced with the failure and since the failure seems to be in intialization ( initEnvironmentEv) post the output of ULIMIT -a

    Information on ULIMIT is found here:  http://pic.dhe.ibm.com/infocenter/streams/v3r1/topic/com.ibm.swg.im.infosphere.streams.install-admin.doc/doc/ibminfospherestreams-install-operating-system-settings.html

     

  • hnasgaard
    hnasgaard
    200 Posts

    Re: Standalone segfault on Power7

    ‏2013-09-13T12:27:30Z  
    • Stan
    • ‏2013-09-12T23:53:21Z

    Please run he dependency checker :  $STREAMS_INSTALL/bin/dependency_checker.sh

    Check the OS vesion is 6.2 or higher  and look for warnings.

    Please post the error message and stack trace produced with the failure and since the failure seems to be in intialization ( initEnvironmentEv) post the output of ULIMIT -a

    Information on ULIMIT is found here:  http://pic.dhe.ibm.com/infocenter/streams/v3r1/topic/com.ibm.swg.im.infosphere.streams.install-admin.doc/doc/ibminfospherestreams-install-operating-system-settings.html

     

    Please try the following experiment:

    In your xterm window,

    Set the STREAMS_INSTANCE_ID environment variable to some string, say

    export STREAMS_INSTANCE_ID=user

    Now run the standalone application and post the results.

  • Stan
    Stan
    76 Posts

    Re: Standalone segfault on Power7

    ‏2013-09-13T14:08:45Z  

    I understand you have  internal contacts working this issue.  Please continue to work with these people to resolve the problem and post the resolution and background information  to this thread for the benefit of Streams Forum users.

    thanks,  Stan

  • Walt_Madden
    Walt_Madden
    6 Posts

    Re: Standalone segfault on Power7

    ‏2013-09-13T16:48:54Z  

    Brian and I exchanged a couple of notes outside of this discussion and it appears the issue is likely to be the uid being used to run the Standalone application is local to the machine and does not exist in the LDAP user database.  Streams is not expecting "not found" as the response to the user database query.

    This is an unusual situation (but not difficult to get into while a new system is being set up).  We'll work to better handle this within Streams in a future release.  Also note the situation could apply to either X86 or Power.