IC5Notice: We have upgraded developerWorks Community to the latest version of IBM Connections. For more information, read our upgrade FAQ.
Topic
  • 2 replies
  • Latest Post - ‏2015-04-29T09:53:53Z by stevealee
RonRispens
RonRispens
2 Posts

Pinned topic Invalid binding in new field using a view

‏2013-10-16T12:44:26Z |
Dear all,
 
I have a problem/question about a invalid binding error that i will try to explain below.
 
Configuration:
IBM Maximo Asset Management 7.5.0.0 Build 20110720-0539 DB Build V7500-00
Tivoli's process automation engine 7.5.0.0 Build 20110720-0539 DB Build V7500-723
 
Situation
I am calculating a value 1 or 0 for each asset in the asset table with the use of a view. In the query of this view is the calculation with use of a CASE to determine if the asset needs a 1 value or a 0 value. The value is also stored in the view as attribute "example001". I want to show this value that is generated by the view in a field added to the asset application (asset tab). 
 
Step by step:
1. I have created a extra attribute for the asset table with the database configuration in maximo. The attribute is called example001. (checked and visible in database) 
 
2. I have created a view with the database configuration in maximo (with all original fields from the asset table). The value that is calculated by the view is stored in a column named example001 same name as the one in the asset table. (checked and view is visible and working in database)
 
3. I have created a relationship with the database configuration on the asset object. The relationship points to the view and the where clause is just assetnum=:assetnum and siteid=:siteid.
 
4. I have added a field to the asset application (asset tab) and in the properties i have added the attribute with relationship from point 3. Like this: EXAMPLE_RELATIONSHIP.EXAMPLE001 where EXAMPLE001 is the attribute in the database. 
 
The problem and question
The problem is that this field shows invalid binding. I have tried almost everything and searched for a long time on the internet but without any result.
I have looked it up in the logs from the application and it shows the following: Attribute Example001 does not exist.
If I change the relationship in the new added field it gives a relationship error  in the log.
If I point to the Example001attribute in the asset table I don't see a error at all. 
If I look at the attributes with the magnifying glass in the properties from the field it shows Example001 in the asset table and also the Example 001 in the VIEW. 
So I think that Maximo is able to see the relationship but somehow cannot connect to the attributes in the view. 
 
Somebody who has seen this problem before? 
Maybe I am missing something, an important step?
 
Please help.
 
Met vriendelijke groet / Kind regards / Sincères salutations,
 
Ron Rispens
 
 
 

 

Updated on 2013-10-17T07:43:31Z at 2013-10-17T07:43:31Z by RonRispens
  • RonRispens
    RonRispens
    2 Posts

    Re: Invalid binding in new field using a view

    ‏2013-10-31T08:48:36Z  

    Solved by changing view/case

  • stevealee
    stevealee
    1 Post

    Re: Invalid binding in new field using a view

    ‏2015-04-29T09:53:53Z  

    Solved by changing view/case

    Hi, Can you please provide the details of how you resolved this and what changes you had to make to the View / Case

     

    Regards

    Steve