Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
1 reply Latest Post - ‏2013-10-01T10:45:39Z by Michael Pointer
JXaviour
JXaviour
1 Post
ACCEPTED ANSWER

Pinned topic JAR not found errors while starting Application Builder

‏2013-10-01T10:03:12Z |

Hello, I have data explorer 8.2.3 and trying the Application Builder tutorial in data explorer v 8.2 incenter
http://pic.dhe.ibm.com/infocenter/dataexpl/v8r2/index.jsp?topic=%2Fcom.ibm.swg.im.infosphere.dataexplorer.product.doc%2FHTML%2Fch09s07.html&path%3D9_6

The velocity connection is created correctly to the collection 'example-metadata' as I could test it through Entity Explorer. After I created the widgets and the 'Book Title' page, when I go to Home and then click Book Titles page, no listings get displayed as expected. In the messages.log, the following errors are added.

[10/1/13 15:00:17:427 IST] 00000067 com.ibm.ws.webcontainer.extension                            W SRVE0190E: File not found: /admin/entity_types_explorer.html
[10/1/13 15:00:22:418 IST] 0000006c com.ibm.ws.webcontainer.extension                            W SRVE0190E: File not found: /admin/entity_models.html
[10/1/13 15:02:05:777 IST] 0000007d com.ibm.ws.webcontainer.extension                            W SRVE0190E: File not found: /index.html
[10/1/13 15:02:06:843 IST] 00000083 com.ibm.ws.webcontainer.extension                            W SRVE0190E: File not found: /images/logo.html
[10/1/13 15:02:30:648 IST] 0000008a com.ibm.ws.webcontainer.extension                            W SRVE0190E: File not found: /Book Title.html
[10/1/13 15:02:31:044 IST] 0000008e com.ibm.ws.webcontainer.extension                            W SRVE0190E: File not found: /images/logo.html


Also I noticed other errors in the messages.log while starting AppBuilder that a huge number of jars could not be loaded due to the reason 'The system cannot find the path specified'. But these path and jar file exists in the system. sample logs below

[10/1/13 14:57:45:908 IST] 0000002b com.ibm.ws.webcontainer.util                                 E SRVE8043E: An IOException occured searching jarFile [] for fileName [META-INF/resources/WEB-INF/classes/] java.io.FileNotFoundException: C:\Program%20Files\IBM\IDE\AppBuilder\wlp\usr\servers\AppBuilder\workarea\org.eclipse.osgi\bundles\60\data\cache\com.ibm.ws.app.manager_gen_bd502b2e-c326-4a3d-b02b-52c254be3460\WEB-INF\lib\gems-gems-nokogiri-1.5.6-java-lib-nokogiri-nokogiri.jar (The system cannot find the path specified.)
[10/1/13 14:57:45:908 IST] 0000002b com.ibm.ws.webcontainer.util                                 E SRVE8043E: An IOException occured searching jarFile [] for fileName [META-INF/resources/WEB-INF/classes/] java.io.FileNotFoundException: C:\Program%20Files\IBM\IDE\AppBuilder\wlp\usr\servers\AppBuilder\workarea\org.eclipse.osgi\bundles\60\data\cache\com.ibm.ws.app.manager_gen_bd502b2e-c326-4a3d-b02b-52c254be3460\WEB-INF\lib\gems-gems-nokogiri-1.5.6-java-lib-xercesImpl.jar (The system cannot find the path specified.)
[10/1/13 14:57:45:909 IST] 0000002b com.ibm.ws.webcontainer.util                                 E SRVE8043E: An IOException occured searching jarFile [] for fileName [META-INF/resources/WEB-INF/classes/] java.io.FileNotFoundException: C:\Program%20Files\IBM\IDE\AppBuilder\wlp\usr\servers\AppBuilder\workarea\org.eclipse.osgi\bundles\60\data\cache\com.ibm.ws.app.manager_gen_bd502b2e-c326-4a3d-b02b-52c254be3460\WEB-INF\lib\jruby-core-1.7.2.jar (The system cannot find the path specified.)


I installed IDE in 'Program Files' folder. Is this an issue?

Is the first set of errors due to the jar loading failure?

Please help to resolve these issues.

  • Michael Pointer
    Michael Pointer
    8 Posts
    ACCEPTED ANSWER

    Re: JAR not found errors while starting Application Builder

    ‏2013-10-01T10:45:39Z  in response to JXaviour

    Joseph,

     

    Can you file a PMR (service request) with IBM Technical Support for this issue?  I think it is more properly handled in the context of customer support than this forum.  Let me know either way, however.

     

    Thanks,

    Mike Pointer