Topic
2 replies Latest Post - ‏2013-07-25T20:23:22Z by LRW
LRW
LRW
6 Posts
ACCEPTED ANSWER

Pinned topic Error - Cannot include fex specified by provided key

‏2013-07-25T13:15:01Z |

A new report was promoted to production yesterday.  It has a html launch page, a 'document' fex and 4 report fex.  When I run the html I get the expected prompt with the selections available.  I make my selection and run and get

                           Error

Cannot include fex specified by provided key

I checked the path to the document fex in the html against the path for the object in the QWQREPOS.WF_REPOSOBJ file and they agree.  So what is this "key provided" and how do we fix this?

I have attached the html code.

A quick solution would be wonderful.  The report was originally created in V1.1.2 but then we couldn't access the document due to a permission error.  Since our user had been waiting for this report to go to production since we upgraded the first week in April, Wayne finally just created a new document in V2.1.0.  We really need this to work so we can make it available to the user.

Thanks

Attachments

  • grusys
    grusys
    144 Posts
    ACCEPTED ANSWER

    Re: Error - Cannot include fex specified by provided key

    ‏2013-07-25T18:20:41Z  in response to LRW

    @LRW,

    I have the same problem and same error. See my open question from Mar 19, 2013:

    Link to my question

    In my case the problem only occurs on a PC with Win7-SP1 64-bit.

    There is no problem on a PC with Win XP.

    • LRW
      LRW
      6 Posts
      ACCEPTED ANSWER

      Re: Error - Cannot include fex specified by provided key

      ‏2013-07-25T20:23:22Z  in response to grusys

      I saw your post but wasn't sure that it was exactly the same thing since my drop down list in the html was populated.  We are on Win7 Enterprise except for one developer.  The developer who worked on this is running Win XP in a virtual environment.  We all get the same error when trying to run the report.  We are operating on one IBM i and have HL folders for our development/test and production environments.  Since we do not have separate systems or partitions for these, we can't use the change management provided in this release and have to continue to copy/paste between folders.

      I have had two people collaborating and working on this all day.  They finally got it resolved.  This is the update I got from them.

      We have the report working in production. It was not easy. The compound document doesn't copy from uat to prd very well. The report paths don't change. I don't want to and not sure I can explain all the convoluted steps to get it to work. It looks to me as though we will have to rewrite every html and document every time we copy from one HL folder to another. Also the stylesheet path within each fex does not change when copied. We might even have to rewrite a lot until IBM can fix the copy paste issue.

      The production report has a slight difference compared to uat.

      Thanks,