IC SunsetThe developerWorks Connections platform will be sunset on December 31, 2019. On January 1, 2020, this forum will no longer be available. More details available on our FAQ.
Topic
  • 5 replies
  • Latest Post - ‏2018-05-02T03:11:45Z by GuoQiangLi
FJN7_bujjireddy_regalla
7 Posts

Pinned topic Server error CWWKS9122I

‏2018-04-19T14:40:36Z |

Hi ,
I am getting the following error and not able to connect to default host,can you please help me.
CWWKS9122I:  For URL /* in application com.ibm.zosconnect.apirequester,
the following HTTP methods are uncovered, and accessible: OPTIONS 

  • GuoQiangLi
    GuoQiangLi
    12 Posts

    Re: Server error CWWKS9122I

    ‏2018-04-23T00:20:11Z  

    Hi,

    Could you please give me a bit more information? Are you trying API requester (outbound) capability in zCEE? which URL are you trying to access and how? eg through a browser? Thanks

  • FJN7_bujjireddy_regalla
    7 Posts

    Re: Server error CWWKS9122I

    ‏2018-04-30T07:07:28Z  

    Hi,

    Could you please give me a bit more information? Are you trying API requester (outbound) capability in zCEE? which URL are you trying to access and how? eg through a browser? Thanks

    Hi ,

     

    I have created a default zos connect server ,and which has given me a default host name and port number in the started task log.I used the same host and port through internet explorer to login to the server but I am not able to login. 

    CWWKE0001I: The server xxxserver has been launched.                            
    BAQR0000I: z/OS Connect Enterprise Edition open beta (20180403-1244)           
    BAQR9999I: Open beta version will expire at Mon Jul 02 00:00:00 GMT 2018       
    CWWKF0015I: The server has the following interim fixes active in the runtime: PI91500. For a full listing of installed fixes run: productInfo version --ifixes
    CWWKF0012I: The server installed the following features: [servlet-3.1, ssl-1.0,0, jndi-1.0, json-1.0, zosconnect:zosConnect-2.0, zosconnect:commands-1.0, distributedMap-1.0, appSecurity-2.0, jaxrsClient-2.0].
    CWWKF0011I: The server xxxserver is ready to run a smarter planet.             
    CWWKT0016I: Web application available (default_host): http://10.1.0.68:9081/   
    CWPKI0817A: The default SSL configuration expects a <keyStore> element with an id value of defaultKeyStore, and a password. The defaultKeyStore <keyStore> element is missing, or the password is not specified. Either define the missing eleement: <keyStore id="defaultKeyStore" password="yourpassword" />, or change the default SSL configuration to use an existing keystore. See the following example: <ssl id="defaultSSLConfig" keyStoreRef="newKeyStore" />

    When I see for error in the server logs I am able to see /IURL is not covered and JVM is exiting messages.

    SRVE0242I: [com.ibm.zosconnect] [/] [com.ibm.zosconnect.internal.web.Ser
    CWWKS9122I:  For URL /* in application com.ibm.zosconnect, the following
    CWPKI0817A: The default SSL configuration expects a <keyStore> element w
    CWWKE0085I: The server bmcserver is stopping because the JVM is exiting.

    Can you please check once.

    Thanks,

    Bujji

  • GuoQiangLi
    GuoQiangLi
    12 Posts

    Re: Server error CWWKS9122I

    ‏2018-05-01T00:01:58Z  

    Hi ,

     

    I have created a default zos connect server ,and which has given me a default host name and port number in the started task log.I used the same host and port through internet explorer to login to the server but I am not able to login. 

    CWWKE0001I: The server xxxserver has been launched.                            
    BAQR0000I: z/OS Connect Enterprise Edition open beta (20180403-1244)           
    BAQR9999I: Open beta version will expire at Mon Jul 02 00:00:00 GMT 2018       
    CWWKF0015I: The server has the following interim fixes active in the runtime: PI91500. For a full listing of installed fixes run: productInfo version --ifixes
    CWWKF0012I: The server installed the following features: [servlet-3.1, ssl-1.0,0, jndi-1.0, json-1.0, zosconnect:zosConnect-2.0, zosconnect:commands-1.0, distributedMap-1.0, appSecurity-2.0, jaxrsClient-2.0].
    CWWKF0011I: The server xxxserver is ready to run a smarter planet.             
    CWWKT0016I: Web application available (default_host): http://10.1.0.68:9081/   
    CWPKI0817A: The default SSL configuration expects a <keyStore> element with an id value of defaultKeyStore, and a password. The defaultKeyStore <keyStore> element is missing, or the password is not specified. Either define the missing eleement: <keyStore id="defaultKeyStore" password="yourpassword" />, or change the default SSL configuration to use an existing keystore. See the following example: <ssl id="defaultSSLConfig" keyStoreRef="newKeyStore" />

    When I see for error in the server logs I am able to see /IURL is not covered and JVM is exiting messages.

    SRVE0242I: [com.ibm.zosconnect] [/] [com.ibm.zosconnect.internal.web.Ser
    CWWKS9122I:  For URL /* in application com.ibm.zosconnect, the following
    CWPKI0817A: The default SSL configuration expects a <keyStore> element w
    CWWKE0085I: The server bmcserver is stopping because the JVM is exiting.

    Can you please check once.

    Thanks,

    Bujji

    HI Bujji,

    zCEE doesn't provides default home page. Login through IE will not show any page. If you want to try zCEE, I would recommend you try to set up a demo following this.

    If you want to try inbound, eg expose CiCS/IMS application as restful service, you can try this

    https://www.ibm.com/support/knowledgecenter/SS4SVW_3.0.0/com.ibm.zosconnect.doc/scenarios/scenarios.html

     

    If you want to try call out. eg call restful API from CICS/IMS application, you can try this.

    https://www.ibm.com/support/knowledgecenter/SS4SVW_3.0.0/com.ibm.zosconnect.doc/scenarios/apireq_scenarios.html

     

    Let us know if you meet any issue. Thanks.

     

  • FJN7_bujjireddy_regalla
    7 Posts

    Re: Server error CWWKS9122I

    ‏2018-05-01T05:45:29Z  

    HI Bujji,

    zCEE doesn't provides default home page. Login through IE will not show any page. If you want to try zCEE, I would recommend you try to set up a demo following this.

    If you want to try inbound, eg expose CiCS/IMS application as restful service, you can try this

    https://www.ibm.com/support/knowledgecenter/SS4SVW_3.0.0/com.ibm.zosconnect.doc/scenarios/scenarios.html

     

    If you want to try call out. eg call restful API from CICS/IMS application, you can try this.

    https://www.ibm.com/support/knowledgecenter/SS4SVW_3.0.0/com.ibm.zosconnect.doc/scenarios/apireq_scenarios.html

     

    Let us know if you meet any issue. Thanks.

     

    Hi,

     

    Thanks for the information.

    I am able to see the below message as server stopped because fo JVM exit.

    SRVE0242I: [com.ibm.zosconnect] [/] [com.ibm.zosconnect.internal.web.Ser

    CWWKS9122I:  For URL /* in application com.ibm.zosconnect, the following
    CWPKI0817A: The default SSL configuration expects a <keyStore> element w
    CWWKE0085I: The server bmcserver is stopping because the JVM is exiting.

    Can you please check and let me know is this is a normal message before I configure the any service.

    Thanks,

    Bujji

  • GuoQiangLi
    GuoQiangLi
    12 Posts

    Re: Server error CWWKS9122I

    ‏2018-05-02T03:11:45Z  

    Hi,

     

    Thanks for the information.

    I am able to see the below message as server stopped because fo JVM exit.

    SRVE0242I: [com.ibm.zosconnect] [/] [com.ibm.zosconnect.internal.web.Ser

    CWWKS9122I:  For URL /* in application com.ibm.zosconnect, the following
    CWPKI0817A: The default SSL configuration expects a <keyStore> element w
    CWWKE0085I: The server bmcserver is stopping because the JVM is exiting.

    Can you please check and let me know is this is a normal message before I configure the any service.

    Thanks,

    Bujji

    Sure,

    To fix CWPKI0817A Please refer to this document

    https://developer.ibm.com/answers/questions/432733/message-cwpki0817a-the-defaultkeystore-element-is.html

     

    Regarding the CWWKE0085I. I need more information

    How you started zCEE? through JCL or command in USS? If command, please show the command.

    Is zCEE shut down immediately after it starts up?

    Any action you took before you see the message? 

    Thanks

    Storm