Topic
  • 6 replies
  • Latest Post - ‏2014-09-02T08:48:27Z by borislavbaros
Richard_Hine
Richard_Hine
12 Posts

Pinned topic VMware discovery problem - missing plugin

‏2013-12-12T21:37:31Z |

Running the BETA3 code, and am struggling with the VMware discovery process, can anyone help me debug this?

getting the following from the ccm.trace.log file

2013-12-12 21:19:54.757+00:00 Thread SDPAdapterTask: VMwarePlugin connect      com.sun.xml.internal.ws.client.ClientTransportException: The server sent HTTP status code 301: Moved Permanently
        at com.sun.xml.internal.ws.transport.http.client.HttpTransportPipe.checkStatusCode(HttpTransportPipe.java:308)
        at com.sun.xml.internal.ws.transport.http.client.HttpTransportPipe.createResponsePacket(HttpTransportPipe.java:257)
      .

2013-12-12 21:19:54.757+00:00 Thread SDPAdapterTask: DiscoveryManager discovery      VMWARE discovery plugin not available

Am I missing some VMware prereq? I am using the VMware vCentre linux appliance.

Thanks, Richard

2013-12-12 21:19:54.757+00:00 Thread SDPAdapterTask: DiscoveryManager discovery      Problems in discovery cycle, no instances discovered
 

Updated on 2013-12-13T12:45:38Z at 2013-12-13T12:45:38Z by Richard_Hine
  • Andreay
    Andreay
    3 Posts
    ACCEPTED ANSWER

    Re: VMware discovery problem - missing plugin

    ‏2013-12-13T15:30:07Z  

    Hello again Chris, have reinstalled VMware tools on the Smartcloud AI server, but no change.

    2013-12-13 07:32:50.771+00:00 Thread SDPAdapterTask: DiscoveryManager checkPluginAvailability      Reconnecting to VMWARE discovery plugin
    2013-12-13 07:32:50.771+00:00 Thread SDPAdapterTask: VMwarePlugin connect      Connecting to http://sco-vcs.cloud.local:80/sdk/vimService using user root
    2013-12-13 07:32:50.772+00:00 Thread SDPAdapterTask: VMwareWebSrvClient rewriteEth0CfgFile      Processing file /etc/sysconfig/network-scripts/ifcfg-eth0
    2013-12-13 07:32:50.772+00:00 Thread SDPAdapterTask: VMwareWebSrvClient rewriteEth0CfgFile      File not found: /etc/sysconfig/networking/devices/ifcfg-eth0
    2013-12-13 07:32:52.727+00:00 Thread SDPAdapterTask: VMwarePlugin connect      com.sun.xml.internal.ws.client.ClientTransportException: The server sent HTTP status code 301: Moved Permanently

    at com.sun.xml.internal.ws.transport.http.client.HttpTransportPipe.checkStatusCode(HttpTransportPipe.java:308)
            at com.sun.xml.internal.ws.transport.http.client.HttpTransportPipe.createResponsePacket(HttpTransportPipe.java:257)
            at com.sun.xml.internal.ws.transport.http.client.HttpTransportPipe.process(HttpTransportPipe.java:215)

    .

    2013-12-13 08:36:22.811+00:00 Thread SDPAdapterTask: DiscoveryManager discovery      VMWARE discovery plugin not available
    2013-12-13 08:36:22.811+00:00 Thread SDPAdapterTask: DiscoveryManager discovery      Problems in discovery cycle, no instances discovered
     

    Sorry about these logs - but any idea how to debug? Thanks


     

    This exception usually means you are tying to establish a non SSL connection with a VVCenter server that does not support it.

    Change the configuration to use SSL and make sure the SSL port is correct (default for SSL is 443 - 80 is for non SSL)

    There is no need to import the certificate as long as you set  the validateCertificates to false.

  • RM03_Chris_Barlock
    RM03_Chris_Barlock
    43 Posts

    Re: VMware discovery problem - missing plugin

    ‏2013-12-12T23:06:39Z  

    I'm not the expert in this area, but I believe the VMware tools need to be installed on your VMs.  If they are missing, that could be the reason.

    Chris

  • Richard_Hine
    Richard_Hine
    12 Posts

    Re: VMware discovery problem - missing plugin

    ‏2013-12-13T09:52:13Z  

    I'm not the expert in this area, but I believe the VMware tools need to be installed on your VMs.  If they are missing, that could be the reason.

    Chris

    Hello again Chris, have reinstalled VMware tools on the Smartcloud AI server, but no change.

    2013-12-13 07:32:50.771+00:00 Thread SDPAdapterTask: DiscoveryManager checkPluginAvailability      Reconnecting to VMWARE discovery plugin
    2013-12-13 07:32:50.771+00:00 Thread SDPAdapterTask: VMwarePlugin connect      Connecting to http://sco-vcs.cloud.local:80/sdk/vimService using user root
    2013-12-13 07:32:50.772+00:00 Thread SDPAdapterTask: VMwareWebSrvClient rewriteEth0CfgFile      Processing file /etc/sysconfig/network-scripts/ifcfg-eth0
    2013-12-13 07:32:50.772+00:00 Thread SDPAdapterTask: VMwareWebSrvClient rewriteEth0CfgFile      File not found: /etc/sysconfig/networking/devices/ifcfg-eth0
    2013-12-13 07:32:52.727+00:00 Thread SDPAdapterTask: VMwarePlugin connect      com.sun.xml.internal.ws.client.ClientTransportException: The server sent HTTP status code 301: Moved Permanently

    at com.sun.xml.internal.ws.transport.http.client.HttpTransportPipe.checkStatusCode(HttpTransportPipe.java:308)
            at com.sun.xml.internal.ws.transport.http.client.HttpTransportPipe.createResponsePacket(HttpTransportPipe.java:257)
            at com.sun.xml.internal.ws.transport.http.client.HttpTransportPipe.process(HttpTransportPipe.java:215)

    .

    2013-12-13 08:36:22.811+00:00 Thread SDPAdapterTask: DiscoveryManager discovery      VMWARE discovery plugin not available
    2013-12-13 08:36:22.811+00:00 Thread SDPAdapterTask: DiscoveryManager discovery      Problems in discovery cycle, no instances discovered
     

    Sorry about these logs - but any idea how to debug? Thanks


     

    Updated on 2013-12-13T12:46:33Z at 2013-12-13T12:46:33Z by Richard_Hine
  • Andreay
    Andreay
    3 Posts

    Re: VMware discovery problem - missing plugin

    ‏2013-12-13T15:30:07Z  

    Hello again Chris, have reinstalled VMware tools on the Smartcloud AI server, but no change.

    2013-12-13 07:32:50.771+00:00 Thread SDPAdapterTask: DiscoveryManager checkPluginAvailability      Reconnecting to VMWARE discovery plugin
    2013-12-13 07:32:50.771+00:00 Thread SDPAdapterTask: VMwarePlugin connect      Connecting to http://sco-vcs.cloud.local:80/sdk/vimService using user root
    2013-12-13 07:32:50.772+00:00 Thread SDPAdapterTask: VMwareWebSrvClient rewriteEth0CfgFile      Processing file /etc/sysconfig/network-scripts/ifcfg-eth0
    2013-12-13 07:32:50.772+00:00 Thread SDPAdapterTask: VMwareWebSrvClient rewriteEth0CfgFile      File not found: /etc/sysconfig/networking/devices/ifcfg-eth0
    2013-12-13 07:32:52.727+00:00 Thread SDPAdapterTask: VMwarePlugin connect      com.sun.xml.internal.ws.client.ClientTransportException: The server sent HTTP status code 301: Moved Permanently

    at com.sun.xml.internal.ws.transport.http.client.HttpTransportPipe.checkStatusCode(HttpTransportPipe.java:308)
            at com.sun.xml.internal.ws.transport.http.client.HttpTransportPipe.createResponsePacket(HttpTransportPipe.java:257)
            at com.sun.xml.internal.ws.transport.http.client.HttpTransportPipe.process(HttpTransportPipe.java:215)

    .

    2013-12-13 08:36:22.811+00:00 Thread SDPAdapterTask: DiscoveryManager discovery      VMWARE discovery plugin not available
    2013-12-13 08:36:22.811+00:00 Thread SDPAdapterTask: DiscoveryManager discovery      Problems in discovery cycle, no instances discovered
     

    Sorry about these logs - but any idea how to debug? Thanks


     

    This exception usually means you are tying to establish a non SSL connection with a VVCenter server that does not support it.

    Change the configuration to use SSL and make sure the SSL port is correct (default for SSL is 443 - 80 is for non SSL)

    There is no need to import the certificate as long as you set  the validateCertificates to false.

  • Richard_Hine
    Richard_Hine
    12 Posts

    Re: VMware discovery problem - missing plugin

    ‏2013-12-13T23:02:59Z  
    • Andreay
    • ‏2013-12-13T15:30:07Z

    This exception usually means you are tying to establish a non SSL connection with a VVCenter server that does not support it.

    Change the configuration to use SSL and make sure the SSL port is correct (default for SSL is 443 - 80 is for non SSL)

    There is no need to import the certificate as long as you set  the validateCertificates to false.

    Many thanks again. Looks like the VC appliance doesn't accept no SSL connections. Changed the AI connection configuration to VMware use use SSL, port 443, no validation and all is well.

    Thanks, Richard

  • steyiven
    steyiven
    3 Posts

    Re: VMware discovery problem - missing plugin

    ‏2014-03-10T06:38:44Z  

    This is the one of the more common problem with VMware. Verify that network connectivity exists between the Update Manager server and the vSphere Client in which you want to enable the plugin.

    windows dedicated server
     

  • borislavbaros
    borislavbaros
    3 Posts

    Re: VMware discovery problem - missing plugin

    ‏2014-09-02T08:48:27Z  

    This is a common issue. Try to uninstall the plug-in and then re-install.

    buy gaming keyboards
     

    Updated on 2014-09-02T08:49:08Z at 2014-09-02T08:49:08Z by borislavbaros