IC SunsetThe developerWorks Connections platform will be sunset on December 31, 2019. On January 1, 2020, this forum will no longer be available. More details available on our FAQ.
Topic
  • 1 reply
  • Latest Post - ‏2013-09-03T09:22:43Z by ReneBlath
Rüdiger Dahlke
Rüdiger Dahlke
121 Posts

Pinned topic another SLES11 SP3 question

‏2013-09-03T06:40:05Z |

we will soon migrate our linux environment to SLES11 FP3 with running SAMP V3.2.2.4 installations. Are there any compatibility problems?

Regards

Ruediger

  • ReneBlath
    ReneBlath
    4 Posts
    ACCEPTED ANSWER

    Re: another SLES11 SP3 question

    ‏2013-09-03T09:22:43Z  

    Hi Rüdiger,

    there is currently one PMR open because of SLES 11.3 regarding prereqSAM. It seems that when 2 versions of the libstdc++ library are installed, the prereq checker can not determine the correct one:

    libstdc++43-32bit
    libstdc++46-32bit

    We are working on a fix for this but until it is ready, we recommend installing SAMP with the option --noprereqcheck if the following problem occurs (installSAM.log):

    prereqSAM: Using default prerequisite checking on the following rpm package:  'libstdc++4.-32bit' 'x86_64'
    prereqSAM: Error: The rpm package is installed, but the following part was not found:  'libstdc++43-32bit-4.6.9-0.11.38.x86_64
    libstdc++46-32bit-4.6.9-0.11.38.x86_64' '/usr/lib/libstdc++.so.6'

    Regards
    René

  • ReneBlath
    ReneBlath
    4 Posts

    Re: another SLES11 SP3 question

    ‏2013-09-03T09:22:43Z  

    Hi Rüdiger,

    there is currently one PMR open because of SLES 11.3 regarding prereqSAM. It seems that when 2 versions of the libstdc++ library are installed, the prereq checker can not determine the correct one:

    libstdc++43-32bit
    libstdc++46-32bit

    We are working on a fix for this but until it is ready, we recommend installing SAMP with the option --noprereqcheck if the following problem occurs (installSAM.log):

    prereqSAM: Using default prerequisite checking on the following rpm package:  'libstdc++4.-32bit' 'x86_64'
    prereqSAM: Error: The rpm package is installed, but the following part was not found:  'libstdc++43-32bit-4.6.9-0.11.38.x86_64
    libstdc++46-32bit-4.6.9-0.11.38.x86_64' '/usr/lib/libstdc++.so.6'

    Regards
    René