IC5Notice: We have upgraded developerWorks Community to the latest version of IBM Connections. For more information, read our upgrade FAQ.
Topic
  • 2 replies
  • Latest Post - ‏2013-11-04T19:27:34Z by Senators
Senators
Senators
3 Posts

Pinned topic Query Studio Icons not appearing in Excel or PDF

‏2013-10-28T15:17:39Z |

Hi There

I am creating new installes for my Cognos 10.2.1 environment. VM's, Windows 2008 SP2. MS Office 2010

Multi server install - Gateway and App server.

When we take a QS report and export to Excel or PDF, the icons (filter, sort etc) do not appear. Red X's or Blanks appear in Excel. I have even tried loggin on the VM (Gateway server) to see if theyd appear

I Viewed the source in Internet Explorer and saw that the Filter.gif is in the ../qs/images directory.

I took the 'qs' folder from the Gateway server and copied it to the App server

The result: The icon appears!!

So it seems to me that if I copy over the whole .../webcontent form the Gateway to the Appserver, that this would work. However, I don't understand why the Appserver doesn't have what it needs.

Anyone run into this? Any thoughts, feedback to a more cleaner solution?

Thank you

  • Senators
    Senators
    3 Posts
    ACCEPTED ANSWER

    Re: Query Studio Icons not appearing in Excel or PDF

    ‏2013-11-04T19:27:34Z  
    • dshill
    • ‏2013-10-29T14:44:16Z

    This can happen in a multi-server environment if the URIs in Cognos Configuration are not correct.  Recommend you open a Service Request and attach all the Cognos\cmplst.txt and Cognos\configuration\cogstartup.xml files. 

    That's not it. Turns out it was a bug with Cognos 10 RTM. I installed the latest Fixpack and that did it!

     

    You also need to open anonymous access on certain folders. We applied it to the folders below, kept Windows Authentication on the rest.

     

    ps
    qs
    common
    cps4
    skins

  • dshill
    dshill
    27 Posts

    Re: Query Studio Icons not appearing in Excel or PDF

    ‏2013-10-29T14:44:16Z  

    This can happen in a multi-server environment if the URIs in Cognos Configuration are not correct.  Recommend you open a Service Request and attach all the Cognos\cmplst.txt and Cognos\configuration\cogstartup.xml files. 

  • Senators
    Senators
    3 Posts

    Re: Query Studio Icons not appearing in Excel or PDF

    ‏2013-11-04T19:27:34Z  
    • dshill
    • ‏2013-10-29T14:44:16Z

    This can happen in a multi-server environment if the URIs in Cognos Configuration are not correct.  Recommend you open a Service Request and attach all the Cognos\cmplst.txt and Cognos\configuration\cogstartup.xml files. 

    That's not it. Turns out it was a bug with Cognos 10 RTM. I installed the latest Fixpack and that did it!

     

    You also need to open anonymous access on certain folders. We applied it to the folders below, kept Windows Authentication on the rest.

     

    ps
    qs
    common
    cps4
    skins