Topic
  • 4 replies
  • Latest Post - ‏2013-09-10T06:52:08Z by Banibrata Patra
Banibrata Patra
Banibrata Patra
4 Posts

Pinned topic ODBCappend not working in distributed mode

‏2013-09-05T15:09:14Z |

Hi,

I am using infosphere streams v3.1. I tried to insert data from stream to a solidDB table. This program is working in standalone mode,however when I try to execute this in Distributed mode this does not work,neither it throws any error.

The program is a simple one,it just read values from a file and insert those in the table. Please suggest how to troubleshoot this problem.

Regards

Banibrata

  • Ivan_CA
    Ivan_CA
    10 Posts
    ACCEPTED ANSWER

    Re: ODBCappend not working in distributed mode

    ‏2013-09-05T15:48:56Z  

    Hi,

    Usually that indicates that you did not set the needed backDoorEvs properties for the instance. Can you try the command below (please change according to your environment), restart the streams instance and try again?

     

    streamtool setproperty -i streams@ivan --property DNA.backDoorEvs=SOLIDDIR=$SOLIDDIR,ODBCINI=$ODBCINI

     

    Also, try to run the app with config tracing : trace; and check the PE logs, that should provide some clues of that's missing/wrong.

     

    Thanks,

    Ivan

  • Ivan_CA
    Ivan_CA
    10 Posts

    Re: ODBCappend not working in distributed mode

    ‏2013-09-05T15:48:56Z  

    Hi,

    Usually that indicates that you did not set the needed backDoorEvs properties for the instance. Can you try the command below (please change according to your environment), restart the streams instance and try again?

     

    streamtool setproperty -i streams@ivan --property DNA.backDoorEvs=SOLIDDIR=$SOLIDDIR,ODBCINI=$ODBCINI

     

    Also, try to run the app with config tracing : trace; and check the PE logs, that should provide some clues of that's missing/wrong.

     

    Thanks,

    Ivan

  • Banibrata Patra
    Banibrata Patra
    4 Posts

    Re: ODBCappend not working in distributed mode

    ‏2013-09-09T04:38:29Z  
    • Ivan_CA
    • ‏2013-09-05T15:48:56Z

    Hi,

    Usually that indicates that you did not set the needed backDoorEvs properties for the instance. Can you try the command below (please change according to your environment), restart the streams instance and try again?

     

    streamtool setproperty -i streams@ivan --property DNA.backDoorEvs=SOLIDDIR=$SOLIDDIR,ODBCINI=$ODBCINI

     

    Also, try to run the app with config tracing : trace; and check the PE logs, that should provide some clues of that's missing/wrong.

     

    Thanks,

    Ivan

    Hello Ivan,

     

    Thanks a lot for your suggestion. I have tried the cmmand you mentioned and it workd perfectly.

    If you get some time can you please share a couple of lines about the significance of this bacDoorEvs property.

    Thanks for your sggestion again.

  • Ivan_CA
    Ivan_CA
    10 Posts

    Re: ODBCappend not working in distributed mode

    ‏2013-09-09T12:13:36Z  

    Hello Ivan,

     

    Thanks a lot for your suggestion. I have tried the cmmand you mentioned and it workd perfectly.

    If you get some time can you please share a couple of lines about the significance of this bacDoorEvs property.

    Thanks for your sggestion again.

    Hi Banibatra,

    Glad it's working now.

    Please check out the redbook Addressing Data Volume, Velocity, and Variety with IBM InfoSphere Streams V3.0 (http://www.redbooks.ibm.com/abstracts/sg248108.html) , there are more detailed explanation about this step of the configuration and others.

    Thanks,
    Ivan

  • Banibrata Patra
    Banibrata Patra
    4 Posts

    Re: ODBCappend not working in distributed mode

    ‏2013-09-10T06:52:08Z  
    • Ivan_CA
    • ‏2013-09-09T12:13:36Z

    Hi Banibatra,

    Glad it's working now.

    Please check out the redbook Addressing Data Volume, Velocity, and Variety with IBM InfoSphere Streams V3.0 (http://www.redbooks.ibm.com/abstracts/sg248108.html) , there are more detailed explanation about this step of the configuration and others.

    Thanks,
    Ivan

    Thanks Ivan!!!!