Topic
  • 2 replies
  • Latest Post - ‏2015-01-05T14:24:21Z by ilangairajan
HWoerner
HWoerner
2 Posts

Pinned topic PTT Exception when retrieving Tuning Parameters

‏2013-05-24T15:32:18Z |

Hi, I am using PTT 2.2.0.00 bundled in ISA 4.1 workbench and I successfully connected the tool to a running Deployment Manager WAS 8.5.0.01 on z/OS. So far a lot of functions work - but whenever I try to retrieve the 'Tuning Parameters' of a server I get the following exception in the Console and no results:

java.lang.NullPointerException
    at com.ibm.websphere.management.configservice.ConfigServiceHelper.getAttributeValue(ConfigServiceHelper.java:68)
    at com.ibm.perf.data.collector.DataCollector.retrieveServerCfgInfo(DataCollector.java:611)
    at com.ibm.perf.ui.handlers.RetrieveServerConfigHandler$1.run(RetrieveServerConfigHandler.java:48)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

On the network monitor I can see that actual data is being transferred to my workstation, seems the client is unable to parse it?

It would be great if the tool could be fixed to make this work. Of course, if you need more information I am happy to help.

Best regards!

  • JPA8300
    JPA8300
    1 Post

    Re: PTT Exception when retrieving Tuning Parameters

    ‏2014-04-01T13:58:30Z  

    I have the same problem. There is no solution to it yet?!!!

  • ilangairajan
    ilangairajan
    1 Post

    Re: PTT Exception when retrieving Tuning Parameters

    ‏2015-01-05T14:24:21Z  

    Is this still a pending issue ? I have the same problem with ISA 4.1 , PTT 2.2.0.20120510 and WAS on zOS.