Topic
  • 3 replies
  • Latest Post - ‏2014-05-06T09:25:54Z by adesso
adesso
adesso
38 Posts

Pinned topic EGL V9 on iseries

‏2014-05-02T13:20:11Z |

Hello,

we plan to migrate to EGL V9. I think we have to upgrade the QEGL-Library on Iseries  with the savfile

that is shipped with EGL V9. Is it necessary to re-compile all of the programs with this new QEGL-Libirary?

Thank you in advance.

Reinhold

  • TuukkaIlomäki
    TuukkaIlomäki
    80 Posts
    ACCEPTED ANSWER

    Re: EGL V9 on iseries

    ‏2014-05-02T13:33:15Z  

    You must upgrade QEGL library on iSeries since EGL V9 runtime contains a new required runtime module named VGNCOIB.

    AFAIK, it is not necessary to re-compile existing programs - at least we did not do that and we have thousands of EGL programs from RBD 7.5 and RAD 6 running smoothly on our iSeries.

  • Jeff.Douglas
    Jeff.Douglas
    243 Posts
    ACCEPTED ANSWER

    Re: EGL V9 on iseries

    ‏2014-05-05T12:26:24Z  

    You must upgrade QEGL library on iSeries since EGL V9 runtime contains a new required runtime module named VGNCOIB.

    AFAIK, it is not necessary to re-compile existing programs - at least we did not do that and we have thousands of EGL programs from RBD 7.5 and RAD 6 running smoothly on our iSeries.

    That is correct. You will never have to regenerate your programs that are running because of an upgrade. We always make our generated code and the use of the runtime code back-release compliant. Your previous version generated programs will work with higher release programs.

  • TuukkaIlomäki
    TuukkaIlomäki
    80 Posts

    Re: EGL V9 on iseries

    ‏2014-05-02T13:33:15Z  

    You must upgrade QEGL library on iSeries since EGL V9 runtime contains a new required runtime module named VGNCOIB.

    AFAIK, it is not necessary to re-compile existing programs - at least we did not do that and we have thousands of EGL programs from RBD 7.5 and RAD 6 running smoothly on our iSeries.

  • Jeff.Douglas
    Jeff.Douglas
    243 Posts

    Re: EGL V9 on iseries

    ‏2014-05-05T12:26:24Z  

    You must upgrade QEGL library on iSeries since EGL V9 runtime contains a new required runtime module named VGNCOIB.

    AFAIK, it is not necessary to re-compile existing programs - at least we did not do that and we have thousands of EGL programs from RBD 7.5 and RAD 6 running smoothly on our iSeries.

    That is correct. You will never have to regenerate your programs that are running because of an upgrade. We always make our generated code and the use of the runtime code back-release compliant. Your previous version generated programs will work with higher release programs.

  • adesso
    adesso
    38 Posts

    Re: EGL V9 on iseries

    ‏2014-05-06T09:25:54Z  

    Thank you for answering my question.