Topic
  • 5 replies
  • Latest Post - ‏2013-06-07T08:30:52Z by shanz9903
myrmidon
myrmidon
23 Posts

Pinned topic Build error

‏2013-05-30T15:49:15Z |

Hello,

I downloaded the evaluation version of Rhapsody 8.

I am on Windows XP, I have installed Visual Studio 2008 C++ Express and MingW.

I have added all Path variables ( C:\Program Files\Microsoft Visual Studio 9.0\VC\bin\;C:\Program Files\Microsoft SDKs\Windows\v6.0A\bin\;C:\MinGW\bin\)

I installed Rhapsody (after having all the above ) and started a new project

The problems are:

1) In Components>Default Components>DefaultConfig>(right click)Features>Settings>Environment

I do not have a MingW choice. Do you know why?

2) I choose "MSVC" but when I try to do a Full Build I get the following

##########################################################

Building ------------  DefaultComponent.exe   ------------
Executing: ""C:\Program Files\IBM\Rational\Rhapsody\8.0\Share"\etc\msvcmake.bat DefaultComponent.mak rebuild x86 VC10 "
Le chemin d'accŠs sp'cifi' est introuvable.
Cleanup
NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio 9.0\VC\bin\cl.EXE"' : code retour '0xc0000135'
Stop.
Build Done

##########################################################

Thanks in advance for your time.

Kind regards,

Christos

 

  • shanz9903
    shanz9903
    273 Posts
    ACCEPTED ANSWER

    Re: Build error

    ‏2013-05-31T09:39:57Z  

    I think Rhapsody 8 uses MSVC for both VC9 and VC10 (ie: Visual Studio 2008 and Visual Studio 2010).

    Your screenshot shows VC10 being used whereas you probably want to use VC9.

    I haven't got Rhapsody 8 installed but there is a new setting somewhere to choose between msvc VC9 and VC10.

    *HERE IT IS*

    http://www-01.ibm.com/support/docview.wss?uid=swg27024158

    Using Rational Rhapsody with Microsoft Visual Studio 2008 and Microsoft Visual Studio 2010

    Beginning in version 8.0, Rational Rhapsody uses a single environment called MSVC for projects that use Microsoft Visual Studio 2008 and projects that use Microsoft Visual Studio 2010.

    To indicate which version of Visual Studio you are using, you must use the MSVC::IDEVersion property.

    The value of this property is passed as a parameter to the Build Framework command, and to the command that is used to build your application. The value of the property is also used in properties that affect the content of the generated makefile.

    The default value of the MSVC::IDEVersion property is VC10:

    • If you are using Visual Studio 2010, you do not have to modify the value of the property.
    • If you are using Visual Studio 2008, you must change the value of the property to VC9.

    Not sure if MinGW is supported. http://www-01.ibm.com/support/docview.wss?uid=swg21454505

     

    Updated on 2013-05-31T09:46:18Z at 2013-05-31T09:46:18Z by shanz9903
  • shanz9903
    shanz9903
    273 Posts
    ACCEPTED ANSWER

    Re: Build error

    ‏2013-05-31T14:48:29Z  
    • myrmidon
    • ‏2013-05-31T13:56:39Z

    Thanks for the quick answer!

    --> "The value of this property is passed as a parameter to the Build Framework command, and to the command that is used to build your application. The value of the property is also used in properties that affect the content of the generated makefile."

    I understand what you mean but I do not know where I can change the Value of MSVC::IDEVersion property from VC10 to VC09 (as I use Visual Studio 2008) (sorry I am new.. :S)

    -->"Not sure if MinGW is supported. http://www-01.ibm.com/support/docview.wss?uid=swg21454505"

    I tried that.

    Firstly, MingW appeared in the environment (but yet I cannot build with it).

    Secondly and most important, many Environment variables (like MSVC! ) disappeared! However some other options appered like "INTEGRITY", "INTEGRITY5".. (?)

    I uninstalled and re installed Rhapsody but there are left the same (please check the photo I enclose). Do you know how I can re add MSVC option in the Environment?

    Thanks again for your time!

    The MinGW Share.zip supports Rhapsody 7.5.1.1, 7.5.2, 7.5.2.1.

    You need to modify the siteC++.prp file and specifically the line

    Property Environment Enum "MinGW,

    You only want to add MinGW to the list that is in the Rhapsody 8 version of siteC++.prp.  Don't add INTEGRITY etc or delete any either.

    MSVC should be left alone.

    That should fix it.

  • shanz9903
    shanz9903
    273 Posts

    Re: Build error

    ‏2013-05-31T09:39:57Z  

    I think Rhapsody 8 uses MSVC for both VC9 and VC10 (ie: Visual Studio 2008 and Visual Studio 2010).

    Your screenshot shows VC10 being used whereas you probably want to use VC9.

    I haven't got Rhapsody 8 installed but there is a new setting somewhere to choose between msvc VC9 and VC10.

    *HERE IT IS*

    http://www-01.ibm.com/support/docview.wss?uid=swg27024158

    Using Rational Rhapsody with Microsoft Visual Studio 2008 and Microsoft Visual Studio 2010

    Beginning in version 8.0, Rational Rhapsody uses a single environment called MSVC for projects that use Microsoft Visual Studio 2008 and projects that use Microsoft Visual Studio 2010.

    To indicate which version of Visual Studio you are using, you must use the MSVC::IDEVersion property.

    The value of this property is passed as a parameter to the Build Framework command, and to the command that is used to build your application. The value of the property is also used in properties that affect the content of the generated makefile.

    The default value of the MSVC::IDEVersion property is VC10:

    • If you are using Visual Studio 2010, you do not have to modify the value of the property.
    • If you are using Visual Studio 2008, you must change the value of the property to VC9.

    Not sure if MinGW is supported. http://www-01.ibm.com/support/docview.wss?uid=swg21454505

     

    Updated on 2013-05-31T09:46:18Z at 2013-05-31T09:46:18Z by shanz9903
  • myrmidon
    myrmidon
    23 Posts

    Re: Build error

    ‏2013-05-31T13:56:39Z  
    • shanz9903
    • ‏2013-05-31T09:39:57Z

    I think Rhapsody 8 uses MSVC for both VC9 and VC10 (ie: Visual Studio 2008 and Visual Studio 2010).

    Your screenshot shows VC10 being used whereas you probably want to use VC9.

    I haven't got Rhapsody 8 installed but there is a new setting somewhere to choose between msvc VC9 and VC10.

    *HERE IT IS*

    http://www-01.ibm.com/support/docview.wss?uid=swg27024158

    Using Rational Rhapsody with Microsoft Visual Studio 2008 and Microsoft Visual Studio 2010

    Beginning in version 8.0, Rational Rhapsody uses a single environment called MSVC for projects that use Microsoft Visual Studio 2008 and projects that use Microsoft Visual Studio 2010.

    To indicate which version of Visual Studio you are using, you must use the MSVC::IDEVersion property.

    The value of this property is passed as a parameter to the Build Framework command, and to the command that is used to build your application. The value of the property is also used in properties that affect the content of the generated makefile.

    The default value of the MSVC::IDEVersion property is VC10:

    • If you are using Visual Studio 2010, you do not have to modify the value of the property.
    • If you are using Visual Studio 2008, you must change the value of the property to VC9.

    Not sure if MinGW is supported. http://www-01.ibm.com/support/docview.wss?uid=swg21454505

     

    Thanks for the quick answer!

    --> "The value of this property is passed as a parameter to the Build Framework command, and to the command that is used to build your application. The value of the property is also used in properties that affect the content of the generated makefile."

    I understand what you mean but I do not know where I can change the Value of MSVC::IDEVersion property from VC10 to VC09 (as I use Visual Studio 2008) (sorry I am new.. :S)

    -->"Not sure if MinGW is supported. http://www-01.ibm.com/support/docview.wss?uid=swg21454505"

    I tried that.

    Firstly, MingW appeared in the environment (but yet I cannot build with it).

    Secondly and most important, many Environment variables (like MSVC! ) disappeared! However some other options appered like "INTEGRITY", "INTEGRITY5".. (?)

    I uninstalled and re installed Rhapsody but there are left the same (please check the photo I enclose). Do you know how I can re add MSVC option in the Environment?

    Thanks again for your time!

    Attachments

    Updated on 2013-05-31T14:03:32Z at 2013-05-31T14:03:32Z by myrmidon
  • shanz9903
    shanz9903
    273 Posts

    Re: Build error

    ‏2013-05-31T14:48:29Z  
    • myrmidon
    • ‏2013-05-31T13:56:39Z

    Thanks for the quick answer!

    --> "The value of this property is passed as a parameter to the Build Framework command, and to the command that is used to build your application. The value of the property is also used in properties that affect the content of the generated makefile."

    I understand what you mean but I do not know where I can change the Value of MSVC::IDEVersion property from VC10 to VC09 (as I use Visual Studio 2008) (sorry I am new.. :S)

    -->"Not sure if MinGW is supported. http://www-01.ibm.com/support/docview.wss?uid=swg21454505"

    I tried that.

    Firstly, MingW appeared in the environment (but yet I cannot build with it).

    Secondly and most important, many Environment variables (like MSVC! ) disappeared! However some other options appered like "INTEGRITY", "INTEGRITY5".. (?)

    I uninstalled and re installed Rhapsody but there are left the same (please check the photo I enclose). Do you know how I can re add MSVC option in the Environment?

    Thanks again for your time!

    The MinGW Share.zip supports Rhapsody 7.5.1.1, 7.5.2, 7.5.2.1.

    You need to modify the siteC++.prp file and specifically the line

    Property Environment Enum "MinGW,

    You only want to add MinGW to the list that is in the Rhapsody 8 version of siteC++.prp.  Don't add INTEGRITY etc or delete any either.

    MSVC should be left alone.

    That should fix it.

  • myrmidon
    myrmidon
    23 Posts

    Re: Build error

    ‏2013-06-06T23:53:41Z  
    • shanz9903
    • ‏2013-05-31T09:39:57Z

    I think Rhapsody 8 uses MSVC for both VC9 and VC10 (ie: Visual Studio 2008 and Visual Studio 2010).

    Your screenshot shows VC10 being used whereas you probably want to use VC9.

    I haven't got Rhapsody 8 installed but there is a new setting somewhere to choose between msvc VC9 and VC10.

    *HERE IT IS*

    http://www-01.ibm.com/support/docview.wss?uid=swg27024158

    Using Rational Rhapsody with Microsoft Visual Studio 2008 and Microsoft Visual Studio 2010

    Beginning in version 8.0, Rational Rhapsody uses a single environment called MSVC for projects that use Microsoft Visual Studio 2008 and projects that use Microsoft Visual Studio 2010.

    To indicate which version of Visual Studio you are using, you must use the MSVC::IDEVersion property.

    The value of this property is passed as a parameter to the Build Framework command, and to the command that is used to build your application. The value of the property is also used in properties that affect the content of the generated makefile.

    The default value of the MSVC::IDEVersion property is VC10:

    • If you are using Visual Studio 2010, you do not have to modify the value of the property.
    • If you are using Visual Studio 2008, you must change the value of the property to VC9.

    Not sure if MinGW is supported. http://www-01.ibm.com/support/docview.wss?uid=swg21454505

     

    I found where to change the version of visual studio:

    "go to the Configurations>Properties tab and set the value of the CPP_CG::MSVC::IDEVersion property to reflect the version of MS Visual Studio you are using, 2008 or 2010. For 2008, select the value VC9. For 2010, select the value VC10."

    As for the MinGW, I do not use these versions of Rhapsody so I could not check.

    Thanks a lot!

  • shanz9903
    shanz9903
    273 Posts

    Re: Build error

    ‏2013-06-07T08:30:52Z  
    • myrmidon
    • ‏2013-06-06T23:53:41Z

    I found where to change the version of visual studio:

    "go to the Configurations>Properties tab and set the value of the CPP_CG::MSVC::IDEVersion property to reflect the version of MS Visual Studio you are using, 2008 or 2010. For 2008, select the value VC9. For 2010, select the value VC10."

    As for the MinGW, I do not use these versions of Rhapsody so I could not check.

    Thanks a lot!

    Glad you're sorted.

    The MinGW should work in Rhapsody 7.6 and 8 too I reckon - it should just be a matter of merging the Rhapsody siteC++.prp with the MinGW Share.zip version.