Topic
  • 5 replies
  • Latest Post - ‏2015-09-08T12:22:32Z by VladYer
AM@15
AM@15
20 Posts

Pinned topic If Rhapsody 8.0.3 supports visual studio express edition and sdk 7.1

‏2013-12-07T06:37:55Z |

If Rational Rhapsody for software architect (version 8.0.3) supports visual studio express edition and SDK 7.1??

If yes, then please let me know the details of how .to integrate this compiler in Rhapsody 8.0.3.

Updated on 2013-12-07T06:39:49Z at 2013-12-07T06:39:49Z by AM@15
  • Yevo
    Yevo
    280 Posts

    Re: If Rhapsody 8.0.3 supports visual studio express edition and sdk 7.1

    ‏2013-12-08T08:43:17Z  

    As I have already mentioned Rhapsody doesn't officially support VS Express edition. It means IBM never tested this configuration. But I'm pretty sure you can use it if you set appropriate path to VS Express home directory during Rhapsody installation. Rhapsody 8.0.3 officially supports VS 2008 and VS2010. You can use any of them to run VS Express compiler. If you didn't set the path to VS Express home directory (e.g. C:\Program Files (x86)\Microsoft Visual Studio 9.0) during Rhapsody installation, you can fix this problem modifying Share\etc\msvcmake.bat file (line 7 or 8), which should contain something like that:

    if "%4"=="VC9" set VS_PATH=C:\Program Files (x86)\Microsoft Visual Studio 9.0\
    if "%4"=="VC10" set VS_PATH=C:\Program Files (x86)\Microsoft Visual Studio 10.0\
     

    If you need also use VS - Rhapsody workflow integration addins, you can go to VS Tools->Options->Add-in/Macros Security dialog (if it is possible in VS Express - I have no idea) and add the following path:

    <Rhapsody binary directory>\VisualStudio\VisualStudio2008

    or

    <Rhapsody binary directory>\VisualStudio\VisualStudio2010

  • AM@15
    AM@15
    20 Posts

    Re: If Rhapsody 8.0.3 supports visual studio express edition and sdk 7.1

    ‏2013-12-08T13:43:56Z  
    • Yevo
    • ‏2013-12-08T08:43:17Z

    As I have already mentioned Rhapsody doesn't officially support VS Express edition. It means IBM never tested this configuration. But I'm pretty sure you can use it if you set appropriate path to VS Express home directory during Rhapsody installation. Rhapsody 8.0.3 officially supports VS 2008 and VS2010. You can use any of them to run VS Express compiler. If you didn't set the path to VS Express home directory (e.g. C:\Program Files (x86)\Microsoft Visual Studio 9.0) during Rhapsody installation, you can fix this problem modifying Share\etc\msvcmake.bat file (line 7 or 8), which should contain something like that:

    if "%4"=="VC9" set VS_PATH=C:\Program Files (x86)\Microsoft Visual Studio 9.0\
    if "%4"=="VC10" set VS_PATH=C:\Program Files (x86)\Microsoft Visual Studio 10.0\
     

    If you need also use VS - Rhapsody workflow integration addins, you can go to VS Tools->Options->Add-in/Macros Security dialog (if it is possible in VS Express - I have no idea) and add the following path:

    <Rhapsody binary directory>\VisualStudio\VisualStudio2008

    or

    <Rhapsody binary directory>\VisualStudio\VisualStudio2010

    Thanks a lot Yevo for your reply.Important information that you have provided is really very helpful to me.

  • milankrf
    milankrf
    3 Posts

    Re: If Rhapsody 8.0.3 supports visual studio express edition and sdk 7.1

    ‏2015-07-24T06:50:56Z  

    I am new to this and getting error message current value is "VC10", but no visual studio found in directory/

    I am attaching the screen shot of this.

  • mahendramengade
    mahendramengade
    2 Posts

    Re: If Rhapsody 8.0.3 supports visual studio express edition and sdk 7.1

    ‏2015-09-07T12:20:27Z  
    • milankrf
    • ‏2015-07-24T06:50:56Z

    I am new to this and getting error message current value is "VC10", but no visual studio found in directory/

    I am attaching the screen shot of this.

    Yes.. I too getting the same error. I have VS express 2012 desktop edition.  I tried changing all relevant files but no success.

    do  I need to change the VS version or is there something we can find in VS express integration with Rhapsody 8.1

     

  • VladYer
    VladYer
    30 Posts

    Re: If Rhapsody 8.0.3 supports visual studio express edition and sdk 7.1

    ‏2015-09-08T12:22:32Z  

    Yes.. I too getting the same error. I have VS express 2012 desktop edition.  I tried changing all relevant files but no success.

    do  I need to change the VS version or is there something we can find in VS express integration with Rhapsody 8.1

     

    This error means you didn't give any path to your VS installation during Rhapsody installation. To fix it

    open msvcmake.bat file in your installed Rhapsody tree (C:\Program Files (x86)\IBM\RHapsody\8.1.3\Share\etc directory)

    and modify VS_PATH variable settings according to your VS installation. See my answer above (Dec 8, 2013) for more information.