Topic
  • 2 replies
  • Latest Post - ‏2013-06-19T19:28:27Z by Liv2luv
Karthiks
Karthiks
1 Post

Pinned topic DataPower appliance does not route MQ message

‏2013-06-19T01:17:13Z |

I have technotes which says DataPower appliance does not route MQ message in error rule after firmware upgrade

http://www-01.ibm.com/support/docview.wss?uid=swg21606311

we are facing below issue and we would like to know  this issue is related to technotes or not?
we are facing issue while using "Multi-Way Results".  Below is the Results xml which we passed to Results action for multi-way results. Result action is able to send two messages to backend Q, but it is not reading the context from input="abc" or input="xyz" rather its taking the message from the context (INPUT) set in the result action.

<results mode="require-all" multiple-outputs="true">
    <url input="abc">dpmq://CQM_MQQM/?

RequestQueue=CFT.QALIAS.MCTS. INQUIRE.CONS.RQST;ReplyQueue= CFT.QALIAS.MCTS.CONS.RESP; SetReplyTo=true</url>
    <url input="xyz">dpmq://CQM_MQQM/? RequestQueue=CFT.QALIAS.MCTS. INQUIRE.CONS.RQST;ReplyQueue= CFT.QALIAS.MCTS.CONS.RESP; SetReplyTo=true</url>
</results>

Thanks & Regards,

 

Karthi

  • kenhygh
    kenhygh
    2032 Posts

    Re: DataPower appliance does not route MQ message

    ‏2013-06-19T10:39:23Z  

    Karthi,

    Unless Hermann chimes in here, your best bet might be to open a PMR with IBM.

  • Liv2luv
    Liv2luv
    573 Posts

    Re: DataPower appliance does not route MQ message

    ‏2013-06-19T19:28:27Z  

    Hi Karthik, are you using dp:encrypt-data and/or dp:decrypt-data anywhere in the code preceding route action ?