Topic
8 replies Latest Post - ‏2013-07-18T20:02:40Z by dirkdigs
dirkdigs
dirkdigs
51 Posts
ACCEPTED ANSWER

Pinned topic remote copy

‏2013-07-16T15:39:41Z |

i am using remote copy to copy a 16TB volume from one v7000 to another

the goal is to blow up the master after the copy is completed and re-create the arrays etc ,

will my target volume copy be read-only or will I be able to map it to a host and use it as I was before?

 

Also is there any CLI command to show the speed the remote copy is working at? the gui is pretty useless.

Updated on 2013-07-16T15:43:47Z at 2013-07-16T15:43:47Z by dirkdigs
  • dirkdigs
    dirkdigs
    51 Posts
    ACCEPTED ANSWER

    Re: remote copy

    ‏2013-07-16T18:13:48Z  in response to dirkdigs

    should i be doing a flash copy or remote copy? (metro mirror)

    both v7000 are local right now and connected thru fiber channel switch. seems remote is going to take a super long time.

    volume is 16.4 TB

    • AndersLorensen
      AndersLorensen
      139 Posts
      ACCEPTED ANSWER

      Re: remote copy

      ‏2013-07-16T21:23:07Z  in response to dirkdigs

      Make sure the Mirror sync rate is set to 100. The default is 50.

      (Properties on the volume, Overview tab, make sure the Show Details are checked, then click Edit to change it.)

      50 = 2 MB/s

      100 = 64 MB/s (which is max)

       

      You should be doing remote copy if its between 2 different v7000's thats not in a cluster together.

       

      As for seeing the speed, I dont think there is a CLI command for that.

      If you are running the newest firmware 7.1.0.1, you can dedicate a fiber port for it, and then watch the speed on the FC switch. I bet thats the easiest way.

       

      --

      Anders

      • chriscanto
        chriscanto
        229 Posts
        ACCEPTED ANSWER

        Re: remote copy

        ‏2013-07-17T08:20:37Z  in response to AndersLorensen

        The 'mirror sync rate' that Anders mentions applies to mirrored volumes only, i.e. volumes with 2 copies.  It doesn't affect the rate of replication.

        The two settings that affect the replication rate are:

        1. Inter-cluster background copy bandwidth.   This is set using:

        chpartnership -bandwidth <bandwidth_in_MBps> <remote_cluster_id/name>

        This bandwidth is used to cap the background remote copy progress (i.e. the initial sync). Set the bandwidth to the maximum rate that the remote copies should resynchronize at. Write operations from the host add to the use of the system link, so if you are still performing host write I/O to the master volume then make sure you leave enough capacity on the link to contain that too.

        The current setting can be seen with the 'lspartnership' CLI.

        I believe this property can also be viewed and changed using the GUI.

        2. The individual 'relationship_bandwidth_limit', as seen in the 'lssystem' CLI.  This value can be changed using

        chsystem -relationshipbandwidthlimit bandwidth_in_MBps

        This specifies the new background copy bandwidth in megabytes per second, from 1 - 1000. The default is 25 MBps. This parameter operates system-wide and defines the maximum background copy bandwidth that any relationship can adopt. The existing background copy bandwidth settings defined on a partnership continue to operate, with the lower of the partnership and volume rates attempted.

        This setting can only be configured using the CLI.

         

        Hopefully that helps.

        • dirkdigs
          dirkdigs
          51 Posts
          ACCEPTED ANSWER

          Re: remote copy

          ‏2013-07-18T15:45:36Z  in response to chriscanto

          my 16.4 TB copy is at 34% after almost 48 hours. 

           

          Are the following correct in order to use max bandwidth?

          chpartnership -bandwidth 100

          chsystem -relationshipbandwidthlimit 1000

          and to confirm, my two v7000 units are connected with fiber channel switch.

          and I am running a metro mirror.

           

          Updated on 2013-07-18T15:47:17Z at 2013-07-18T15:47:17Z by dirkdigs
          • chriscanto
            chriscanto
            229 Posts
            ACCEPTED ANSWER

            Re: remote copy

            ‏2013-07-18T15:57:34Z  in response to dirkdigs

            The chpartnership CLI requires you to specify which partnership you are configuring, so you need to add the name of the remote system onto the end of that command example.

            Both commands take the rate in units of MBps, so if you specify 100 for the per partnership bandwidth and then 1000 for the per relationship bandwidth then it'll run at the lower of the two rates.   I imagine you really wanted to specify the same on both, in this situation.

            You can refer to the CLI help in the product for further info on the commands and their syntax.

            • dirkdigs
              dirkdigs
              51 Posts
              ACCEPTED ANSWER

              Re: remote copy

              ‏2013-07-18T16:04:34Z  in response to chriscanto

              OK so I need to set  1000 for both? Also would the metro mirror need to be restarted or will these changes take effect on the fly?

              Updated on 2013-07-18T16:28:49Z at 2013-07-18T16:28:49Z by dirkdigs
              • chriscanto
                chriscanto
                229 Posts
                ACCEPTED ANSWER

                Re: remote copy

                ‏2013-07-18T16:47:11Z  in response to dirkdigs

                Yep, if you think you have enough resources to sustain that rate.   You need to consider:

                * read bandwidth from source volume(s)

                * link bandwidth

                * write bandwidth to target volume(s)

                 

                • dirkdigs
                  dirkdigs
                  51 Posts
                  ACCEPTED ANSWER

                  Re: remote copy

                  ‏2013-07-18T20:02:40Z  in response to chriscanto

                  done. everything is now set to 1000 MB/s. we will see if the speed picks up.