Topic
  • 2 replies
  • Latest Post - ‏2016-03-07T16:27:54Z by RajMun
WitoldZieliński
WitoldZieliński
1 Post

Pinned topic Business Monitor Development Toolkit 8.0.1 code generation error

‏2014-01-13T11:14:10Z |

Hi,

Every time I try to generate Java EE code for Business Monitor Model in WBM Dev Toolkit v8.0.1 (RAD 8.0.4) I get an exception:
java.lang.NullPointerException
  java.lang.NullPointerException
 at org.eclipse.jst.j2ee.project.facet.J2EEModuleFacetInstallDataModelProvider.hasValidRuntime(Unknown Source)
 at org.eclipse.jst.j2ee.project.facet.J2EEModuleFacetInstallDataModelProvider.getDefaultProperty(Unknown Source)
 at org.eclipse.jst.j2ee.internal.ejb.project.operations.EjbFacetInstallDataModelProvider.getDefaultProperty(Unknown Source)
 at org.eclipse.wst.common.frameworks.internal.datamodel.DataModelImpl.getProperty(Unknown Source)
 at org.eclipse.wst.common.frameworks.internal.datamodel.DataModelImpl.getStringProperty(Unknown Source)
 at org.eclipse.jst.j2ee.project.facet.J2EEModuleFacetInstallDataModelProvider.propertySet(Unknown Source)
 at org.eclipse.jst.j2ee.internal.ejb.project.operations.EjbFacetInstallDataModelProvider.propertySet(Unknown Source)
 at org.eclipse.wst.common.frameworks.internal.datamodel.DataModelImpl.internalSetProperty(Unknown Source)
 at org.eclipse.wst.common.frameworks.internal.datamodel.DataModelImpl.setProperty(Unknown Source)
 at org.eclipse.wst.common.frameworks.internal.datamodel.DataModelImpl.setBooleanProperty(Unknown Source)
 at com.ibm.wbimonitor.deploy.base.EarProjectGenerator.createEJB(Unknown Source)
 at com.ibm.wbimonitor.deploy.base.EarProjectGenerator.run(Unknown Source)
 at com.ibm.wbimonitor.deploy.editor.wizard.GenerateWizard$GenerateJob.runInWorkspace(Unknown Source)
 at org.eclipse.core.internal.resources.InternalWorkspaceJob.run(Unknown Source)
 at org.eclipse.core.internal.jobs.Worker.run(Unknown Source)

 any idea?

 

Updated on 2014-01-13T11:14:47Z at 2014-01-13T11:14:47Z by WitoldZieliński
  • 1GSA_Javier_Ordax
    1GSA_Javier_Ordax
    1 Post

    Re: Business Monitor Development Toolkit 8.0.1 code generation error

    ‏2016-02-05T22:28:34Z  

    Hi.

     

    Old post, but just in case someone with similar inssue, in my case it was using IBM Integration Designer 8.5.6.

     

    In my case the issue was because I didn't install monitor as test environment in the IDE. So I uninstalled Integration Desginer and the test environment and installed it again but this time creating the test environment for Process Server and Business Monitor.

     

    Then I could create the monitor model projects.

     

  • RajMun
    RajMun
    1 Post

    Re: Business Monitor Development Toolkit 8.0.1 code generation error

    ‏2016-03-07T16:27:54Z  

    I am also facing this issue. Changing workspace seems to have it fixed. Not very happy though :(