Topic
4 replies Latest Post - ‏2013-10-08T20:21:08Z by Ronn78
Ronn78
Ronn78
4 Posts
ACCEPTED ANSWER

Pinned topic SLM action issues

‏2013-09-11T15:38:01Z |

Hi all,

I am new in Data Power, created a SLM action in Multi Protocol Gateway to limit the outgoing request. I set input as a PIPE and output as OUTPUT. When I run the work flow it's creating the SLM  statement configuration xml  and sending it to web service instead of actual request. Am I missing anything here? Please help? Thanks 

Ronnie

  • kenhygh
    kenhygh
    873 Posts
    ACCEPTED ANSWER

    Re: SLM action issues

    ‏2013-09-11T17:37:23Z  in response to Ronn78

    Ronnie,

    input should probably be whatever your message content context is.

    I usually set output to NULL, and have a Results action with input of the message content.

    • Ronn78
      Ronn78
      4 Posts
      ACCEPTED ANSWER

      Re: SLM action issues

      ‏2013-09-11T19:15:03Z  in response to kenhygh

      Thank you for your reply. I have WTX map(dpa file) in the WF.I tired using the INPUT but SLM action node didn't like it may be because my source is not XML format,  I am going to try your suggested method and let you know. 

      • SriniDp
        SriniDp
        44 Posts
        ACCEPTED ANSWER

        Re: SLM action issues

        ‏2013-09-13T19:50:12Z  in response to Ronn78

        Thats the right behaviour it is doing. It is sending the result of SLM action to backend server. SLM Action doesnt need to process the request message and send the result of it to backend server.

        So,

         

        Make the INPUT and OUTPUT context of SLM to NULL.

        Updated on 2013-09-13T19:50:37Z at 2013-09-13T19:50:37Z by SriniDp
        • Ronn78
          Ronn78
          4 Posts
          ACCEPTED ANSWER

          Re: SLM action issues

          ‏2013-10-08T20:21:08Z  in response to SriniDp

          Thank you for your help. It worked.