Topic
  • 8 replies
  • Latest Post - ‏2013-11-25T14:16:00Z by OFWHMG
OFWHMG
OFWHMG
36 Posts

Pinned topic Disappearing MQ Explorer Perspective

‏2013-11-12T12:41:44Z |

I had to re install the MQ Explorer into my zOS V2.1 Explorer (I uninstalled it then re installed it) and now I do not see it when I do a Window>Show perspective>other.  Is there some configuration file that has been corrupted?  See the attached snapshots. 

Thank you.

 

  • DaveN
    DaveN
    80 Posts

    Re: Disappearing MQ Explorer Perspective

    ‏2013-11-12T12:55:58Z  

    Hi,

    Did you look at the Features and Plug-ins tab? If the MQ Explorer features and plug-ins show in that then I'm a bit stumped.

    If they don't show then you could use the OSGi console to view which plug-ins are available in the system and try and start them.

    However we're deep into Eclipse territory at this stage - this is why we can't give you a simple answer!

  • OFWHMG
    OFWHMG
    36 Posts

    Re: Disappearing MQ Explorer Perspective

    ‏2013-11-12T13:47:48Z  

    Dave, I looked at the Features and Plug-ins tabs and could not find anything there specific to WebSphere MQ.  It looks like pretty low level stuff.  Could you give me a screen shot of what I should see there if WebSphere MQ Explorer is installed successfully?     

  • OFWHMG
    OFWHMG
    36 Posts

    Re: Disappearing MQ Explorer Perspective

    ‏2013-11-12T13:52:01Z  

    Dave, Do you have any documentation (or where documentation exists) on how I would use the "OSGI console"  to see plug-ins and start them?  Thank you. 

  • OFWHMG
    OFWHMG
    36 Posts

    Re: Disappearing MQ Explorer Perspective

    ‏2013-11-13T11:32:43Z  

    Hey never mind Dave.  I found a great article about using the OSGI console on developerworks!

  • DaveN
    DaveN
    80 Posts

    Re: Disappearing MQ Explorer Perspective

    ‏2013-11-13T12:10:15Z  
    • OFWHMG
    • ‏2013-11-13T11:32:43Z

    Hey never mind Dave.  I found a great article about using the OSGI console on developerworks!

    Ah sorry for the lack of reply. Yes - that's the article I would have pointed you at :-)

    http://www.ibm.com/developerworks/library/os-ecl-osgiconsole/

    When I have issues with things I install not being available in the GUI, if the features and plug-ins don't show up in the about dialog, I always have a look in the console. Often the plug-ins show as stopped, so I try starting them and maybe get a useful error message somewhere...!

  • OFWHMG
    OFWHMG
    36 Posts

    Re: Disappearing MQ Explorer Perspective

    ‏2013-11-13T16:44:13Z  

    Dave, I had quite a nice time using the OSGI console after reading that article.  I cannot find anything about MQ Explorer bundles when I do an ss command.  I also did not find anything about MQ Explorer in the features and plug-ins tabs as indicated in my first reply.  I think this means that MQ Explorer never got installed even though Help>About and installation indicates that it was!

    How do I proceed now to get the MQ Explorer installed?  

  • DaveN
    DaveN
    80 Posts

    Re: Disappearing MQ Explorer Perspective

    ‏2013-11-23T10:19:21Z  
    • OFWHMG
    • ‏2013-11-13T16:44:13Z

    Dave, I had quite a nice time using the OSGI console after reading that article.  I cannot find anything about MQ Explorer bundles when I do an ss command.  I also did not find anything about MQ Explorer in the features and plug-ins tabs as indicated in my first reply.  I think this means that MQ Explorer never got installed even though Help>About and installation indicates that it was!

    How do I proceed now to get the MQ Explorer installed?  

    Hey,

    Personally at this point I would uninstall and reinstall - it's not a problem we've been able to recreate here from the instructions you've given so it's quite likely just a one-off.

    If it does occur again, or you prefer to try and get your current install working then I think you would need to raise a PMR which we could investigate in a more structured fashion and try and get the Installation Manager team involved if necessary.

    Dave

  • OFWHMG
    OFWHMG
    36 Posts

    Re: Disappearing MQ Explorer Perspective

    ‏2013-11-25T14:16:00Z  
    • DaveN
    • ‏2013-11-23T10:19:21Z

    Hey,

    Personally at this point I would uninstall and reinstall - it's not a problem we've been able to recreate here from the instructions you've given so it's quite likely just a one-off.

    If it does occur again, or you prefer to try and get your current install working then I think you would need to raise a PMR which we could investigate in a more structured fashion and try and get the Installation Manager team involved if necessary.

    Dave

    Hey Dave, I am going to abandon my plans to use IM for rolling out the new z/OS Explorer with the CICS Explorer and MQ inside.  We are going to do everything with a P2 install and roll it out with Java Web Start.  You are helping me with that on another thread on this forum.  Thanks.