Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
4 replies Latest Post - ‏2013-09-03T22:51:49Z by Ratan_k00
Ratan_k00
Ratan_k00
50 Posts
ACCEPTED ANSWER

Pinned topic rcleartool issues

‏2013-09-03T15:35:05Z |

We have CCRC 8.0.1 web server running on Solaris and CTE 8.0.1.1 clients on Windows.                                                    
                                                                       
New one (CTE 8.0.1) that comes with installation (in %ProgramFiles(x86)%\IBM\RationalSDLC\clearcase\RemoteClient\) connects:                   
                                                                       
>rcleartool login -lname ABCD -password XXXXXXXX -server https://ccrc801-wan-server/ccrc                                         
You are successfully logged in as "ABCD" to server "https://ccrc801-wan-server/ccrc".       

New views created from CTE 8.0.1.1.                                
                                                                       
But update doesn't work:                                               
                                                                       
>rcleartool update -server https://ccrc801-wan-server/ccrc C:\Users\ABCD\ABCD_view_update_test                                  
Processing dir "".                                                     
End dir "".                                                            
Done Loading "".                                                       
                                                                       
It looks like path is not recognized by the server, and the reason is  
that copyarea is empty.                                                
                                                                       
=============================                                          
                                                                       
lsview was returning local path (C:\Users\ABCD\ABCD_view_update_test), but now it returns:            
                                                                       
>rcleartool lsview -server https://ccrc801-wan-server/ccrc ABCD_view_update_test                                                
                                                                       
ABCD_view_update_test                                                
/prj/vx/loc/vw04/webviews/ABCD/ABCD_view_update_test/.view.stg
 

  • benray
    benray
    74 Posts
    ACCEPTED ANSWER

    Re: rcleartool issues

    ‏2013-09-03T16:04:51Z  in response to Ratan_k00

    It does appear to have done some processing although the directory string is blank (""). What's in your config spec? In what working directory are you running the rcleartool commands? Does the same view load something in CTE?

    • Ratan_k00
      Ratan_k00
      50 Posts
      ACCEPTED ANSWER

      Re: rcleartool issues

      ‏2013-09-03T18:22:40Z  in response to benray

      Yes, update works .... only thing is that there is no string within quotes.

      Now, how to get the copy area path listed in rcleartool lsview command?

       

       

      • benray
        benray
        74 Posts
        ACCEPTED ANSWER

        Re: rcleartool issues

        ‏2013-09-03T18:31:50Z  in response to Ratan_k00

        The copy area path does not go into the registry and thus will not appear in lsview. For web views (similar to snapshot views) there is a list of copy areas in a user's home directory. For example

        [ben@hangar18 test1]$ cat /home/ben/.ccase_wvreg
        /home/ben/wp_proj1_int
        /home/ben/wp_proj1_dev
        /home/ben/ccrc_p1
        /home/ben/ccrc1
         

        Inside each copyarea is a .copyarea.dat file that references the view tag. The client reads this file and knows where your web views are located - this information is not available to other users.