Topic
3 replies Latest Post - ‏2013-05-08T03:55:28Z by LinhLe
LinhLe
LinhLe
8 Posts
ACCEPTED ANSWER

Pinned topic The Stagetype 'CDCTStagePX' cannot be found in the repository

‏2013-05-06T09:38:47Z |

Dear all,

I'm trying to Configure InfoSphere CDC with InfoSphere DataStage for real-time ETL, by following the guide in link http://www.ibm.com/developerworks/data/library/techarticle/dm-1203cdcdirectconnect/?ca=drs.

But, after export DataStage job definition and import into DataStage. When I'm tried to configure CDC Stage, I received the following error: The Stagetype 'CDCTStagePX' cannot be found in the repository. The screenshot show bellow:

 

Anyone guide me to solve this problem? It'll related to Installation or Configuration?

Thanks so much.

  • Anil_Abraham
    Anil_Abraham
    3 Posts
    ACCEPTED ANSWER

    Re: The Stagetype 'CDCTStagePX' cannot be found in the repository

    ‏2013-05-07T18:11:14Z  in response to LinhLe

    The Auto-start InfoSphere DataStage Job check box was disabled. When both InfoSphere CDC and InfoSphere Information Server for DataStage are installed on the same machine, this option is automatically enabled for the end-user to select this box. This might be disabled when an incorrect path is given. Please  check this criteria.

    IDR(CDC) Transaction stage looks different , If you have followed the link. 

  • GlenSakuth
    GlenSakuth
    66 Posts
    ACCEPTED ANSWER

    Re: The Stagetype 'CDCTStagePX' cannot be found in the repository

    ‏2013-05-07T18:15:28Z  in response to LinhLe

    It looks like the transaction stage of DataStage is not installed (or paths are not correct).  What version of DataStage are you using.  I know that the minimum level of DataStage was IS 8.5 and it required two patches (JR37451 and JR38113).

    • LinhLe
      LinhLe
      8 Posts
      ACCEPTED ANSWER

      Re: The Stagetype 'CDCTStagePX' cannot be found in the repository

      ‏2013-05-08T03:55:28Z  in response to GlenSakuth

      Thanks for your response.

      I saw that The CDC Transaction for DataStage not installed. We can install it or install IBM DataStage 8.5 fix pack 1 (I'm currently use IBM Infosphere DataStage 8.5).

       

      Thanks all.