IC SunsetThe developerWorks Connections Platform is now in read-only mode and content is only available for viewing. No new wiki pages, posts, or messages may be added. Please see our FAQ for more information. The developerWorks Connections platform will officially shut down on March 31, 2020 and content will no longer be available. More details available on our FAQ. (Read in Japanese.)
Topic
  • 1 reply
  • Latest Post - ‏2018-02-15T09:36:04Z by bayliss
bayliss
bayliss
36 Posts

Pinned topic CWPKI0817A The defaultKeyStore <keyStore> element is missing.

‏2018-02-05T11:14:21Z | zosconnect

From the January 2018 open beta, if you do not configure SSL in your z/OS Connect EE server you will see the following audit message during server start up: 

 

CWPKI0817A: The default SSL configuration expects a <keyStore> element with an id value of defaultKeyStore, and a password. The defaultKeyStore <keyStore> element is missing, or the password is not specified. Either define the missing element: <keyStore id="defaultKeyStore" password="yourpassword" />, or change the default SSL configuration to use an existing keystore. See the following example: <ssl id="defaultSSLConfig" keyStoreRef="newKeyStore" />.


Regards, Sue

Updated on 2018-02-15T09:35:45Z at 2018-02-15T09:35:45Z by bayliss
  • bayliss
    bayliss
    36 Posts
    ACCEPTED ANSWER

    Re: CWPKI0817A The defaultKeyStore <keyStore> element is missing.

    ‏2018-02-15T09:36:04Z  
     

    If you do not require SSL (and did not intend to configure SSL), you can safely ignore this message.

     

    If you do require SSL, then review and correct your SSL configuration in server.xml.

     

    FYI: This audit message was introduced in the IBM WebSphere Application Server - Liberty Profile 17.0.0.4, which has been embedded in the January 2018 z/OS Connect EE open beta. When you specify the <feature>zosconnect:zosConnect-2.0</feature> in server.xml, it automatically loads the ssl Liberty feature. If the ssl Liberty feature is loaded, an attempt is made to initialize SSL. But this will fail, if the required SSL configuration elements are missing from server.xml. The CWPKI0817A message has been added (in response to the OpenLiberty issue #474) to indicate the reason for the failure.

     

    Regards, Sue

  • bayliss
    bayliss
    36 Posts

    Re: CWPKI0817A The defaultKeyStore <keyStore> element is missing.

    ‏2018-02-15T09:36:04Z  
     

    If you do not require SSL (and did not intend to configure SSL), you can safely ignore this message.

     

    If you do require SSL, then review and correct your SSL configuration in server.xml.

     

    FYI: This audit message was introduced in the IBM WebSphere Application Server - Liberty Profile 17.0.0.4, which has been embedded in the January 2018 z/OS Connect EE open beta. When you specify the <feature>zosconnect:zosConnect-2.0</feature> in server.xml, it automatically loads the ssl Liberty feature. If the ssl Liberty feature is loaded, an attempt is made to initialize SSL. But this will fail, if the required SSL configuration elements are missing from server.xml. The CWPKI0817A message has been added (in response to the OpenLiberty issue #474) to indicate the reason for the failure.

     

    Regards, Sue