Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
4 replies Latest Post - ‏2013-10-18T13:54:36Z by Abish
hadi92
hadi92
2 Posts
ACCEPTED ANSWER

Pinned topic Can not follow requirement links even with calmlinks set to true

‏2013-10-14T12:28:24Z |

Hi,

I'm using RM 4.0.2, RQM 4.0.2, with RPE 1.2.

I'm trying to generate a report that inspect the following data model:

Test Plan -> Test Suite -> Test Case -> Requirement

I am blocked in the last part of that report. I can not follow the link between the Test Case and the Requirement even when I set the calmlinks parameter to true.

Find attached the RPE template. Can somemone explain me how to follow these links?

 

Attachments

  • Dragos.Cojocari
    Dragos.Cojocari
    1608 Posts
    ACCEPTED ANSWER

    Re: Can not follow requirement links even with calmlinks set to true

    ‏2013-10-14T13:23:29Z  in response to hadi92

    Hey,

     

    this should help: http://rpeactual.com/2013/03/08/clm-traceability-with-rpe/

     

    Regards,

        Dragos

  • hadi92
    hadi92
    2 Posts
    ACCEPTED ANSWER

    Re: Can not follow requirement links even with calmlinks set to true

    ‏2013-10-14T14:09:40Z  in response to hadi92

    Tx for your answer,  but I am still facing the issue in my specific case.

    I have successfuly  made antoher template; which follows TestPlan -> TestCase -> Requirement.

    But, In the attached file, the issue is not about following the link. It is that I can not even print the  testcase->requirement.href property.

     

    It seems that I have the issue when I add the TestSuite level between TestPlan and TestCase as described in my first post.

     

    • Dragos.Cojocari
      Dragos.Cojocari
      1608 Posts
      ACCEPTED ANSWER

      Re: Can not follow requirement links even with calmlinks set to true

      ‏2013-10-18T13:35:13Z  in response to hadi92

      Hey Hadi,

       

      It's possible that the schema for the TestCase object under TestSuite to be different from the TestCase one under TestPlan. But my knowledge of RQM's API is not very detailed so I recommend checking the RQM's Reportable REST API Wiki and also raising this question on the RQM Jazz.net forum.

       

      Regards,

         Dragos

      • Abish
        Abish
        3 Posts
        ACCEPTED ANSWER

        Re: Can not follow requirement links even with calmlinks set to true

        ‏2013-10-18T13:54:36Z  in response to Dragos.Cojocari

        Hi Hadi

        I am updating this thread as you have also raised a support request on this issue. I have attached a sample template "Support_rqmFollowValidateLinks.dta" for your reference. Using this template I am able to extract the Title of a linked Requirement of a Test Case, which is a part of a Test Suite.

        In your template, the schema that is loaded is of type REST V2 and not REST. I am not sure if RQM OSLC API is reportable enough to contain all this required information. Also the base URL that you have provided in the specification file was of type REST. This could be the reason why the data has not retuned.

        If you look at the schema in the attached template, they are all of type "REST".  I am also attaching the DSX file for your reference. Please try this in your environment and let me know if this helps.

        Best Regards
        Abish M Zachariah