Topic
2 replies Latest Post - ‏2013-10-02T20:39:38Z by linda_pontremoli
linda_pontremoli
linda_pontremoli
3 Posts
ACCEPTED ANSWER

Pinned topic Does CICS Explorer SDK 5.1.1. is supported under Eclipse IDE Kepler 4.3.0. version?

‏2013-10-01T20:54:34Z |

CICS Explorer SDK v5.1.1 has been installed under ECLIPSE IDE for JAVA Kepler version,

but when RESOURCE or CICS SM perspective are choosen sometimes some errors, showed below, are issued.

So, the question is: does CICS Explorer SDK 5.1.1. is supported under Eclipse IDE Kepler (4.3.0) version?

At site http://www-01.ibm.com/support/docview.wss?uid=swg24033579#plus

is stated: ' CICS Explorer Update your Eclipse IDE to release 4.2.2, or later2

So I would expect that Kepler 4.3.0 is supported, but here following the errors we get:

Environment:

eclipse.buildId=4.3.0.I20130605-2000
java.version=1.7.0_40
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments:  -product org.eclipse.epp.package.jee.product
Command-line arguments:  -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.jee.product

when CICS SM perpsective is choosen, here folowing the error issued:
Error
Mon Sep 30 17:28:22 CEST 2013
An internal error occurred during: "Decoration Calculation".

java.lang.NullPointerException
        at com.ibm.cics.core.ui.properties.CICSObjectPropertySource.<init>(CICSObjectPropertySource.java:34)
        at com.ibm.cics.core.ui.adapters.ActionFilterAdapterFactory$1.attributeExistsFor(ActionFilterAdapterFactory.java:154)
        at com.ibm.cics.core.ui.adapters.ActionFilterAdapterFactory$1.testAttribute(ActionFilterAdapterFactory.java:143)
        at org.eclipse.ui.internal.ActionExpression$ObjectStateExpression.preciselyMatches(ActionExpression.java:530)
        at org.eclipse.ui.internal.ActionExpression$ObjectStateExpression.isEnabledFor(ActionExpression.java:499)
        at org.eclipse.ui.internal.ActionExpression$SingleExpression.isEnabledFor(ActionExpression.java:743)
        at org.eclipse.ui.internal.ActionExpression.isEnabledFor(ActionExpression.java:1053)
        at org.eclipse.ui.internal.decorators.DecoratorDefinition.isEnabledFor(DecoratorDefinition.java:281)
        at org.eclipse.ui.internal.decorators.DecoratorManager.getDecoratorsFor(DecoratorManager.java:382)
        at org.eclipse.ui.internal.decorators.LightweightDecoratorManager.getDecoratorsFor(LightweightDecoratorManager.java:315)
        at org.eclipse.ui.internal.decorators.LightweightDecoratorManager.getDecorations(LightweightDecoratorManager.java:340)
        at org.eclipse.ui.internal.decorators.DecorationScheduler$1.ensureResultCached(DecorationScheduler.java:371)
        at org.eclipse.ui.internal.decorators.DecorationScheduler$1.run(DecorationScheduler.java:331)
        at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)
 

When RESOURCE perspective is choosen following errors are detected:

null Error
Tue Oct 01 16:36:29 CEST 2013
Problems occurred when invoking code from plug-in: "org.eclipse.ui.workbench".

java.lang.ClassCastException: java.lang.Object cannot be cast to java.lang.String
        at com.ibm.cics.core.connections.internal.ConnectionTrimWidget$1.sourceChanged(ConnectionTrimWidget.java:42)
        at org.eclipse.ui.AbstractSourceProvider.fireSourceChanged(AbstractSourceProvider.java:69)
        at com.ibm.cics.core.connections.internal.ConnectionTrimWidgetCategorySource.updateActiveCategory(ConnectionTrimWidgetCategorySource.java:135)
        at com.ibm.cics.core.connections.internal.ConnectionTrimWidgetCategorySource.access$0(ConnectionTrimWidgetCategorySource.java:131)
        at com.ibm.cics.core.connections.internal.ConnectionTrimWidgetCategorySource$1.partDeactivated(ConnectionTrimWidgetCategorySource.java:78)
        at org.eclipse.ui.internal.PartService$9.run(PartService.java:164)
        at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
        at org.eclipse.ui.internal.PartService.partDeactivated(PartService.java:162)
        at org.eclipse.ui.internal.WorkbenchPage$17.run(WorkbenchPage.java:4822)
        at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
        at org.eclipse.ui.internal.WorkbenchPage.firePartDeactivated(WorkbenchPage.java:4820)
        at org.eclipse.ui.internal.WorkbenchPage.access$18(WorkbenchPage.java:4805)
        at org.eclipse.ui.internal.WorkbenchPage$E4PartListener.partDeactivated(WorkbenchPage.java:204)
        at org.eclipse.e4.ui.internal.workbench.PartServiceImpl$3.run(PartServiceImpl.java:197)
        at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
        at org.eclipse.e4.ui.internal.workbench.PartServiceImpl.firePartDeactivated(PartServiceImpl.java:195)
        at org.eclipse.e4.ui.internal.workbench.PartServiceImpl.activate(PartServiceImpl.java:574)
        at org.eclipse.e4.ui.internal.workbench.PartServiceImpl.switchPerspective(PartServiceImpl.java:515)
        at org.eclipse.e4.ui.workbench.renderers.swt.PerspectiveStackRenderer.showTab(PerspectiveStackRenderer.java:124)
        at org.eclipse.e4.ui.workbench.renderers.swt.LazyStackRenderer$1.handleEvent(LazyStackRenderer.java:66)
        at org.eclipse.e4.ui.services.internal.events.UIEventHandler$1.run(UIEventHandler.java:41)
        at org.eclipse.swt.widgets.Synchronizer.syncExec(Synchronizer.java:180)
        at org.eclipse.ui.internal.UISynchronizer.syncExec(UISynchronizer.java:150)
        at org.eclipse.swt.widgets.Display.syncExec(Display.java:4688)
        at org.eclipse.e4.ui.internal.workbench.swt.E4Application$1.syncExec(E4Application.java:205)
        at org.eclipse.e4.ui.services.internal.events.UIEventHandler.handleEvent(UIEventHandler.java:38)
        at org.eclipse.equinox.internal.event.EventHandlerWrapper.handleEvent(EventHandlerWrapper.java:197)
        at org.eclipse.equinox.internal.event.EventHandlerTracker.dispatchEvent(EventHandlerTracker.java:197)
        at org.eclipse.equinox.internal.event.EventHandlerTracker.dispatchEvent(EventHandlerTracker.java:1)
        at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
        at org.eclipse.osgi.framework.eventmgr.ListenerQueue.dispatchEventSynchronous(ListenerQueue.java:148)
        at org.eclipse.equinox.internal.event.EventAdminImpl.dispatchEvent(EventAdminImpl.java:135)
        at org.eclipse.equinox.internal.event.EventAdminImpl.sendEvent(EventAdminImpl.java:78)
        at org.eclipse.equinox.internal.event.EventComponent.sendEvent(EventComponent.java:39)
        at org.eclipse.e4.ui.services.internal.events.EventBroker.send(EventBroker.java:80)
        at org.eclipse.e4.ui.internal.workbench.UIEventPublisher.notifyChanged(UIEventPublisher.java:58)
        at org.eclipse.emf.common.notify.impl.BasicNotifierImpl.eNotify(BasicNotifierImpl.java:374)
        at org.eclipse.e4.ui.model.application.ui.advanced.impl.PerspectiveStackImpl.setSelectedElement(PerspectiveStackImpl.java:135)
        at org.eclipse.e4.ui.model.application.ui.advanced.impl.PerspectiveStackImpl.setSelectedElement(PerspectiveStackImpl.java:1)
        at org.eclipse.e4.ui.workbench.addons.perspectiveswitcher.PerspectiveSwitcher$13.widgetSelected(PerspectiveSwitcher.java:439)
        at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:248)
        at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
        at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1057)
        at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4170)
        at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3759)
        at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.java:1113)
        at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
        at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:997)
        at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:138)
        at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:610)
        at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
        at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:567)
        at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
        at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:124)
        at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:354)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:181)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.lang.reflect.Method.invoke(Unknown Source)
        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:636)
        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:591)
        at org.eclipse.equinox.launcher.Main.run(Main.java:1450)
 

Many thanks in advance for any clarification you would kindly provide.

Kind regards, Linda

  • StevenHorsman
    StevenHorsman
    1 Post
    ACCEPTED ANSWER

    Re: Does CICS Explorer SDK 5.1.1. is supported under Eclipse IDE Kepler 4.3.0. version?

    ‏2013-10-02T09:24:39Z  in response to linda_pontremoli

    Hi Linda,

    The short answer is no, Kepler is not supported. If you look at footnote 2 it says "The supported release of Eclipse IDE for Java EE Developers is Juno (4.2.2).", but I agree that "CICS Explorer Update your Eclipse IDE to release 4.2.2, or later2 " is not very clear, so I'll have a chat to the webpage owners and see if we can improve this.

    Let us know if you have a direct requirement for Kepler and we can advise you are how to raise that request against us.

    Steven

    • linda_pontremoli
      linda_pontremoli
      3 Posts
      ACCEPTED ANSWER

      Re: Does CICS Explorer SDK 5.1.1. is supported under Eclipse IDE Kepler 4.3.0. version?

      ‏2013-10-02T20:39:38Z  in response to StevenHorsman

      Many thanks for the clarification Steven,

      it is ok for me and the customer to install Juno, no particular need to have Kepler.

      Kind regards,

      Linda