Topic
  • 7 replies
  • Latest Post - ‏2014-05-15T05:47:40Z by Vasya_Terkin
Vasya_Terkin
Vasya_Terkin
9 Posts

Pinned topic Missing image in active report. IIS 7. Windows Authenticating.

‏2013-12-10T13:55:15Z |
Hello everyone! Please, explain to me, where is the problem.
I have missing pictures trouble only in my active reports.
 
I can use every pictures from my virtual directory "pic" everywhere:
 in Cognos Connection Portal, in Report Studio and so on.
But if I run active report, there is missing pictures.
If I set anonymous authentication enabled on "pic" virtual directory, pictures apper.
I came to the following conclusions:
1) there is some more folder permission on "pic" directory needed.
2) WebDav works in active reports only with anonymous authentication. Is it bug?
3) There is some problems with authentication in active reports.
 
Please, tell me, that I'm right only in (1). What folder permissions is needed?
 
Virtual directory "pic" located in mySite/cognos/pic, and configured as:
1) WebDav is enabled. There is the WebDav rule ("read" to all users) on the "pic" directory. 
2) Authentication: "Windows authentication", NTLM.
3) Folder permissions: "full" to Application Pool, system and all domain users.
Information about my system described below.
My Cognos 10.2 BI components located on my Windows PC included in Active Directory Domain.
I've configured everything.
Web server is IIS 7, Application Pool Identity, Windows Authentication, using NTLM.
Every cognos user has a "read" (and "execute" in some cases) permissions on every needed directories and virtual directories.
Application Pool has full access to all directories and virtual directories.
Cognos configuration: ISAPI, AD, Cognos Content Store.
Thanks!

 

  • Mehdi R
    Mehdi R
    4 Posts

    Re: Missing image in active report. IIS 7. Windows Authenticating.

    ‏2014-01-20T10:58:08Z  

    Hi,

    I'm facing to the same issue for the images in active reports

    Did you fix it?

    Regards,

    Mehdi

  • Vasya_Terkin
    Vasya_Terkin
    9 Posts

    Re: Missing image in active report. IIS 7. Windows Authenticating.

    ‏2014-01-22T07:28:53Z  
    • Mehdi R
    • ‏2014-01-20T10:58:08Z

    Hi,

    I'm facing to the same issue for the images in active reports

    Did you fix it?

    Regards,

    Mehdi

    Hi!

    Unfortunately, I didn't fix it.

    For now I'm using anonymous authentication enabled on "pic" virtual directory.

    Somebody help us, please?

    Updated on 2014-01-22T07:29:06Z at 2014-01-22T07:29:06Z by Vasya_Terkin
  • neni
    neni
    4 Posts

    Re: Missing image in active report. IIS 7. Windows Authenticating.

    ‏2014-01-27T20:18:58Z  

    Hi!

    Unfortunately, I didn't fix it.

    For now I'm using anonymous authentication enabled on "pic" virtual directory.

    Somebody help us, please?

    please try placing the images on your application server in "webcontent\samples\images"

  • neni
    neni
    4 Posts

    Re: Missing image in active report. IIS 7. Windows Authenticating.

    ‏2014-02-04T18:46:14Z  
    • neni
    • ‏2014-01-27T20:18:58Z

    please try placing the images on your application server in "webcontent\samples\images"

    Vasya_terkin, Did you try this option, if yes, then please share the results.

  • TimTam18
    TimTam18
    11 Posts

    Re: Missing image in active report. IIS 7. Windows Authenticating.

    ‏2014-02-07T03:44:06Z  

    Hi  - I had a similar issue some time ago, logged a PMR to IBM and get it resolved finally. This is an extract from the email chain:

    i. IBM's suggestion: Install WebDAV Publishing Role Service & enable WebDAV Autoring Rules to Enable the service. <<  My comment: I also reckon this is more to allow Authors to browse, view and modify images in the "Image" folder via a HTTP interface. A "nice to have" feature but not a must.

    ii. IBM's suggestion: Configure IIS Web Service Authentication for Anonymous user read access to the Cognos virtual directory images folder. << My comment: The "Anonymous Authentication" featured should be enabled, but only at the immediate folder hosting the image (e.g. http://servername/cognos/images or http://servername/cognos/samples/images ). It should NOT be enabled right at the Cognos virtual directory (e.g. http://servername/cognos ) because this will disable single sign-on and violates the recommended setting as per this guide (see the WebDAV section) 

     

    You can also refer to this Proven Practice document, especially the WebDAV section, for further details:
     

    Hope it helps,

    TT

  • Vasya_Terkin
    Vasya_Terkin
    9 Posts

    Re: Missing image in active report. IIS 7. Windows Authenticating.

    ‏2014-04-11T13:21:11Z  
    • TimTam18
    • ‏2014-02-07T03:44:06Z

    Hi  - I had a similar issue some time ago, logged a PMR to IBM and get it resolved finally. This is an extract from the email chain:

    i. IBM's suggestion: Install WebDAV Publishing Role Service & enable WebDAV Autoring Rules to Enable the service. <<  My comment: I also reckon this is more to allow Authors to browse, view and modify images in the "Image" folder via a HTTP interface. A "nice to have" feature but not a must.

    ii. IBM's suggestion: Configure IIS Web Service Authentication for Anonymous user read access to the Cognos virtual directory images folder. << My comment: The "Anonymous Authentication" featured should be enabled, but only at the immediate folder hosting the image (e.g. http://servername/cognos/images or http://servername/cognos/samples/images ). It should NOT be enabled right at the Cognos virtual directory (e.g. http://servername/cognos ) because this will disable single sign-on and violates the recommended setting as per this guide (see the WebDAV section) 

     

    You can also refer to this Proven Practice document, especially the WebDAV section, for further details:
     

    Hope it helps,

    TT

    Hello TimTam18!

    As I said: 

    1) WebDav is enabled on my site. There is the WebDav rule ("read" to all users) on the "pic" directory. 
    2) Authentication: "Windows authentication", NTLM.
    3) Folder permissions: "full" to Application Pool, system and all domain users.

    Configure IIS Web Service Authentication for Anonymous user read access to the Cognos virtual directory images folder

    If I do this, then Anonimous user can enter to "http://host/cognos/pic" and can see any pictures.

    I want that only authorized users may see these pictures.

    Anonimous access is not appropriate.

  • Vasya_Terkin
    Vasya_Terkin
    9 Posts

    Re: Missing image in active report. IIS 7. Windows Authenticating.

    ‏2014-05-15T05:47:40Z  
    • neni
    • ‏2014-02-04T18:46:14Z

    Vasya_terkin, Did you try this option, if yes, then please share the results.

    Hello, neni! Yes, it works!
    But only when I insert relative URL "../samples/images/picture1234.png" as image URL in active report.
     i.e. image <effective_URL> = <COG_ROOT>/bin/../webcontent/<dummy>/samples/images/picture1234.png
     = <COG_ROOT>/webcontent/samples/images/picture1234.png
    When I insert absolute URL: "http://host/cognos/pic/s_images/picture1234.png and run report, this picture is missing.
    When I insert absolute URL in browser address bar, I can see this picture (after passing windows authentication).
    As a result it's impossible to find image by virtual path if absolute URL doesn't work.
     
    When I allow anonymous authentication on the folder where the picture located, the picture appears in the active report.
    Does anyone know why this happens? Please, help.
     
    Here is a document that explains how the search of images works based on the image URL syntax:
     
    Info:
    <COG_ROOT> = D:\cognos64\
    Physical path to the picture: D:\cognos64\webcontent\samples\images\picture1234.png
    Virtual path to the picture: http://host/cognos/pic/s_images/picture1234.png
     "cognos", "pic" and "s_images" are virtual directories:
     "cognos" = D:\cognos64\webcontent
     "pic" = D:\cognos_website\wwwroot\pic\
     "s_images" = D:\cognos64\webcontent\samples\images\
     
    I've tried to place the picture everywhere,
     but it can't be found by absolute URL in active reports,
     until I allow anonymous acces to the folder containing this picture.