IC SunsetThe developerWorks Connections platform will be sunset on December 31, 2019. On January 1, 2020, this community and its apps will no longer be available. More details available on our FAQ.
Topic
  • 7 replies
  • Latest Post - ‏2019-08-24T08:30:23Z by Mike.Scharnow
DoorsXLAustralia
DoorsXLAustralia
49 Posts

Pinned topic DOORS 9.7 FLEXnet licensing error:-25,147

‏2019-08-14T16:57:46Z |

I installed DOORS 9.7

I also installed RLKS 8.1.2 which includes FlexLM 11.8

I configured the Flex server to serve the license file which I had previously been using for DOORS 9.6.1.8 on the same machine (also served by FlexLM 11.8)

The diagnostics indicates that FlexLM is serving 3 DOORS licenses

>>>>>Users of DOORS:  (Total of 3 licenses issued;  Total of 0 licenses in use)

But when I run the DOORS client I get the following error:-

  License server system does not support this version of this feature
  DOORS
  27000@localhost
  FLEXnet licensing error:-25,147

Do I need a newer version of Flex to serve the same license to 9.7 or do I need a new license file?

  • Mike.Scharnow
    Mike.Scharnow
    23 Posts

    Re: DOORS 9.7 FLEXnet licensing error:-25,147

    ‏2019-08-15T10:45:28Z  

    Have not seen this before. For comparison: I work with RLKS 8.1.4, the version in our license file says.INCREMENT DOORS telelogic 2020.0201 21-feb-2020 

     

    The software compatibilty report for DOORS 9.7 is not yet available, but the one for 9.6.1.11 (https://www.ibm.com/software/reports/compatibility/clarity-reports/report/html/softwareReqsForProduct?deliverableId=AA494B70E87411E7974C181B76870538&osPlatforms=Linux|Windows&duComponentIds=D000|S000&mandatoryCapIds=25&optionalCapIds=73|36|186|223) says that any RLKS Version >= 8.0 is fine, I don't think this changed with DOORS 9.7.

    So, it is rather likely that your license file needs to be regenerated.

     

    Hope this helps,
    Mike

  • DoorsXLAustralia
    DoorsXLAustralia
    49 Posts

    Re: DOORS 9.7 FLEXnet licensing error:-25,147

    ‏2019-08-15T17:03:16Z  

    Have not seen this before. For comparison: I work with RLKS 8.1.4, the version in our license file says.INCREMENT DOORS telelogic 2020.0201 21-feb-2020 

     

    The software compatibilty report for DOORS 9.7 is not yet available, but the one for 9.6.1.11 (https://www.ibm.com/software/reports/compatibility/clarity-reports/report/html/softwareReqsForProduct?deliverableId=AA494B70E87411E7974C181B76870538&osPlatforms=Linux|Windows&duComponentIds=D000|S000&mandatoryCapIds=25&optionalCapIds=73|36|186|223) says that any RLKS Version >= 8.0 is fine, I don't think this changed with DOORS 9.7.

    So, it is rather likely that your license file needs to be regenerated.

     

    Hope this helps,
    Mike

    ^Thanks Mike

    Are you running DOORS 9.7?

    When you run the FlexLM version that comes with RLKS 8.1.4 and open >Help>About does it say 11.8 or some newer version?

  • Mike.Scharnow
    Mike.Scharnow
    23 Posts

    Re: DOORS 9.7 FLEXnet licensing error:-25,147

    ‏2019-08-15T18:39:34Z  

    ^Thanks Mike

    Are you running DOORS 9.7?

    When you run the FlexLM version that comes with RLKS 8.1.4 and open >Help>About does it say 11.8 or some newer version?

    meh, stupid spam prevention mechanisms... 8th attempt..

    Yes, we currently evaluate DOORS 9,7.
    Help->About does not say anything about RLKS, but I get the following information from the programs directly
    c:\Program Files (x86)\IBM\RationalRLKS\common>lmgrd -version
    lmgrd v11.10.0.3 build 96515 i86_n3 - Copyright (c) 1988-2011 Flexera Software, Inc. All Rights Reserved.

    c:\Program Files (x86)\IBM\RationalRLKS\common>ibmratl
    20:36:01 (ibmratl) FLEXnet Licensing version v11.10.0.3 build 96515 i86_n3

    Updated on 2019-08-18T08:40:46Z at 2019-08-18T08:40:46Z by Mike.Scharnow
  • Mike.Scharnow
    Mike.Scharnow
    23 Posts

    Re: DOORS 9.7 FLEXnet licensing error:-25,147

    ‏2019-08-18T08:39:18Z  

    meh, stupid spam prevention mechanisms... 8th attempt..

    Yes, we currently evaluate DOORS 9,7.
    Help->About does not say anything about RLKS, but I get the following information from the programs directly
    c:\Program Files (x86)\IBM\RationalRLKS\common>lmgrd -version
    lmgrd v11.10.0.3 build 96515 i86_n3 - Copyright (c) 1988-2011 Flexera Software, Inc. All Rights Reserved.

    c:\Program Files (x86)\IBM\RationalRLKS\common>ibmratl
    20:36:01 (ibmratl) FLEXnet Licensing version v11.10.0.3 build 96515 i86_n3

    Yes, we currently evaluate DOORS 9,7. Help->About does not say anything about RLKS, but I get the following information from the programs directly c:\Program Files (x86)\IBM\RationalRLKS\common>lmgrd -version lmgrd v11.10.0.3 build 96515 i86_n3 - Copyright (c) 1988-2011 Flexera Software, Inc. All Rights Reserved. c:\Program Files (x86)\IBM\RationalRLKS\common>ibmratl 20:36:01 (ibmratl) FLEXnet Licensing version v11.10.0.3 build 96515 i86_n3
  • DoorsXLAustralia
    DoorsXLAustralia
    49 Posts

    Re: DOORS 9.7 FLEXnet licensing error:-25,147

    ‏2019-08-22T17:59:37Z  

    ^Thanks Mike.

    I decided to try and upgrade to a newer RLKS (and FlexLM)

    I tried 8.1.4 64 bit but at the very end of the installation i got

    Error during "install" phase:

    Plug-in "com.ibm.cic.agent.core.nativeInstallAdapter.win32" was unable to instantiate class "com.ibm.cic.agent.internal.adapters.nativeAdapter.win32.WinPlatformOperationsProvider".

    I then tried 8.1.4 32 bit

    same error

    I then tried 8.1.5 64 bit

    same error

    I then tried 8.1.5 32 bit

    same error

    Seems that the only RLKS I can install is 8.1.2

     

    Googling the error brings up a technote on 8.1.2 oddly

    https://www-01.ibm.com/support/docview.wss?uid=swg21607521

    So i will try and investigate these technote suggestions further

  • DoorsXLAustralia
    DoorsXLAustralia
    49 Posts

    Re: DOORS 9.7 FLEXnet licensing error:-25,147

    ‏2019-08-23T16:28:15Z  

    I managed to get rid of the error

    Plug-in "com.ibm.cic.agent.core.nativeInstallAdapter.win32" was unable to instantiate class "com.ibm.cic.agent.internal.adapters.nativeAdapter.win32.WinPlatformOperationsProvider".

    by shortening the installation path

    The directory structure was too deeply nested.

    But with RLKS 8.1.4 installed and serving the license correctly I still got the same error when trying to launch the DOORS 9.7 client.

    License server system does not support this version of this feature
      DOORS
      27000@localhost
      FLEXnet licensing error:-25,147

    I then tried uninstalling and reinstalling 9.6.1.8 and that worked fine.

    So it looks like DOORS 9.7 does not work with some older license files that are OK for 9.6.x

    I guess the license will need regenerated to run 9.7

     

    Updated on 2019-08-23T16:29:29Z at 2019-08-23T16:29:29Z by DoorsXLAustralia
  • Mike.Scharnow
    Mike.Scharnow
    23 Posts

    Re: DOORS 9.7 FLEXnet licensing error:-25,147

    ‏2019-08-24T08:30:23Z  

    I managed to get rid of the error

    Plug-in "com.ibm.cic.agent.core.nativeInstallAdapter.win32" was unable to instantiate class "com.ibm.cic.agent.internal.adapters.nativeAdapter.win32.WinPlatformOperationsProvider".

    by shortening the installation path

    The directory structure was too deeply nested.

    But with RLKS 8.1.4 installed and serving the license correctly I still got the same error when trying to launch the DOORS 9.7 client.

    License server system does not support this version of this feature
      DOORS
      27000@localhost
      FLEXnet licensing error:-25,147

    I then tried uninstalling and reinstalling 9.6.1.8 and that worked fine.

    So it looks like DOORS 9.7 does not work with some older license files that are OK for 9.6.x

    I guess the license will need regenerated to run 9.7

     

    Thank you for the update. Yes, it seems that this will be the solution.